Bug 518939 - BUG warning when adding new printer
Summary: BUG warning when adding new printer
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: beta
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Martin Jenner
URL:
Whiteboard:
: 472261 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-24 09:25 UTC by Tomas Pelka
Modified: 2009-10-26 12:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-26 12:25:37 UTC


Attachments (Terms of Use)

Description Tomas Pelka 2009-08-24 09:25:30 UTC
Description of problem:
Kerneloops appears when I'm adding a new printer through system-config-printer (s-c-p). Cups-pk-helper installed.

Version-Release number of selected component (if applicable):
cups-1.4-0.b2.18.fc11.x86_64
bluez-cups-4.37-1.fc11.x86_64
libgnomecups-0.2.3-5.fc11.x86_64
hal-cups-utils-0.6.19-2.fc11.x86_64
cups-pk-helper-0.0.4-1.fc11.x86_64
cups-libs-1.4-0.b2.18.fc11.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Run s-c-p.
2. Add new printer.
3. Enter valid root password.
  
Actual results:
Kerneloops appears right after successful authentication. 

WARNING: at kernel/sysctl.c:2058 unregister_sysctl_table+0xc7/0xfc() (Tainted: G        W )
Hardware name: Precision WorkStation T5400  
Modules linked in: lp fuse sco bridge stp llc bnep l2cap bluetooth sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 dm_multipath uinput snd_hda_codec_analog snd_hda_intel snd_hda_codec i5k_amb hwmon snd_hwdep snd_pcm snd_timer snd iTCO_wdt iTCO_vendor_support soundcore snd_page_alloc i5400_edac ppdev edac_core parport_pc ata_generic parport pata_acpi serio_raw pcspkr ata_piix i2c_i801 tg3 dcdbas shpchp ahci nouveau drm i2c_algo_bit i2c_core [last unloaded: freq_table]
Pid: 18530, comm: python Tainted: G        W  2.6.29.4-1.el6.x86_64 #1
Call Trace:
 [<ffffffff81048fcb>] warn_slowpath+0xbc/0xf0
 [<ffffffff81301c9c>] ? sock_sendmsg+0xcc/0xe5
 [<ffffffff81184d87>] ? avc_has_perm+0x5c/0x71
 [<ffffffffa01253af>] ? parport_release+0xaa/0x164 [parport]
 [<ffffffff81184d87>] ? avc_has_perm+0x5c/0x71
 [<ffffffff81050676>] unregister_sysctl_table+0xc7/0xfc
 [<ffffffffa01278ad>] parport_device_proc_unregister+0x2d/0x3b [parport]
 [<ffffffffa0125ad0>] parport_unregister_device+0x14/0x131 [parport]
 [<ffffffffa01581b1>] pp_release+0x11c/0x14e [ppdev]
 [<ffffffff810d8684>] __fput+0xf9/0x1a0
 [<ffffffff810d8745>] fput+0x1a/0x1c
 [<ffffffff810d5a85>] filp_close+0x68/0x72
 [<ffffffff810d5b3b>] sys_close+0xac/0xea
 [<ffffffff8101142a>] system_call_fastpath+0x16/0x1b

See http://www.kerneloops.org/submitresult.php?number=657152

Expected results:
Kerneloops should not appear.

Additional info:
Seems that oops have no impact to cups or whole system.

Comment 1 RHEL Product and Program Management 2009-08-24 09:35:28 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Tim Waugh 2009-08-24 10:23:44 UTC
Kernel problem.

Comment 3 Prarit Bhargava 2009-10-23 19:00:59 UTC
Not an oops.

P.

Comment 4 Prarit Bhargava 2009-10-23 19:37:59 UTC
Tomas, silly question -- but are you actually using a parallel port printer or a USB printer?

P.

Comment 5 Tomas Pelka 2009-10-26 09:44:36 UTC
(In reply to comment #4)
> Tomas, silly question -- but are you actually using a parallel port printer or
> a USB printer?
> 
> P.  

Not silly. Actually I'm using a network printer (through socket).

Now I'm using RHEL6.0-20091021.0, kernel 2.6.31-31.el6.x86_64 and WARNINGs disappeard.

Comment 6 Prarit Bhargava 2009-10-26 12:26:41 UTC
*** Bug 472261 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.