This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 518965 - CDROM boot failure code : 0003
CDROM boot failure code : 0003
Status: CLOSED DUPLICATE of bug 517151
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-24 08:11 EDT by Tim Waugh
Modified: 2009-08-26 11:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-26 11:30:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
F11.log (602 bytes, text/plain)
2009-08-26 11:22 EDT, Tim Waugh
no flags Details
F11.xml (1.70 KB, text/plain)
2009-08-26 11:22 EDT, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2009-08-24 08:11:05 EDT
Description of problem:
I cannot get a virtual guest to boot from a CD-ROM ISO image.

Version-Release number of selected component (if applicable):
libvirt-0.7.0-6.fc12.x86_64
qemu-0.10.91-0.8.rc1.fc12.x86_64
qemu-system-x86-0.10.91-0.8.rc1.fc12.x86_64
virt-manager-0.8.0-2.fc12.noarch
kernel-2.6.31-0.167.rc6.git6.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Clean install of packages (yum install virt-manager)
2.Run virt-manager
3.Set up a new Fedora 11 guest from qemu:qemu-owned Fedora-11-x86_64-DVD.iso

i.e. click New, fill in name as F11, select Local install media, click Forward
Select Use ISO image, Browse, Browse Local, select Fedora-11-x86_64-DVD.iso
OS Type: Linux, Version: Fedora 11, Forward
Memory (RAM): 1024Mb, Forward
Enable storage for this virtual machine
Create a disk image on the computer's hard driver
1Gb, don't allocate now, Forward, Finish

Actual results:
Guest BIOS reports:

Booting from CD-Rom...
CDROM boot failure code : 0003
Boot failed: could not read the boot disk

FATAL: No bootable device.

Expected results:
Boots normally.

Additional info:
# rpm -V libvirt
missing     /var/cache/libvirt/qemu
# ls -ld /tmp
drwxrwxrwt. 95 root root 86016 2009-08-24 12:38 /tmp
# ls -ld /tmp/tim
drwxrwxr-x. 2 twaugh twaugh 4096 2009-08-21 17:17 /tmp/tim
# ls -l /tmp/tim/Fedora-11-x86_64-DVD.iso
-rw-rw-r--. 1 qemu qemu 4268124160 2009-08-15 11:09 /tmp/tim/Fedora-11-x86_64-DVD.iso
# ls -Z /tmp/tim/Fedora-11-x86_64-DVD.iso
-rw-rw-r--. qemu qemu system_u:object_r:virt_content_t:s0 /tmp/tim/Fedora-11-x86_64-DVD.iso
# sha256sum /tmp/tim/Fedora-11-x86_64-DVD.iso 
9f733ef43d470217a08dd3f4214deecccfc9e6d5041dc8eef47d990c419a6884  /tmp/tim/Fedora-11-x86_64-DVD.iso
Comment 1 Daniel Berrange 2009-08-26 11:02:57 EDT
Can you provide the /var/log/libvirt/qemu/$GUEST.log  from the time this error happens ?    Also the 'virsh dumpxml $GUEST'  output from the time it is running and showing this errror


At least QEMU has started up, so its unlikely to be selinux / file permissions problem at this point. There must be some guest config / setup problem instead i reckon
Comment 2 Tim Waugh 2009-08-26 11:22:10 EDT
Created attachment 358731 [details]
F11.log
Comment 3 Tim Waugh 2009-08-26 11:22:32 EDT
Created attachment 358732 [details]
F11.xml
Comment 4 Daniel Berrange 2009-08-26 11:30:42 EDT
Ah ha, the guest XML has the CDROM device configured to use VirtIO !

    <disk type='file' device='cdrom'>
      <driver name='qemu'/>
      <source file='/tmp/tim/Fedora-11-x86_64-DVD.iso'/>
      <target dev='vdb' bus='virtio'/>
      <readonly/>
    </disk>


This is a bug in virtinst library   - bug 517151

To workaround, you can use  'virsh edit $GUEST' and change

      <target dev='vdb' bus='virtio'/>

to 

      <target dev='hdc' bus='ide'/>

*** This bug has been marked as a duplicate of bug 517151 ***

Note You need to log in before you can comment on or make changes to this bug.