Bug 517151 - virtinst creates cdrom device using virtio rather than IDE
virtinst creates cdrom device using virtio rather than IDE
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 518535 518552 518965 (view as bug list)
Depends On:
Blocks: F12VirtBlocker
  Show dependency treegraph
 
Reported: 2009-08-12 14:46 EDT by Gene Czarcinski
Modified: 2016-04-26 14:18 EDT (History)
8 users (show)

See Also:
Fixed In Version: python-virtinst-0.500.0-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-21 12:29:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager.log (13.60 KB, text/plain)
2009-08-14 19:58 EDT, Gene Czarcinski
no flags Details
f10test.log (617 bytes, text/plain)
2009-08-14 19:58 EDT, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2009-08-12 14:46:36 EDT
Description of problem:
When creating a new guest virtual machine for Fedora 10 and specifying Fedora 10 as the system type, the resulting device type for the CD/DVD iso image is "/dev/vdb" which results in "could not read boot disk".

I suspect that only an IDE device will work with the CD/DVD.

I have not tested it but this probably does not work with a Fedora 11 guest either.

Specifying that the system type is Fedora 9 so that IDE device types only will be used works.

Version-Release number of selected component (if applicable):
Fedora 11 plus "virt-preview" set of packages for F11.
libvirt-0.7.0-3.fc11.x86_64
qemu-0.10.91-0.5.rc1.fc11.x86_64
qemu-kvm-0.10.91-0.5.rc1.fc11.x86_64
virt-manager-0.8.0-1.fc11.noarch


How reproducible:
everytime
Comment 1 Mark McLoughlin 2009-08-14 14:41:38 EDT
Could you attach virt-manager.log and the guest log from /var/log/libvirt/qemu ?
Comment 2 Gene Czarcinski 2009-08-14 19:58:15 EDT
Created attachment 357518 [details]
virt-manager.log

started with a clean log ... only did the definition of "f10test" which had /deb/vdb for the CD/DVD (which did not work)
Comment 3 Gene Czarcinski 2009-08-14 19:58:51 EDT
Created attachment 357519 [details]
f10test.log
Comment 4 Mark McLoughlin 2009-08-18 06:21:13 EDT
Thanks Gene, I can reproduce this - adding to the Fedora 12 blocker list
Comment 5 Mark McLoughlin 2009-08-21 03:02:02 EDT
*** Bug 518552 has been marked as a duplicate of this bug. ***
Comment 6 Mark McLoughlin 2009-08-21 03:02:47 EDT
Perry confirms this happens with virt-install too
Comment 7 Mark McLoughlin 2009-08-21 03:43:49 EDT
*** Bug 518535 has been marked as a duplicate of this bug. ***
Comment 8 Eric Paris 2009-08-21 10:56:46 EDT
removing the virtio storage device for the cdrom and re-adding a new storage device as cdrom/ide for the iso and my livecd boots!

Success!
Comment 9 Daniel Berrange 2009-08-26 11:30:42 EDT
*** Bug 518965 has been marked as a duplicate of this bug. ***
Comment 10 Mark McLoughlin 2009-09-21 12:29:17 EDT
I think this is supposed to be fixed by:

* Sun Sep 13 2009 Cole Robinson <crobinso@redhat.com> - 0.500.0-2.fc12
- Don't use virtio for cdrom devices (bz 517151)

However, there may be more issues - see bug #524109

Note You need to log in before you can comment on or make changes to this bug.