Bug 519026 - selecting custom partitioning throws exception
Summary: selecting custom partitioning throws exception
Keywords:
Status: CLOSED DUPLICATE of bug 517260
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-24 16:14 UTC by Robert M Williams
Modified: 2009-10-07 14:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-25 16:00:27 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (96.77 KB, text/plain)
2009-08-24 16:15 UTC, Robert M Williams
no flags Details
Attached traceback automatically from anaconda. (121.69 KB, text/plain)
2009-08-31 09:23 UTC, Blizzerand
no flags Details
Attached traceback automatically from anaconda. (418.76 KB, text/plain)
2009-09-14 12:24 UTC, andreasfrische+redhat
no flags Details
Attached traceback automatically from anaconda. (266.36 KB, text/plain)
2009-10-02 15:57 UTC, James Laska
no flags Details
Attached traceback automatically from anaconda. (927.65 KB, text/plain)
2009-10-07 09:16 UTC, Harald Hoyer
no flags Details

Description Robert M Williams 2009-08-24 16:14:58 UTC
The following was filed automatically by anaconda:
anaconda 12.15 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 934, in populate
    devname = "%s" % device.path
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1356, in getScreen
    self.populate(initial = 1)
  File "/usr/lib/anaconda/gui.py", line 1285, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1202, in nextClicked
    self.setScreen ()
AttributeError: 'NoneType' object has no attribute 'path'

Comment 1 Robert M Williams 2009-08-24 16:15:03 UTC
Created attachment 358478 [details]
Attached traceback automatically from anaconda.

Comment 2 Robert M Williams 2009-08-24 16:18:05 UTC
system is Dell Inspiron 1545 laptop
hard drive type SATA
hard drive contained pre-exsisting Fedora created default LVM layout

Comment 3 Robert M Williams 2009-08-24 16:59:43 UTC
booted from a live cd and deleted all partitions from drive
also noted drive partition table type was GPT (possibly from previous Windows 7 install since removed)
reset partition table type to msdos
did not create any partitions from live cd. so drive was completely clean.
rebooted fedora install dvd and was able to partition the drive without traceback
interesting that the install of fedora 12 prior to this reinstall worked without this error using the 'use entire drive' option, but using custom partitioning did on the same drive with the same version of fedora 12

Comment 4 Chris Lumens 2009-08-25 16:00:27 UTC

*** This bug has been marked as a duplicate of bug 517260 ***

Comment 5 Blizzerand 2009-08-31 09:23:51 UTC
Created attachment 359236 [details]
Attached traceback automatically from anaconda.

Comment 6 Blizzerand 2009-08-31 09:30:59 UTC
Comment Automatically produced

I was trying o install Fedora 12 Alpha with the option *Create custom layer* but got the errors attached in the above post . Doing so it forced me to exit the installer

Comment 7 andreasfrische+redhat 2009-09-14 12:24:53 UTC
Created attachment 360929 [details]
Attached traceback automatically from anaconda.

Comment 8 James Laska 2009-10-02 15:57:27 UTC
Created attachment 363500 [details]
Attached traceback automatically from anaconda.

Comment 9 Harald Hoyer 2009-10-07 09:16:33 UTC
Created attachment 363939 [details]
Attached traceback automatically from anaconda.

Comment 10 Harald Hoyer 2009-10-07 09:17:47 UTC
trying to use existing layout after a unsuccessful anaconda partitioning

Comment 11 James Laska 2009-10-07 14:10:59 UTC
Moving anaconda trace hash to DUP'd bug.


Note You need to log in before you can comment on or make changes to this bug.