Bug 517260 - liveinst fails at partitioning screen
liveinst fails at partitioning screen
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:38997998bbbb9120e...
: Reopened
: 519026 521102 530221 (view as bug list)
Depends On:
Blocks: F12AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-08-13 05:59 EDT by Sebastian Vahl
Modified: 2010-06-15 17:37 EDT (History)
17 users (show)

See Also:
Fixed In Version: anaconda-12.39-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-31 12:06:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
full anaconda traceback saved to file (359.73 KB, text/plain)
2009-08-13 05:59 EDT, Sebastian Vahl
no flags Details
anaconda 12.25 exception report (57.18 KB, text/plain)
2009-09-18 15:25 EDT, andreasfrische+redhat
no flags Details
Attached traceback automatically from anaconda. (180.28 KB, text/plain)
2009-10-20 13:10 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (78.77 KB, text/plain)
2009-10-22 23:59 EDT, Paul Victor Novarese
no flags Details
Screenshot demonstrating fix.png (45.88 KB, image/png)
2009-10-31 12:06 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (184.21 KB, text/plain)
2009-11-22 10:49 EST, Patrick
no flags Details
Attached traceback automatically from anaconda. (471.33 KB, text/plain)
2009-12-31 18:48 EST, Gian Paolo Mureddu
no flags Details
Attached traceback automatically from anaconda. (154.30 KB, text/plain)
2010-01-06 06:15 EST, Tomasz Torcz
no flags Details
Attached traceback automatically from anaconda. (103.82 KB, text/plain)
2010-01-06 06:47 EST, Tomasz Torcz
no flags Details
Attached traceback automatically from anaconda. (99.01 KB, text/plain)
2010-04-30 19:17 EDT, rickabillie
no flags Details
Attached traceback automatically from anaconda. (60.46 KB, text/plain)
2010-06-15 17:37 EDT, Justin Bard
no flags Details

  None (edit)
Description Sebastian Vahl 2009-08-13 05:59:40 EDT
Created attachment 357291 [details]
full anaconda traceback saved to file

Description of problem:
After selecting a custom layout liveinst fails with this traceback:

anaconda 12.13-1.fc12 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 934, in populate
    devname = "%s" % device.path
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1356, in getScreen
    self.populate(initial = 1)
  File "/usr/lib/anaconda/gui.py", line 1285, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1202, in nextClicked
    self.setScreen ()
AttributeError: 'NoneType' object has no attribute 'path'


Version-Release number of selected component (if applicable):
anaconda 12.13-1.fc12

How reproducible:
anaconda-12.13-1.fc12.x86_64

Steps to Reproduce:
1. create a live image (KDE here)
2. install with liveinst
3. select custom layout and proceed
  
Actual results:
crash


Expected results:
works
Comment 1 Andy Lindeberg 2009-08-13 15:25:37 EDT
This should be fixed in anaconda 12.16.
Comment 2 Sebastian Vahl 2009-08-17 11:54:34 EDT
When will -16 hit F12Alpha/Rawhide?
Comment 3 Sebastian Vahl 2009-08-18 07:44:29 EDT
I've added it at as blocker for F12Alpha because atm there is no way to install live images (or test them properly).
Comment 5 David Lehman 2009-08-18 15:12:04 EDT
(In reply to comment #3)
> I've added it at as blocker for F12Alpha because atm there is no way to install
> live images (or test them properly).  

This is not accurate. You should be able to test live images as long as the backing device is not a partition (eg: cd, lv).
Comment 6 James Laska 2009-08-18 15:19:35 EDT
(In reply to comment #3)
> I've added it at as blocker for F12Alpha because atm there is no way to install
> live images (or test them properly).  

Sebastian: I'm told that booting the live image with the argument "nompath" is
sufficient to work around this issue.  Are you able to confirm this workaround?
Comment 7 Sebastian Vahl 2009-08-18 16:05:58 EDT
(In reply to comment #5)
> (In reply to comment #3)
> > I've added it at as blocker for F12Alpha because atm there is no way to install
> > live images (or test them properly).  
> 
> This is not accurate. You should be able to test live images as long as the
> backing device is not a partition (eg: cd, lv).  

You were right: I've used a local partition to boot the live images. After using an usb stick, liveinst isn't failing anymore.


(In reply to comment #6)
> (In reply to comment #3)
> > I've added it at as blocker for F12Alpha because atm there is no way to install
> > live images (or test them properly).  
> 
> Sebastian: I'm told that booting the live image with the argument "nompath" is
> sufficient to work around this issue.  Are you able to confirm this workaround?  

I have only tested this when booting from a local partition and there it is failing, too.
Comment 8 James Laska 2009-08-18 16:43:50 EDT
Moving this to blocks:F12Beta based on the updated feedback around using a live image with a USB stick.  Should a workaround be required, once anaconda-12.16 is built you may use a rawhide nightly live image (see http://alt.fedoraproject.org/pub/alt/nightly-composes/).

Thanks!
Comment 9 Chris Lumens 2009-08-25 12:00:27 EDT
*** Bug 519026 has been marked as a duplicate of this bug. ***
Comment 10 Chris Lumens 2009-09-03 12:45:50 EDT
*** Bug 521102 has been marked as a duplicate of this bug. ***
Comment 11 Hicham HAOUARI 2009-09-03 12:50:32 EDT
I confirm this with anaconda 12.20-1.fc12

Used local partition as liveimg.
Comment 12 Hicham HAOUARI 2009-09-03 13:05:03 EDT
passing nompath as argument when booting the liveimg didn't help
Comment 13 Adam Williamson 2009-09-11 11:22:04 EDT
Comments 11, 12 (and the dupe reports) suggest this bug still exists. Returning to ASSIGNED.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 John Poelstra 2009-09-11 11:22:33 EDT
This bug was reviewed at the Fedora 12 Beta Blocker bug meeting on 2009-09-11.  Based on a review of the comments it was determined that this bug is not fix.  Moving back to ASSIGNED.
Comment 15 John Poelstra 2009-09-18 11:21:10 EDT
This bug was reviewed at the Fedora 12 Beta Blocker bug meeting on 2009-09-18.  It needs to be retested.  Please help us by reporting if the latest package addresses the originally reported issue.  Thanks.
Comment 16 andreasfrische+redhat 2009-09-18 15:25:43 EDT
Created attachment 361710 [details]
anaconda 12.25 exception report

problem persists with the spins from 17.09.09
Comment 17 andreasfrische+redhat 2009-09-22 12:51:18 EDT
fixed in rawhide
Comment 18 Adam Williamson 2009-09-22 13:47:08 EDT
how could you possibly have tested? live builds since sept 18th don't boot on any hardware, as far as I'm aware...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 andreasfrische+redhat 2009-09-22 14:22:18 EDT
i managed to boot the kde spin from 21.09
( by getting into the emergency shell , unmounting the root partition , running /sbin/dmsqashfs<something> /dev/sda3, and exiting the shell )
Comment 20 James Laska 2009-10-02 11:59:30 EDT
Still broken while testing anaconda-12.32 live image install.  See updated traceback attached to DUP'd bug (https://bugzilla.redhat.com/attachment.cgi?id=363500).
Comment 21 James Laska 2009-10-07 10:11:30 EDT
Added anaconda trace hash from bug that was DUP'd to this issue.
Comment 22 James Laska 2009-10-09 09:29:30 EDT
I'm having difficulty reproducing this failure.  The problem does not appear using procedure noted in comment#0.  However, when I recreated this issue, it was during the anaconda storage test day.  According to hhoyer who also hit this issue, it was while testing an encrypted logical '/' volume on a RAID1 /dev/md0 physical volume.

I'm not able to hit this issue during testing today.  Can someone else confirm that the problem is resolved using the latest live image (see http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/).

dlehman:  Is there another way this defect could occur outside of the reproducer posted in comment#0?
Comment 23 David Lehman 2009-10-09 10:42:42 EDT
It should occur any time you use a usb-backed live install and choose custom partitioning. It will not occur with livecd, only liveusb.
Comment 24 James Laska 2009-10-12 11:14:18 EDT
Discussed with dlehman and jkeating about this bug.  Harald Hoyer and I have reproduced this issue while testing RAID installs, but I've no longer been able to reproduce the issue using the documented procedure in this bug.  The agreement is to move this issue off the F12Beta list, and to the F12BLocker list given that the producer no longer seems to be as straight forward as noted in comment#0.
Comment 25 David Lehman 2009-10-14 02:10:12 EDT
I think the trick to reproducing this failure may be using a partitioned device with more than one partition as the live device (eg: usb or other disk).
Comment 26 Hicham HAOUARI 2009-10-14 06:49:52 EDT
If it is not possible to install the liveimg from a local partition, please state it in the wiki or the errata so people can stop complaining about this problem. 

Just as a note, it is possible to install the live iso from the harddisk by using grub v2.
Comment 27 Adam Williamson 2009-10-14 18:24:51 EDT
Hicham: um. What? That's not what this bug is about, so far as I can tell.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 28 Hicham HAOUARI 2009-10-15 04:17:55 EDT
Adam, plz see comment 0 and 7.
Comment 29 James Laska 2009-10-20 13:10:14 EDT
Created attachment 365387 [details]
Attached traceback automatically from anaconda.
Comment 30 David Lehman 2009-10-20 19:13:29 EDT
Should be fixed in anaconda-12.39-1.
Comment 31 Warren Togami 2009-10-20 22:56:27 EDT
I don't see 12.39 built.
Comment 32 David Lehman 2009-10-22 10:04:43 EDT
*** Bug 530221 has been marked as a duplicate of this bug. ***
Comment 33 Paul Victor Novarese 2009-10-22 23:59:25 EDT
Created attachment 365811 [details]
Attached traceback automatically from anaconda.
Comment 34 Adam Williamson 2009-10-28 16:59:36 EDT
12.39 was tagged on 20091024. Can you please re-test with a build from that date or later and confirm the fix? Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 35 James Laska 2009-10-31 12:06:35 EDT
Created attachment 366939 [details]
Screenshot demonstrating fix.png

Confirmed the fix with anaconda-12.41-1.fc12.i686 and a USB live image containing the following partition setup:

Model: SanDisk Cruzer (scsi)
Disk /dev/sdb: 4027MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      512B    2020MB  2020MB  primary  fat32        boot, lba
 2      2020MB  4027MB  2007MB  primary  fat32        lba
Comment 36 Patrick 2009-11-22 10:49:15 EST
Created attachment 372922 [details]
Attached traceback automatically from anaconda.
Comment 37 Patrick 2009-11-22 10:52:16 EST
I have this bug with the install dvd when trying to create a custom layout
Comment 38 Patrick 2009-11-23 05:09:57 EST
More information on this bug :
I had a raid and another harddrive.
When I unplugged the other harddrive I could go through the partitionning task.
Comment 39 David Lehman 2009-11-23 15:41:53 EST
(In reply to comment #38)
> More information on this bug :
> I had a raid and another harddrive.
> When I unplugged the other harddrive I could go through the partitionning task.  

Please open a separate bug report for your problem. Although it ends up causing a very similar traceback, yours is a different failure. Thanks.
Comment 40 Gian Paolo Mureddu 2009-12-31 18:48:47 EST
Created attachment 381128 [details]
Attached traceback automatically from anaconda.
Comment 41 Tomasz Torcz 2010-01-06 06:15:35 EST
Created attachment 381957 [details]
Attached traceback automatically from anaconda.
Comment 42 Tomasz Torcz 2010-01-06 06:30:20 EST
I cannot install F12 using netinstall. Is there update for anaconda available somewhere?
Comment 43 Tomasz Torcz 2010-01-06 06:47:33 EST
Created attachment 381963 [details]
Attached traceback automatically from anaconda.
Comment 44 David Lehman 2010-01-06 12:10:18 EST
(In reply to comment #41)
> Created an attachment (id=381957) [details]
> Attached traceback automatically from anaconda.  

Tomasz,

Can you please open a new bug and describe in some detail what you did leading to this failure? (pre-existing storage layout, steps taken in installer)

Although the traceback looks the same as the others in this bug, yours is different.

Thanks.
Comment 45 rickabillie 2010-04-30 19:17:05 EDT
Created attachment 410612 [details]
Attached traceback automatically from anaconda.
Comment 46 Justin Bard 2010-06-15 17:37:29 EDT
Created attachment 424307 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.