Bug 519146 - system-config-kickstart crashes
Summary: system-config-kickstart crashes
Keywords:
Status: CLOSED DUPLICATE of bug 487390
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-kickstart
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-25 11:12 UTC by Shreyank Gupta
Modified: 2009-08-25 14:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-25 14:16:00 UTC
Type: ---


Attachments (Terms of Use)
Bug report (738 bytes, application/octet-stream)
2009-08-25 11:12 UTC, Shreyank Gupta
no flags Details

Description Shreyank Gupta 2009-08-25 11:12:43 UTC
Created attachment 358555 [details]
Bug report

Description of problem:

system-config-kickstart crashes while opening fedora-live-base.ks file from spin-kickstart.

Version-Release number of selected component (if applicable):
2.7.22

How reproducible:
Very

Steps to Reproduce:

1. Start system-config-kickstart
2. File > Open File to open /usr/share/spin-kickstarts/fedora-live-base.ks
 OR
1. run system-config-kickstart /usr/share/spin-kickstarts/fedora-live-base.ks from the terminal.
  
Actual results:

Crashes with the following traceback:

Component: system-config-kickstart
Summary: TB9b18a952 basic.py:240:applyKickstart:ValueError: list.index(x): x not in list

Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 315, in on_activate_open
    self.applyKickstart()
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 339, in applyKickstart
    self.basic_class.applyKickstart()
  File "/usr/share/system-config-kickstart/basic.py", line 240, in applyKickstart
    self.timezone_combo.list.select_item(self.timezone_list.index(zone))
ValueError: list.index(x): x not in list

Local variables in innermost frame:
lang: Italian (Switzerland)
ksLang: en_US
self: <basic.basic instance at 0x9313c6c>
zone: US/Eastern


Expected results:

Should be able to correctly parse the kickstart file and allow the user to customise it.


Additional info:

Comment 1 Chris Lumens 2009-08-25 14:16:00 UTC

*** This bug has been marked as a duplicate of bug 487390 ***


Note You need to log in before you can comment on or make changes to this bug.