Bug 519211 - nm-applet doesn't work
nm-applet doesn't work
Status: CLOSED DUPLICATE of bug 529766
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-25 12:37 EDT by Jonathan Kamens
Modified: 2009-11-06 23:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-06 23:05:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2009-08-25 12:37:41 EDT
I don't get a NetworkManager applet icon in my panel when I start the NetworkManager service.  I do see some minor moving around of icons when I start the service, so I suspect that the applet is trying to start but failing.

When I try to run nm-applet by hand, first I see this in the terminal from which I started it:

** (nm-applet:17321): WARNING **: Icon nm-no-connection missing: Error opening file: No such file or directory

and then I get a pop-up which says this:

The NetworkManager applet could not find some required resources.  It cannot continue.
Comment 1 Matthias Clasen 2009-08-26 22:10:44 EDT
What does ls /usr/share/icons/hicolor/*/apps/nm-no-connection.* say ?

What icon theme are you using ?

Does gtk-update-icon-cache -f /usr/share/icons/hicolor fix things ?
Comment 2 Jonathan Kamens 2009-08-27 08:33:59 EDT
$ ls /usr/share/icons/hicolor/*/apps/nm-no-connection.*
/usr/share/icons/hicolor/16x16/apps/nm-no-connection.png
/usr/share/icons/hicolor/22x22/apps/nm-no-connection.png
/usr/share/icons/hicolor/32x32/apps/nm-no-connection.png
/usr/share/icons/hicolor/scalable/apps/nm-no-connection.svg
$ 

When I bring up the appearances control panel, the first theme displayed is labeled "Custom", it is the one selected, and there's a warning below it that says, "This theme will not look as intended because the required icon theme 'Clearlooks' is not installed.'"  However, when I click on the next theme in the control panel, Clearlooks, it doesn't display an error, so it appears that the Clearlooks theme *is* installed, so I don't know what that warning is about.

I just installed clearlooks-compact-gnome-theme and closed and reopened the control panel, and it still says that Clearlooks is not installed.  Is there some other RPM that I should install to fix that problem?

In any case, installing clearlooks-compact-gnome-theme does seem to fix the nm-applet problem.
Comment 3 Matthias Clasen 2009-08-27 11:39:28 EDT
an icon theme of 'Clearlooks' is somewhat bizarre. All the places where icon theme is stored should default to 'Fedora':

/etc/gtk-2.0/gtkrc
/usr/share/themes/Fedora/index.theme
/etc/gconf/schemas/desktop_gnome_interface.schemas


What does gconftool-2 --get /desktop/gnome/interface/icon_theme say ?
Comment 4 Jonathan Kamens 2009-08-27 14:14:13 EDT
It returns "Clearlooks".

I've never changed the icon theme, as far as I know, or for that matter changed the theme at all.

Note that this system has been around for a *long* time, updated incrementally for many years.  If I had to guess, I'd guess that it started somewhere around Fedora 6, but that's just a guess.  So this is anything but a pristine install :-).
Comment 5 Matthias Clasen 2009-08-27 14:21:07 EDT
hmm, ok

to fix your system, either open the appearance capplet, go to 'Customize', open the Icons tab and select 'Fedora', or

gconftool-2 --type string --set /desktop/gnome/interface/icon_theme Fedora
Comment 6 Jonathan Kamens 2009-08-27 16:48:03 EDT
OK, I can do that, but I'm more interested in how to prevent this from happening to other people when they upgrade to F12...
Comment 7 Dan Williams 2009-11-06 23:05:23 EST

*** This bug has been marked as a duplicate of bug 529766 ***

Note You need to log in before you can comment on or make changes to this bug.