This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 529766 - applet won't start
applet won't start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 519211 530161 530253 530298 530511 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-19 17:05 EDT by Bill Nottingham
Modified: 2014-03-16 23:20 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-22 13:28:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2009-10-19 17:05:44 EDT
Description of problem:

The first time after any boot, I get:

Missing resources

The NetworkManager applet could not find some required resources. It cannot continue.

Subsequent applet restarts work. :/

Version-Release number of selected component (if applicable):

NetworkManager-gnome-0.7.996-4.git20091002.fc12.x86_64
gnome-panel-2.28.0-8.fc12.x86_64

How reproducible:

100%

Steps to Reproduce:
1. boot
2. log in
  
Actual results:

Error

Expected results:

No error.
Comment 1 Dan Williams 2009-10-19 17:18:24 EDT
upstream commit is 048cd5ea2b828dca1a322677a44852a5e0ca844c
Comment 2 Dan Williams 2009-10-19 17:18:59 EDT
though I'm not sure why the gtk-update-icon-cache -f in the %post isn't helping there, but since the icon was unused, it can go anyway
Comment 3 Adam Williamson 2009-10-21 01:11:23 EDT
if this could be fixed and tagged into F12 ASAP it'd be appreciated - it's likely to cause some consternation for Beta users who do upgrades. thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2009-10-21 18:29:16 EDT
curious about this one: does it occur in the Beta or did it only start with an update that landed after the beta unfreeze (gnome-panel?)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Dan Williams 2009-10-21 19:02:19 EDT
there haven't been any updates since the Beta freeze...
Comment 6 Dan Williams 2009-10-21 19:02:54 EDT
*** Bug 530161 has been marked as a duplicate of this bug. ***
Comment 7 Adam Williamson 2009-10-21 19:15:59 EDT
dan: not to NM, but there were to gnome-panel. was wondering if those changes had triggered it somehow.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Dan Williams 2009-10-21 19:34:01 EDT
My current theory is:

1) a new icon got added back in late September (which turns out to be unecessary and unused anyway)
2) that new icon would require a gtk-update-icon-cache -f to let the GTK icon theme know about it
3) if the icon theme doesn't know about the icon, you'll get this error
4) gtk-update-icon-theme -f is called from the -gnome package's %post script
5) mccan's applet-schemas patch from late September didn't properly handle the case of updating from a system where the schemas were not previously installed and thus the script run would fail (bug 526519)
6) since the script run would fail due to the missing schemas on upgrade, perhaps the gtk-update-icon-cache -f didn't get run at all
7) applet fail

sound plausible?

In any case, the icon is removed from the builds I'm about to do, and there's a real fix for bug 526519 too.

Second, there appear to be panel size issues; the applet starts up and the panel doesn't have a size for it yet, so it sends the applet a width of '0'.  The applet checks for width < 0, but not for width = 0, before requesting icons.  The GTK icon theme refuses to return any icons for a size of 0, and thus more fail.
Comment 9 Adam Williamson 2009-10-21 20:13:32 EDT
indeed, sounds plausible, and if i'm reading it correctly, explains why we didn't catch the issue just doing clean test installs of the Beta. which is what I was wondering, really.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 James Cassell 2009-10-22 11:22:18 EDT
(In reply to comment #9)
> indeed, sounds plausible, and if i'm reading it correctly, explains why we
> didn't catch the issue just doing clean test installs of the Beta. which is
> what I was wondering, really.
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers  

I ran into this after doing a preupgrade to rawhide a couple hours ago.
Comment 11 James Cassell 2009-10-22 13:11:35 EDT
the problem seems to be gone after updating to:
NetworkManager-gnome-0.7.996-5.git20091021.fc12.x86_64
NetworkManager-glib-0.7.996-5.git20091021.fc12.x86_64
NetworkManager-0.7.996-5.git20091021.fc12.x86_64
Comment 12 Richard Fearn 2009-10-22 18:13:08 EDT
*** Bug 530253 has been marked as a duplicate of this bug. ***
Comment 13 Dan Williams 2009-10-26 18:19:41 EDT
*** Bug 530298 has been marked as a duplicate of this bug. ***
Comment 14 Dan Williams 2009-10-26 18:19:45 EDT
*** Bug 530511 has been marked as a duplicate of this bug. ***
Comment 15 Dan Williams 2009-11-06 23:05:23 EST
*** Bug 519211 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.