Bug 519391 - (nss) broken pkgconfig file
(nss) broken pkgconfig file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nss (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Elio Maldonado Batiz
Fedora Extras Quality Assurance
:
: 519995 (view as bug list)
Depends On:
Blocks: 519081
  Show dependency treegraph
 
Reported: 2009-08-26 09:03 EDT by Andreas Schwab
Modified: 2009-08-28 12:53 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-28 11:14:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nss part (1.00 KB, patch)
2009-08-28 04:04 EDT, Caolan McNamara
no flags Details | Diff

  None (edit)
Description Andreas Schwab 2009-08-26 09:03:55 EDT
nss-devel-3.12.3.99.3-16.fc12

$ nss-config --cflags
-I
$ pkg-config --variable=includedir --print-errors nss
Requires field occurs twice in '/usr/lib64/pkgconfig/nss.pc'
Comment 1 Ulrich Drepper 2009-08-26 11:01:43 EDT
Please fix this ASAP.  It is holding up important testing for F12.
Comment 2 Elio Maldonado Batiz 2009-08-26 14:06:13 EDT
Check http://koji.fedoraproject.org/koji/taskinfo?taskID=1636051 for the fix
Comment 3 Andreas Schwab 2009-08-27 06:37:42 EDT
Still blocked by nss-softokn.
Comment 4 Caolan McNamara 2009-08-27 12:58:38 EDT
3.12.3.99.3-18.fc12 from #2 doesn't fix this, you've still got %NSSUTIL_VERSION% etc in nss.pc
Comment 5 Elio Maldonado Batiz 2009-08-27 13:21:52 EDT
You are right, the fixed nss.pc.in doesn't show up in the srpm. Another one coming.
Comment 6 Warren Togami 2009-08-27 17:02:21 EDT
package: 389-adminutil-devel-1.1.8-4.fc12.i686 from rawhide-i386
  unresolved deps: 
     pkgconfig(nss)
package: conexus-nss-devel-0.9.0-1.fc12.i686 from rawhide-i386
  unresolved deps: 
     pkgconfig(nss) >= 0:3.11
package: libpathfinder-nss-devel-1.0.0-2.fc12.i686 from rawhide-i386
  unresolved deps: 
     pkgconfig(nss) >= 0:2.0.0
package: mozldap-devel-6.0.5-6.fc12.i686 from rawhide-i386
  unresolved deps: 
     pkgconfig(nss) >= 0:3.11
package: svrcore-devel-4.0.4-5.fc12.i686 from rawhide-i386
  unresolved deps: 
     pkgconfig(nss) >= 0:3.12.3.99.3
package: xmlsec1-nss-devel-1.2.12-1.fc12.i686 from rawhide-i386
  unresolved deps: 
     pkgconfig(nss) >= 0:1.4

Is something supposed to provide this?
Comment 7 Warren Togami 2009-08-27 20:59:56 EDT
http://koji.fedoraproject.org/koji/getfile?taskID=1639014&name=build.log
Another nss related build failure...

+ pkg-config --exists nss
+ echo 'Unable to find suitable version of nss to use!'
Unable to find suitable version of nss to use!
+ exit 1
Comment 8 Caolan McNamara 2009-08-28 04:04:03 EDT
Created attachment 359022 [details]
nss part

3.12.3.99.3-22.fc12 isn't going to fix this either. You need to replace those %NSSUTIL_VERSION% and %SOFTOKEN_VERSION% values in the .pc.in as are already done for %NSS_VERSION%

Requires: nspr >= 4.8, nss-util >= %NSSUTIL_VERSION%, nss-softokn >= %SOFTOKEN_VERSION%

And then the same sort of thing probably has to be done to nss-softokn .spec as well, i.e.

-                          -e "s,%%SOFTKN_VERSION%%,%{version},g" > \
+                          -e "s,%%NSSUTIL_VERSION%%,%{version},g" \
+                          -e "s,%%SOFTOKEN_VERSION%%,%{version},g" > \
Comment 9 Dan Williams 2009-08-28 10:06:28 EDT
Yeah; nss-softokn -21 needs fixes to, just for the record this is what I get when trying to build NetworkManager:

checking for NSS... configure: error: Package requirements (nss >= 3.11) were not met:
Package 'NSS-SOFTOKN' requires 'nss-util >= %NSSUTIL_VERSION%' but version of NSS-UTIL is 3.12.3.99.3
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables NSS_CFLAGS
and NSS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
Comment 10 Rex Dieter 2009-08-28 11:14:31 EDT
Should be fixed in 
nss-3.12.3.99.3-24.fc12
nss-softokn-3.12.3.99.3-22.fc12

http://koji.fedoraproject.org/koji/buildinfo?buildID=129665
http://koji.fedoraproject.org/koji/buildinfo?buildID=129667

respectively.  holler if problems persist.
Comment 11 Rex Dieter 2009-08-28 11:15:12 EDT
*** Bug 519995 has been marked as a duplicate of this bug. ***
Comment 12 Elio Maldonado Batiz 2009-08-28 12:43:10 EDT
Rex, Thank you for the fix. 

I see you comment
# FIXME: Due to nss.pc.in substitutions in the %%build section, these Requires must
# be exactly matching versions?
Requires:         nss-util >= %{version}
Requires:         nss-softokn >= %{version}
Requires:         nss-softokn-freebl%{_isa} >= %{version}

which I guess should be changed to

Requires:         nss-util = %{version}-%{release}
Requires:         nss-softokn = %{version}-%{release}
Requires:         nss-softokn-freebl%{_isa} >= %{version}

and we would probably have to do a chained build for this to work.

That is fine as long as we keep them all at the same version. Such is the case now in Fedora. In the case of RHEL for example we want to keep softokn at the currently FIPS validated version while at the same upgrading the rest of nss to the latest. I will have to do thread carefully, keep track of the desired softokn version and adjust both the use of versions in the %build section and here with the requires.
Comment 13 Warren Togami 2009-08-28 12:53:13 EDT
I wrote that.  It doesn't need to be exactly matching, but rather versions must be explicitly defined so the Requires matches the the versions written to the pkgconfig file.

Note You need to log in before you can comment on or make changes to this bug.