Bug 519465 - wodim man page falsely claims DVD+RW formatting is automatic
Summary: wodim man page falsely claims DVD+RW formatting is automatic
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cdrkit
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Honza Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-26 17:53 UTC by Andre Robatino
Modified: 2011-06-15 11:28 UTC (History)
4 users (show)

Fixed In Version: cdrkit-1.1.11-8.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-15 05:42:25 UTC


Attachments (Terms of Use)
proposed patch (1.93 KB, patch)
2011-05-18 08:07 UTC, Honza Horak
no flags Details | Diff
proposed patch (4.07 KB, patch)
2011-05-18 15:53 UTC, Honza Horak
no flags Details | Diff

Description Andre Robatino 2009-08-26 17:53:27 UTC
Description of problem:
If one tries to write to a previously unused DVD+RW disc with wodim, one gets an error saying the disc is unformatted.  But the wodim man page claims this is supposed to happen automatically.

[vic@compaq-pc tmp]$ wodim -v dev=/dev/dvd driveropts=burnfree
padsize=63s -pad -dao home.iso
TOC Type: 1 = CD-ROM
wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK
limits.scsidev: '/dev/dvd'
devname: '/dev/dvd'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Wodim version: 1.1.9
Driveropts: 'burnfree'
SCSI buffer size: 64512
Device type    : Removable CD-ROM
Version        : 5
Response Format: 2
Capabilities   :
Vendor_info    : 'Optiarc '
Identification : 'DVD RW AD-7201S5'
Revision       : '1H0B'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x001A (DVD+RW)
Profile: 0x002B (DVD+R/DL)
Profile: 0x001B (DVD+R)
Profile: 0x001A (DVD+RW) (current)
Profile: 0x0016 (DVD-R/DL layer jump recording)
Profile: 0x0015 (DVD-R/DL sequential recording)
Profile: 0x0014 (DVD-RW sequential recording)
Profile: 0x0013 (DVD-RW restricted overwrite)
Profile: 0x0012 (DVD-RAM)
Profile: 0x0011 (DVD-R sequential recording)
Profile: 0x0010 (DVD-ROM)
Profile: 0x000A (CD-RW)
Profile: 0x0009 (CD-R)
Profile: 0x0008 (CD-ROM)
Profile: 0x0002 (Removable disk)
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Driver flags   : SWABAUDIO BURNFREE
Supported modes: PACKET SAO
Drive buf size : 1245184 = 1216 KB
Beginning DMA speed test. Set CDR_NODMATEST environment variable if device
communication breaks or freezes immediately after that.
FIFO size      : 4194304 = 4096 KB
Track 01: data   471 MB         padsize:  126 KB
Total size:      542 MB (53:42.05) = 241654 sectors
Lout start:      542 MB (53:44/04) = 241654 sectors
Current Secsize: 2048
HINT: use dvd+rw-mediainfo from dvd+rw-tools for information extraction.
Blocks total: 2295104 Blocks current: 2295104 Blocks remaining: 2053450
Speed set to 5540 KB/s
Starting to write CD/DVD at speed   4.0 in real SAO mode for single
session.
Last chance to quit, starting real write in    0 seconds. Operation
starts.
Waiting for reader process to fill input buffer ... input buffer ready.
Performing OPC...
Sending CUE sheet...
Starting new track at sector: 0
Track 01:    0 of  471 MB written.Errno: 5 (Input/output error),
write_g1 scsi sendcmd: no error
CDB:  2A 00 00 00 00 00 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 30 10 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x30 Qual 0x10 (medium not formatted) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.001s timeout 200s

write track data: error after 0 bytes
wodim: A write error occured.
wodim: Please properly read the error message above.
Writing  time:   10.150s
Average write speed  71.5x.
Fixating...
Fixating time:    0.003s
wodim: fifo had 64 puts and 1 gets.
wodim: fifo was 0 times empty and 0 times full, min fill was 100%.
[vic@compaq-pc tmp]$

From the wodim man page:

       -format
              Format a CD-RW/DVD-RW/DVD+RW disc.  Formatting is currently only
              implemented  for DVD+RW media.  A ’maiden’ DVD+RW media needs to
              be formatted before you may write  to  it.   However,  as  wodim
              autodetects  the  need for formatting in this case and auto for-
              mats the medium before it starts writing, the -format option  is
              only needed if you like to forcibly reformat a DVD+RW medium.

Version-Release number of selected component (if applicable):
wodim-1.1.9-6.fc11

How reproducible:
always

Steps to Reproduce:
1.  Attempt to write to a previously unused DVD+RW disc using wodim.
  
Actual results:
"medium not formatted" error, but man page says it's supposed to be formatted automatically.

Expected results:
Either medium should be formatted automatically, or man page shouldn't claim it will be.

Comment 1 Andre Robatino 2009-08-28 00:56:47 UTC
Another error is that the man page falsely implies that the -format option can be used to forcibly reformat a DVD+RW medium.  In reality, this is impossible even when using the -force option.  The -format option can only be used on an unformatted DVD+RW disc.

Comment 2 Andre Robatino 2009-08-28 01:14:32 UTC
Rawhide's wodim man page is the same.  My Rawhide is virtual and I don't seem to be able to test this properly, but the odds are that Rawhide has the same issues.  Someone with Rawhide on real hardware and some unused DVD+RW discs, please test this and then bump the Version to Rawhide if the problems still exist there.  Thanks.

Comment 3 Andre Robatino 2009-08-28 21:29:36 UTC
It also appears that if a DVD+RW is partially formatted (using "dvd+rw-format /dev/dvd", for example) and you use wodim to write past the point where the disc is currently formatted, it seems to complete successfully, but reading will fail.  My father experienced this when writing a large (several hundred MB) tarball with wodim.  The write completed without error but attempting to read it using star failed with a checksum error.  So the problem seems to be that wodim is incapable of handling automatic formatting at all - and if the disc is partially formatted, and it writes past that point, it won't even indicate that there's a problem.  The only way to be sure that a wodim write will work is if the ENTIRE disc is formatted IN ADVANCE.

Comment 4 Jörg Schilling 2009-08-30 10:49:03 UTC
What you see is just a result from the fact that
some non-cooperative downstream packagers bastardized
a working program and created a buggy fork.

The man page was taken from cdrtools and it is correct for
the software it was taken from.

In the fork, the working DVD support code was ripped off
and replaced by something half baken.....

BTW: It does not make sense to discuss things like this 
as the fork "cdrkit" cannot be legally distributed - it is
in conflict with the copyright law.

The obvious solution is to use recent original software.
The original software has no legallity or license problem
and works as documented.

Comment 5 Andre Robatino 2009-08-31 03:16:47 UTC
Verified that wodim's -format option can't be used in Rawhide either to fully format a partially formatted DVD+RW, even using -force.  I don't have any unused DVD+RWs to verify that the original problem also exists in Rawhide, but all things considered I think it's safe to assume it does.  Bumping the Version to rawhide.

Comment 6 Jörg Schilling 2009-08-31 07:53:19 UTC
wodim is completely unmaintained since May 6th 2007, don't
expect to see any fixes anytime soon as long as Redhat 
continues to distribute wodim instead of the original software.

Comment 7 Kevin Kofler 2009-11-02 16:22:46 UTC
Nonsense, the latest commit to cdrkit upstream was just 3 weeks ago.

Comment 8 Kevin Kofler 2009-11-02 16:30:00 UTC
And BTW, the best tool to burn DVDs, especially DVD+RWs, is growisofs, packaged in the dvd+rw-tools package. See also:
http://fy.chalmers.se/~appro/linux/DVD+RW/
http://fy.chalmers.se/~appro/linux/DVD+RW/-RW/ (especially the first Q&A)

Comment 9 Andre Robatino 2009-11-02 16:45:36 UTC
I know about growisofs, but have a backup script that uses wodim, due to 1) the fact that it has a zero-padding option, and 2) behaves better as far as automatically pulling in and ejecting the disc.  I couldn't figure out how to get the same behavior using growisofs.  The downside is that I have to make sure that any discs used are fully formatted in advance, due to this bug.

Comment 10 Jörg Schilling 2009-11-02 16:48:29 UTC
This is nonsense. Pretending some some pseudo activities
from time to time does not verify a maintained project.
There are still more than 100 different serious bugs in the 
various bug tracking systems of the Linux distributors. There
are even more than 60 serious bugs in the Debian bug tracking
system. The majority of the bugs in question are present since 
the fork was created and nobody cares to fix them even though
most of the bugs are easy to fix.

Please do not try to mess around with the users and and finally
admit that all known problems with the fork will disappear if you
upgrade to recent original software.

And BTW: cdrecord is one of the _very_ first DVD writing programs.
Cdrecord supports to write DVDs since February 1998. The original
cdrecord of course supports to write DVD-RWs since a long time.
The problem with wodim is that the working DVD support that comes
with cdrecord has been ripped off and replaced by something 
half baken.

Comment 11 Jörg Schilling 2009-11-02 16:49:32 UTC
(In reply to comment #9)
> I know about growisofs, but have a backup script that uses wodim, due to 1) the
> fact that it has a zero-padding option, and 2) behaves better as far as
> automatically pulling in and ejecting the disc.  I couldn't figure out how to
> get the same behavior using growisofs.  The downside is that I have to make
> sure that any discs used are fully formatted in advance, due to this bug.  

I recommend you to simply just the original cdrtools.

Comment 12 Bug Zapper 2009-11-16 11:43:28 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 Bug Zapper 2010-03-15 12:47:23 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 14 Fedora Admin XMLRPC Client 2011-01-10 13:23:20 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 15 Honza Horak 2011-05-18 08:07:05 UTC
Created attachment 499538 [details]
proposed patch

This patch implements auto-formatting on maiden DVD+RW. It can be tested in:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3078215

I'll try to discuss it with upstream before applying in Rawhide.

Comment 16 Honza Horak 2011-05-18 15:53:57 UTC
Created attachment 499635 [details]
proposed patch

This is a new patch, because the previous one didn't work properly. A new test build is available here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3078796

Comment 17 Fedora Update System 2011-06-03 06:25:59 UTC
cdrkit-1.1.11-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/cdrkit-1.1.11-8.fc15

Comment 18 Fedora Update System 2011-06-03 06:27:06 UTC
cdrkit-1.1.11-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/cdrkit-1.1.11-3.fc14

Comment 19 Fedora Update System 2011-06-04 03:00:09 UTC
Package cdrkit-1.1.11-3.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cdrkit-1.1.11-3.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/cdrkit-1.1.11-3.fc14
then log in and leave karma (feedback).

Comment 20 Fedora Update System 2011-06-15 05:42:12 UTC
cdrkit-1.1.11-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2011-06-15 05:44:16 UTC
cdrkit-1.1.11-8.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Jörg Schilling 2011-06-15 09:19:44 UTC
You are publishing software of questionable legality:
 
http://cdrecord.berlios.de/private/linux-dist.html#violations

There is non-working DVD-support in this wodim and there is missing
BluRay support. wodim is a cdrecord version from September 2004 with
DVD-support removed and with Debian specific bugs added. Do not expect
it to be usable in 2011.

Please upgrade to recent original software. The original software grants
you proven legality and is decently maintained.

Comment 23 Honza Horak 2011-06-15 10:51:14 UTC
(In reply to comment #4)
> The obvious solution is to use recent original software.
> The original software has no legallity or license problem
> and works as documented.

(In reply to comment #11)
> I recommend you to simply just the original cdrtools.

(In reply to comment #22)
> Please upgrade to recent original software. The original software grants
> you proven legality and is decently maintained.


As I've written in bug #709902, I don't think it is necessary to say the same thing several times per every cdrkit bug. Many similar ideas were already said in bug #507108.

Comment 24 Jörg Schilling 2011-06-15 11:28:42 UTC
As long as RedHat distributes the illegal cdrkit instead of the legal
original software and as long as RedHat legal denies even to talk about
this problem, what other opportunity do I have to enclourage you to
start a discussion that ends in RedHat becomming legal again?


Note You need to log in before you can comment on or make changes to this bug.