Bug 519472 - Option to delete packages upon deletion of custom channel is missing.
Option to delete packages upon deletion of custom channel is missing.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Tomas Lestach
Martin Minar
: Regression
: 483815 (view as bug list)
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2009-08-26 14:19 EDT by Brandon Perkins
Modified: 2016-07-03 20:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:54:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brandon Perkins 2009-08-26 14:19:57 EDT
Description of problem:
Option to delete packages upon deletion of custom channel is missing.

Version-Release number of selected component (if applicable):
spacewalk-java-0.5.44-41.el4sat


How reproducible:
Always.

Steps to Reproduce:
1. Create custom channel.
2. Push custom RPMs into channel.
3. Browse to the channel.
4. 'delete software channel'
5. 'Delete Channel' button.
  
Actual results:
Channel is Deleted.

Expected results:
1) Taken to a page like:
https://<FQDN>/network/software/packages/manage/index.pxt?view_channel=no_channels
with a 'blue box' saying:
  Channel $CHANNEL has been deleted.
  The packages selected below were unique to $CHANNEL, and have now been
  orphaned. The packages which are not selected were already orphaned.
with the list of packages for that particular channel that are all pre-selected.
2) Press the 'Delete Packages' button.
3) Taken to a page like:
https://<FQDN>/network/software/packages/manage/delete_confirm.pxt?set_label=deletable_package_list&view_channel=no_channels
which is a confirm deletion page.
4) Press the 'Confirm' button.
5) Packages are all deleted.

Additional info:
Comment 1 Tomas Lestach 2012-11-28 04:14:50 EST
In case a deleted channel contained any custom packages, the user will be redirected to the "Manage Software Packages" page with preselected packages from the deleted channel with the option to delete them.

spacewalk.git: 731a4a32b8acf9da74fb47797be67967a0e165ba
Comment 3 Tomas Lestach 2013-05-22 10:49:03 EDT
*** Bug 483815 has been marked as a duplicate of this bug. ***
Comment 6 Clifford Perry 2013-10-01 17:54:48 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.