Bug 519529 - Crash creating lvm
Crash creating lvm
Status: CLOSED DUPLICATE of bug 496760
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:e180b0eff9fefd223...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-26 19:18 EDT by Martin Ebourne
Modified: 2009-12-15 01:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-01 09:44:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (273.99 KB, text/plain)
2009-08-26 19:19 EDT, Martin Ebourne
no flags Details
Attached traceback automatically from anaconda. (493.04 KB, text/plain)
2009-10-02 06:53 EDT, Martin Banas
no flags Details
Attached traceback automatically from anaconda. (289.35 KB, text/plain)
2009-12-15 01:37 EST, Luya Tshimbalanga
no flags Details

  None (edit)
Description Martin Ebourne 2009-08-26 19:18:55 EDT
The following was filed automatically by anaconda:
anaconda 12.15 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 358, in lvcreate
    raise LVMError("lvcreate failed for %s/%s" % (vg_name, lv_name))
  File "/usr/lib/anaconda/storage/devices.py", line 2193, in create
    lvm.lvcreate(self.vg.name, self._name, self.size)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 203, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 700, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 230, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 117, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1201, in nextClicked
    self.anaconda.dispatch.gotoNext()
LVMError: lvcreate failed for vg_willis/home
Comment 1 Martin Ebourne 2009-08-26 19:19:05 EDT
Created attachment 358788 [details]
Attached traceback automatically from anaconda.
Comment 2 Martin Ebourne 2009-08-26 19:41:13 EDT
Chose default partitioning, use whole disk, review layout.
Deleted lvm/vg but not pv. Resized boot to 2000MB. Created lvm, upped block size to 16MB, added root (30G), swap (1G), and home (default remainder) LVs. Confirmed layout -> bang while creating LV.

Worked a second time when I reduced home to 50G.

160GB disk.
Comment 3 Chris Lumens 2009-09-01 09:44:14 EDT

*** This bug has been marked as a duplicate of bug 496760 ***
Comment 4 Martin Banas 2009-10-02 06:53:11 EDT
Created attachment 363461 [details]
Attached traceback automatically from anaconda.
Comment 5 Luya Tshimbalanga 2009-12-15 01:37:40 EST
Created attachment 378437 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.