Bug 496760 - LVMError in lvcreate: Insufficient free extents
LVMError in lvcreate: Insufficient free extents
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: 0xFFFF (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:5d8883ea0e9be94a9...
: CommonBugs, Reopened
: 498234 517537 519529 520624 (view as bug list)
Depends On: 498137
Blocks: F11AnacondaBlocker 526956
  Show dependency treegraph
 
Reported: 2009-04-20 20:48 EDT by Mike Wolf
Modified: 2011-03-14 13:32 EDT (History)
33 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 526956 (view as bug list)
Environment:
Last Closed: 2010-01-18 11:12:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (483.34 KB, text/plain)
2009-04-20 20:48 EDT, Mike Wolf
no flags Details
Attached traceback automatically from anaconda. (177.98 KB, text/plain)
2009-04-20 21:06 EDT, Mike Wolf
no flags Details
Attached traceback automatically from anaconda. (1.31 MB, text/plain)
2009-04-23 12:32 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (177.42 KB, text/plain)
2009-04-23 16:03 EDT, Morgan Olausson
no flags Details
Attached traceback automatically from anaconda. (200.24 KB, text/plain)
2009-04-29 06:28 EDT, Patrick C. F. Ernzer
no flags Details
Anaconda dump log (415.71 KB, text/plain)
2009-04-29 10:58 EDT, IBM Bug Proxy
no flags Details
Attached traceback automatically from anaconda. (206.29 KB, text/plain)
2009-05-02 15:10 EDT, eric@christensenplace.us
no flags Details
Anaconda dump log (116.17 KB, text/plain)
2009-05-12 07:43 EDT, IBM Bug Proxy
no flags Details
Attached traceback automatically from anaconda. (234.03 KB, text/plain)
2009-05-12 12:27 EDT, Patrick Stanistreet
no flags Details
Attached traceback automatically from anaconda. (177.82 KB, text/plain)
2009-05-13 21:24 EDT, Mike Wolf
no flags Details
Attached traceback automatically from anaconda. (152.35 KB, text/plain)
2009-05-19 10:25 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (656.72 KB, text/plain)
2009-05-20 22:12 EDT, Don Bower
no flags Details
Attached traceback automatically from anaconda. (190.07 KB, text/plain)
2009-05-24 09:19 EDT, Beartooth
no flags Details
Anaconda dump log (143.06 KB, text/plain)
2009-06-01 03:04 EDT, IBM Bug Proxy
no flags Details
Attached traceback automatically from anaconda. (244.97 KB, text/plain)
2009-06-11 16:02 EDT, Don Bower
no flags Details
Attached traceback automatically from anaconda. (93.39 KB, text/plain)
2009-06-13 19:34 EDT, Whorehay
no flags Details
Attached traceback automatically from anaconda. (263.44 KB, text/plain)
2009-06-14 13:25 EDT, howe.howie
no flags Details
Attached traceback automatically from anaconda. (232.26 KB, text/plain)
2009-06-15 14:55 EDT, David W. Legg
no flags Details
Attached traceback automatically from anaconda. (168.27 KB, text/plain)
2009-06-15 18:50 EDT, Whorehay
no flags Details
Attached traceback automatically from anaconda. (193.59 KB, text/plain)
2009-06-18 07:59 EDT, Brian Marsden
no flags Details
Attached traceback automatically from anaconda. (154.69 KB, text/plain)
2009-06-18 20:27 EDT, howe.howie
no flags Details
Attached traceback automatically from anaconda. (216.44 KB, text/plain)
2009-07-01 11:04 EDT, Mathieu Baudier
no flags Details
Attached traceback automatically from anaconda. (583.14 KB, text/plain)
2009-07-09 15:17 EDT, David Aquilina
no flags Details
Attached traceback automatically from anaconda. (173.58 KB, text/plain)
2009-07-10 07:49 EDT, rune_grysbaek
no flags Details
Attached traceback automatically from anaconda. (190.96 KB, text/plain)
2009-07-26 23:43 EDT, Dick Dunbar
no flags Details
Attached traceback automatically from anaconda. (155.68 KB, text/plain)
2009-07-27 20:08 EDT, Chandrasekar Kannan
no flags Details
Attached traceback automatically from anaconda. (170.54 KB, text/plain)
2009-08-12 09:48 EDT, masterson.andrew
no flags Details
Attached traceback automatically from anaconda. (310.88 KB, text/plain)
2009-08-14 17:40 EDT, Kevin Baker
no flags Details
Attached traceback automatically from anaconda. (229.42 KB, text/plain)
2009-08-25 15:30 EDT, Scott Dodson
no flags Details
F12 alpha: anaconda log file (267.84 KB, text/plain)
2009-08-27 04:40 EDT, IBM Bug Proxy
no flags Details
Attached traceback automatically from anaconda. (298.71 KB, text/plain)
2009-10-30 21:24 EDT, Andrew Jamison
no flags Details
Attached traceback automatically from anaconda. (220.32 KB, text/plain)
2010-02-12 09:47 EST, bethebeast
no flags Details
Attached traceback automatically from anaconda. (128.53 KB, text/plain)
2011-03-14 13:32 EDT, Eric Lavoie
no flags Details

  None (edit)
Description Mike Wolf 2009-04-20 20:48:01 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.46 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 357, in lvcreate
    raise LVMError("lvcreate failed for %s/%s" % (vg_name, lv_name))
  File "/usr/lib/anaconda/storage/devices.py", line 2035, in create
    lvm.lvcreate(self.vg.name, self._name, self.size)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 203, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 658, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 234, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 117, in turnOnFilesystems
    anaconda.id.storage.doIt()
LVMError: lvcreate failed for vg_gx2701/lv_root
Comment 1 Mike Wolf 2009-04-20 20:48:10 EDT
Created attachment 340459 [details]
Attached traceback automatically from anaconda.
Comment 2 Mike Wolf 2009-04-20 21:06:11 EDT
Created attachment 340462 [details]
Attached traceback automatically from anaconda.
Comment 3 Mike Wolf 2009-04-20 21:40:34 EDT
Install is from boot.iso dated 4/20/2009.  Dell Optiplex GX270, 40 GB hard drive.


I'm going to give the "easy" way to recreate this bug, and then the realistic way.  Each has a slightly different expected result, but both have the same actual result.

"Easy Way"

1.  Install from boot.iso (anaconda 11.5.0.46).
2.  When you get to the drive layout screen, select "replace existing Linux system" and "Review and modify partitioning layout",  then click "Next".
3.  Click "New".
4.  Under "Mount Point", enter "/home" (without quotes).
5.  Click "Fill to maximum allowable size" and click "OK".
6.  Click "Next".
7.  After a few seconds, you'll get an error, with the option of filing a bug.  You'll find the traceback above.

You'll notice after step #5 that the size listed for /dev/sda2 and its logical volume group shrink considerably (mine went from 37946 MB to 188 MB), but the logical volumes within the volume group DO NOT shrink, and thus are larger than their group.  I expected it to show a dialogue box indicating "There is no available room on this device", or something to that effect, since I had not created space on the drive before creating a new partition.  Instead, it incorrectly resized another partition.


Now for the "Realistic" way.

1.  Do steps 1-2 above.
2.  Select the "lv_root" logical volume, then click "Edit".
3.  In the "Edit LVM Volume Group" window, select "lv_root" and click "Edit".
4.  Change the size to 10240 MB and click "OK".
5.  Select "lv_swap" and click "Edit"
6.  Change the size to 2048 MB and click "OK". (You can change it to whatever you want... This is the number I was using).
7.  Do steps 3-7 above.

The idea here was to create a separate partition for /home with the space I had removed from the volume group.  Since I didn't have a calculator handy, I figured the "Fill to maximum allowable size" option would use exactly the remaining space.  So, in this case expected result was to create a new partition with a size less than or equal to the remaining space on the drive.  I say "less than" in case the remaining space isn't exactly divisible by the extent size.

Additional info: This bug presents whether "encrypt disk" is selected or not.
Comment 4 David Lehman 2009-04-21 11:48:05 EDT
This appears to be a real bug, but what you are trying to do will not work even after the bug is fixed. You are trying to reclaim disk space by changing the sizes of LVs, but to reclaim disk space what you need to shrink is the PVs, which will in turn shrink the VG. However, once the PVs are part of a VG you can no longer edit them. What you will need to do is remove the LVs, remove the VG, resize the PV(s), then rebuild the VG and LVs and /home partition.
Comment 5 Mike Wolf 2009-04-21 19:43:06 EDT
Oh...  Oops :)  I guess since anaconda automatically shrunk the PV when I calculated everything else myself I thought that that's what was supposed to happen...  So it wasn't a bug, it was a feature! :)
Comment 6 David Lehman 2009-04-21 20:07:05 EDT
What should have happened when you clicked "OK" on the dialog to create /home is you should have gotten a popup that said "Not enough free space" or similar, and then dropped you back to the partitioning screen. This is because the disks have been fully allocated and, since the /boot request has a fixed size and the PVs are part of a VG, none of the partitions can be altered (resized).

It does not automatically shrink your PVs/VG to match the sizes of your LVs because it cannot know if you are preparing to add another LV, or if you just want to leave some space in the VG for whatever reason.
Comment 7 Mike Wolf 2009-04-21 20:16:29 EDT
Sorry, Dave... that was my failed attempt at humor :)  I understand, and will do this properly from now on.  Thanks for your help!
Comment 8 Radek Vykydal 2009-04-22 07:23:42 EDT
(In reply to comment #4)
> This appears to be a real bug, but what you are trying to do will not work even
> after the bug is fixed. You are trying to reclaim disk space by changing the
> sizes of LVs, but to reclaim disk space what you need to shrink is the PVs,
> which will in turn shrink the VG. However, once the PVs are part of a VG you
> can no longer edit them. What you will need to do is remove the LVs, remove the
> VG, resize the PV(s), then rebuild the VG and LVs and /home partition.  

For VGs on growing PVs (which are in comment #3 i think), you don't have to
take these steps necessarily. But Mike's steps probably wouldn't work even after
the bug is fixed. (I am working on patch to check that there is enough space for
allocated LVs when adding a partition that would make their PVs(VGs) grow less)
because he wanted to create /home with "Fill to maximum allowable
size" which wouldn't work as he expected. But there is a way to create /home
without removing VG if the VG lies on growing PV (e.g. default PV holding
/ and swap):

Reduce sizes of LVs (e.g. of '/') by amount sufficient to satisfy
added partition request. The thing is that the sufficient amount is not obvious:
In simple case with one growing PV, the amount is the size specified
for new partition (/home). If the new partition is growing ("Fill
to maximum allowable size"), or if more growing PVs come into play,
the sufficient amount depends on how partition growing algorithm
distributes free space between all growing partitions
(including the new one) - that is, how much growing PVs will get
shrinked by added partition.
Comment 9 Radek Vykydal 2009-04-22 12:58:57 EDT
(In reply to comment #8)
> (In reply to comment #4)

> > This appears to be a real bug, but what you are trying to do will not work even
> > after the bug is fixed. You are trying to reclaim disk space by changing the
> > sizes of LVs, but to reclaim disk space what you need to shrink is the PVs,
> > which will in turn shrink the VG. However, once the PVs are part of a VG you
> > can no longer edit them. What you will need to do is remove the LVs, remove the
> > VG, resize the PV(s), then rebuild the VG and LVs and /home partition.  
> 
> For VGs on growing PVs (which are in comment #3 i think), you don't have to
> take these steps necessarily.

OK, as I learned you will have to, Dave has a patch which will ensure
this more sensible behavior wrt growing PVs.
Comment 10 James Laska 2009-04-23 12:32:53 EDT
Created attachment 340964 [details]
Attached traceback automatically from anaconda.
Comment 11 Morgan Olausson 2009-04-23 16:03:22 EDT
Created attachment 341002 [details]
Attached traceback automatically from anaconda.
Comment 12 Patrick C. F. Ernzer 2009-04-29 06:28:27 EDT
Created attachment 341734 [details]
Attached traceback automatically from anaconda.
Comment 13 Patrick C. F. Ernzer 2009-04-29 06:31:17 EDT
Comment #12 was F11 Preview on a FSC PRIMERGY Econel 230R S1
Comment 14 Chris Lumens 2009-04-29 10:46:49 EDT
*** Bug 498234 has been marked as a duplicate of this bug. ***
Comment 15 IBM Bug Proxy 2009-04-29 10:58:33 EDT
Created attachment 341767 [details]
Anaconda dump log
Comment 16 eric@christensenplace.us 2009-05-02 15:10:29 EDT
Created attachment 342190 [details]
Attached traceback automatically from anaconda.
Comment 17 Chris Lumens 2009-05-08 16:15:35 EDT
This should be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 18 Jon Masters 2009-05-10 12:58:20 EDT
There is a very similar bug in Anaconda in F11 Preview. If you try to resize /boot (to make room for testing kernels) then Anaconda will happily accept the resized volume during partitioning, but will then end up with a volume group containing volumes that exceed the new size of the group - common failure is resizing /boot leads to last volume "swap" being too big within the group.

I think this is a fairly annoying bug, though there is a workaround of going into the groups each time and resizing their members manually.
Comment 19 James Laska 2009-05-11 16:26:27 EDT
A fix for this issue is available in the latest Rawhide build.  

Can you confirm that this issue is no longer present?  For information on downloading and installing rawhide, see https://fedoraproject.org/wiki/Releases/Rawhide#Direct_Rawhide_install.
Comment 20 IBM Bug Proxy 2009-05-12 07:43:29 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-05-12 07:30 EDT-------
(In reply to comment #17)
> A fix for this issue is available in the latest Rawhide build.
>
> Can you confirm that this issue is no longer present?  For information on
> downloading and installing rawhide, see
> https://fedoraproject.org/wiki/Releases/Rawhide#Direct_Rawhide_install.
>

I could still reproduce this in latest rawhide build. Not sure latest build has issue this fixed.

Thanks
Pavan
Comment 21 IBM Bug Proxy 2009-05-12 07:43:38 EDT
Created attachment 343569 [details]
Anaconda dump log


------- Comment (attachment only) From pavan.naregundi@in.ibm.com 2009-05-12 07:31 EDT-------
Comment 22 Patrick Stanistreet 2009-05-12 12:27:35 EDT
Created attachment 343620 [details]
Attached traceback automatically from anaconda.
Comment 23 Mike Wolf 2009-05-13 21:24:58 EDT
Created attachment 343900 [details]
Attached traceback automatically from anaconda.
Comment 24 Mike Wolf 2009-05-13 21:33:50 EDT
Comment #23 is from an install using boot.iso dated 2009-05-08.  When I check the i386 mirrors (like Virginia Tech), the latest package of anaconda available was last updated 2009-05-08 (version 11.5.0.51-1), so I'm making the assumption that this package was on the 2009-05-08 boot.iso, and that no later version of anaconda is available in a later boot.iso.  If I am incorrect, please let me know.  If not -- it's still broken.  I used the "Easy Method" of recreating the error, as described in Comment #3.
Comment 25 David Lehman 2009-05-13 22:09:03 EDT
This required a fix to parted, which made it into version 1.8.8-17. This parted package seems to have been built on 08 May, so it would not be in the rawhide trees for that day.

When I get a chance I'll try to reproduce this on my own here.
Comment 26 David Lehman 2009-05-14 20:35:36 EDT
I retested and got past this problem, but then ran into bug 499459. I am working on a fix for that issue now.
Comment 27 Mike Wolf 2009-05-15 18:40:21 EDT
I just retested with boot.iso 2009-05-14 with anaconda 11.5.0.52, and the bug has been fixed.  Thanks!

Mike
Comment 28 IBM Bug Proxy 2009-05-18 02:33:27 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-05-18 02:27 EDT-------
Retested with latest rawhide(anaconda 11.5.0.52). This issue seems to be fixed now.
Comment 29 James Laska 2009-05-18 07:34:59 EDT
Thanks for the feedback Mike and Pavan.
Comment 30 James Laska 2009-05-19 10:25:31 EDT
Created attachment 344624 [details]
Attached traceback automatically from anaconda.
Comment 31 James Laska 2009-05-19 10:28:17 EDT
Reproduced this bug on an IBM Power5 with rawhide-20090519 (includes anaconda-11.5.0.52 and pyparted-2.0.12-1).

Is there another exposure window for this issue (see attached traceback in comment#30)?
Comment 32 Will Woods 2009-05-19 18:57:06 EDT
Tried to reproduce this on i586 with anaconda-11.5.0.53, following the "Realistic" reproducer from comment #3. Install completed successfully.
Comment 33 James Laska 2009-05-20 08:11:18 EDT
Okay, moving this back to CLOSED RAWHIDE.  SaveToBugzilla definitely found this issue and logged it against anaconda-11.5.0.52, but perhaps something else is lurking.  I'll continue testing on that platform to trigger this issue.

Based on Mike, Pavan and Will's feedback, moving back to CLOSED RAWHIDE.

Thanks!
Comment 34 Don Bower 2009-05-20 22:12:04 EDT
Created attachment 344908 [details]
Attached traceback automatically from anaconda.
Comment 35 Beartooth 2009-05-24 09:19:26 EDT
Created attachment 345243 [details]
Attached traceback automatically from anaconda.
Comment 36 Beartooth 2009-05-24 09:34:59 EDT
  I've burned the same .iso at least twice, with K3B and iirc Brasero; it had been downloaded from http://mirrors.kernel.org/fedora/releases/test/11-Preview/Live/i686/F11-Preview-i686-Live.iso on or shortly before 5/23/09. Length 644.7 MB (675987456 bytes)

  I did fiddle with trying to create a /home, around 1/4 - 1/2 the size of the hard drive. Will try again with no fiddling. (I told it "review & modify," but only looked; it appeared to intend putting almost all space into /root.
Comment 37 Beartooth 2009-05-24 11:21:56 EDT
  I've burned the same .iso at least twice, with K3B and iirc Brasero; it had been downloaded from http://mirrors.kernel.org/fedora/releases/test/11-Preview/Live/i686/F11-Preview-i686-Live.iso on or shortly before 5/23/09. Length 644.7 MB (675987456 bytes)

  I did fiddle with trying to create a /home, around 1/4 - 1/2 the size of the hard drive. Will try again with no fiddling. (I told it "review & modify," but only looked; it appeared to intend putting almost all space into /root.
Comment 38 Beartooth 2009-05-24 11:29:48 EDT
  Without fiddling, it did install. Rebooting was odd -- it failed to eject the medium, *and* to finish shutting down. I had to use the shutdown button, *and* the three-finger salute, *and* finally the power button (but not remove the electric cord nor the battery). Then I got the medium out with a paper clip. 

   After that, however, it booted into Firstboot, and completed normally. I'm now adding and removing software before doing an update.
Comment 39 Mike Wolf 2009-05-24 12:18:02 EDT
Beartooth,

While you downloaded the file on May 23, the F11-Preview iso was created on April 24.  This bug was fixed in early May, and the Preview disk does not get updated.  If you want to retest, you'll need to download the latest rawhide from:

http://mirrors.kernel.org/fedora/development/i386/os/images/

Download the file labeled "boot.iso".  This image basically only includes the installer, so it will download all other packages from the repo when you do the install.

Mike
Comment 40 IBM Bug Proxy 2009-06-01 03:04:23 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-06-01 02:50 EDT-------
This issue is again seen on latest Fedora 11 Rawhide.

Machine: P550
CPU Type: power 5

Steps:
1. Start the f11 rawhide installation.
2. Choose "Use Entire Disk" at partition stage. Anaconda trace gets generated

Attaching the anaconda dump log in next comment.

Thanks
Pavan
Comment 41 IBM Bug Proxy 2009-06-01 03:04:35 EDT
Created attachment 346058 [details]
Anaconda dump log


------- Comment (attachment only) From pavan.naregundi@in.ibm.com 2009-06-01 02:52 EDT-------
Comment 42 Don Bower 2009-06-11 16:02:30 EDT
Created attachment 347466 [details]
Attached traceback automatically from anaconda.
Comment 43 Whorehay 2009-06-13 19:34:53 EDT
Created attachment 347788 [details]
Attached traceback automatically from anaconda.
Comment 44 howe.howie 2009-06-14 13:25:08 EDT
Created attachment 347841 [details]
Attached traceback automatically from anaconda.
Comment 45 David W. Legg 2009-06-15 14:55:39 EDT
Created attachment 347986 [details]
Attached traceback automatically from anaconda.
Comment 46 Whorehay 2009-06-15 18:50:57 EDT
Created attachment 348026 [details]
Attached traceback automatically from anaconda.
Comment 47 Brian Marsden 2009-06-18 07:59:47 EDT
Created attachment 348422 [details]
Attached traceback automatically from anaconda.
Comment 48 howe.howie 2009-06-18 20:27:04 EDT
Created attachment 348587 [details]
Attached traceback automatically from anaconda.
Comment 50 Morgan Olausson 2009-06-22 12:05:35 EDT
Hi, to me it seems like the options presented at installation does not suit all user cases. Perhaps the menuoptions presented at installation needs to be updated to the "LVM-world" realities. I mean that since a linux LVM system can be on two HD:s, the installation options get a bit confusing. For me at least "use entire disc" sound like a bigger thing than "replace a linux system"(forgot the exact phrase). Could it be some very high level logical error hidden here somewhere?

Probably I am very far out in the blue about this, but I got this feeling and wanted to put some attention to the possibility.

Keep up the good work. Fedora11 is really quick on my old computer :-)
Comment 52 Mike Wolf 2009-06-22 19:04:14 EDT
I'm reopening, due to the number of people who are still having this issue with what appears to be the release version of anaconda (ver. 11.5.0.59).  I'm also changing to F11 instead of rawhide.  Please correct if this is wrong.

Could somebody please report how to recreate this error using the release install media?

Mike
Comment 53 Morgan Olausson 2009-06-23 14:21:51 EDT
When I installed F11 (release) I had to try it a few times before success. I got different fault messages (This LVM-error where among them, i don't remember the other(s)). So comment #51 about lingering metadata make sense to me.

comment #52
"Could somebody please report how to recreate this error using the release
install media?"

I had Ubuntu 9.04 (lvm-installation) on one HD, and fedora on the other HD when I tried to install F11-release version and got a lvm-error.
Comment 54 Mathieu Baudier 2009-07-01 11:04:00 EDT
Created attachment 350132 [details]
Attached traceback automatically from anaconda.
Comment 55 David Aquilina 2009-07-09 15:17:48 EDT
Created attachment 351122 [details]
Attached traceback automatically from anaconda.
Comment 57 rune_grysbaek 2009-07-10 07:49:58 EDT
Created attachment 351249 [details]
Attached traceback automatically from anaconda.
Comment 58 Dick Dunbar 2009-07-26 23:43:44 EDT
Created attachment 355226 [details]
Attached traceback automatically from anaconda.
Comment 59 Dick Dunbar 2009-07-26 23:50:37 EDT
Comment on attachment 355226 [details]
Attached traceback automatically from anaconda.

Re-Install on Dell Optiplex 745.  Base 232GB Sata0 disk contained WinXP is target install/boot drive.

WD 2TB disk attached to Silicon Image Sata controller.

Successfully installed Fedora 11 to WD disk.  Now switching to 250GB disk for base/boot, and it is failing.

Any workarounds?  My first Bugzilla report.  Will keep searching.
Comment 60 Dick Dunbar 2009-07-27 00:21:49 EDT
anaconda 11.5.0.59

I bypassed the error by:
1. eliminating second 2TB disk from the install
2. Switching from "replace linux" to "use entire disk"
   on the Sata0 250BGB disk.

I'll add the second disk in as a filesystem later.
Comment 61 Chandrasekar Kannan 2009-07-27 20:08:53 EDT
Created attachment 355339 [details]
Attached traceback automatically from anaconda.
Comment 62 masterson.andrew 2009-08-12 09:48:32 EDT
Created attachment 357174 [details]
Attached traceback automatically from anaconda.
Comment 63 Kevin Baker 2009-08-14 17:40:06 EDT
Created attachment 357508 [details]
Attached traceback automatically from anaconda.
Comment 64 Scott Dodson 2009-08-25 15:30:02 EDT
Created attachment 358623 [details]
Attached traceback automatically from anaconda.
Comment 65 IBM Bug Proxy 2009-08-27 04:40:25 EDT
Created attachment 358824 [details]
F12 alpha: anaconda log file


------- Comment on attachment From pavan.naregundi@in.ibm.com 2009-08-27 04:28 EDT-------


This bug still exists in F12 Alpha(anconda 12.15).

Steps where I got this issue:

1. Start the installation in GUI mode
2. select custom partiition
3. partition layout looks similar to below
        * /dev/sda1 prep - 10M
        * /dev/sda2 / (ext4) - 30G
        * /dev/sda3 LVM - 32G
            (physical Extent  - 16M)
                * LogVol00 /ext4  (ext4) - 2G
                * LogVol01 /ext3  (ext3) - 17G
                * LogVol02 /xfs     (xfs)  - ~13G
        * /dev/sda4 Extended partition ~4541M
                * /dev/sda5 swap - 4G
                * free space 541M

After a retry, I did not face this issue with the same configuration. Looks like it is not easily reproducible.
Comment 66 Chris Lumens 2009-09-01 09:43:53 EDT
*** Bug 520624 has been marked as a duplicate of this bug. ***
Comment 67 Chris Lumens 2009-09-01 09:44:14 EDT
*** Bug 519529 has been marked as a duplicate of this bug. ***
Comment 68 Chris Lumens 2009-09-01 09:44:41 EDT
*** Bug 517537 has been marked as a duplicate of this bug. ***
Comment 69 IBM Bug Proxy 2009-09-03 02:28:59 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-09-03 02:18 EDT-------
Redhat, Any updates on this bug?
Comment 71 David Lehman 2009-10-14 02:07:34 EDT
Next time you hit this, please leave the system in the failure state so I can look around on it. If you want to start collecting information yourself, the output of the following commands would be useful:

  cat /proc/partitions
  for disk in /dev/sd[a-z] ; do parted $disk print ; done
  lvm pvs
  lvm vgs
  lvm lvs
Comment 72 Martin Banas 2009-10-14 07:35:27 EDT
Hi Dave,

I'm not able to reproduce this on RHEL6.0-20091006.0 with anaconda 12.34. If I found that error again, I'll get the requested info for you.
Comment 73 Andrew Jamison 2009-10-30 21:24:05 EDT
Created attachment 366890 [details]
Attached traceback automatically from anaconda.
Comment 74 IBM Bug Proxy 2010-01-15 09:57:30 EST
------- Comment From emachado@linux.vnet.ibm.com 2010-01-15 09:41 EDT-------
Thanks Pavan for retesting this. I'm closing this issue as unreproducible on Fedora 12.
Comment 75 David Lehman 2010-01-18 11:12:22 EST
Closing this on the basis of comment 74 along with the fact that nobody has reported seeing this problem on Fedora 12.
Comment 76 bethebeast 2010-02-12 09:47:54 EST
Created attachment 390499 [details]
Attached traceback automatically from anaconda.
Comment 77 Eric Lavoie 2011-03-14 13:32:12 EDT
Created attachment 484258 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.