Bug 519706 - packages.getDetails API support for multiple package checksums
Summary: packages.getDetails API support for multiple package checksums
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/API
Version: RHN Stable
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Sebastian Skracic
QA Contact: Red Hat Network Quality Assurance
URL:
Whiteboard: US81
: 522584 (view as bug list)
Depends On:
Blocks: 519193 rhn-sprint31
TreeView+ depends on / blocked
 
Reported: 2009-08-27 13:51 UTC by Sebastian Skracic
Modified: 2010-03-18 12:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-18 12:49:36 UTC


Attachments (Terms of Use)

Description Sebastian Skracic 2009-08-27 13:51:59 UTC
XMLRPC API must support new/multiple package/file checksums and provide
as much backward compatibility as possible.

Comment 1 Sebastian Skracic 2009-08-28 08:54:13 UTC
Support for multiple package checksums implemented in packages.getDetails via 6ca4562b1d117e882585b2fc21e1f7cd2a81e8e9 and 2b06c995b01d93cfc0460948726824ea270f75eb.

Comment 2 Sebastian Skracic 2009-09-02 18:51:54 UTC
The code is on webdev.

Comment 4 Sebastian Skracic 2009-09-10 18:30:28 UTC
*** Bug 522584 has been marked as a duplicate of this bug. ***

Comment 5 Grant Gainey 2009-09-18 14:56:23 UTC
TEST PLAN:
=========

1) identify an RPM which has MD% and at least one other checksum type defined for it in RHN
2) Get that package's package_id
3) Request that package's details via packages.getDetails <pid> call

EXPECTED BEHAVIOR:

1) package_md5sum key continues to return the md5 checksum for the package
2) package_checksums key returns a map of checksums, keyed by checksum type

EXAMPLE:
=======

callAnyMethod.py sskracicgit redhat packages.getDetails 315908
...
 'package_checksums': {'md5': 'f7890d88eb58fec2a5f868fbd6b4dc00',
                       'sha-256': '079469edbae9f94ba2f5fcb0d0cfe423a078d7852580306b4080399d200844db',
                       'sha-384': '80c3cad3c5b4181744acc593d9c649236437a513a395b9b8904bf226a3328bf783f985f6c8d7bf349daf14ba6b7e899d',
                       'sha-512': '1bb9cabc376d16b022d37d991b04ffa673ac2b7bf1dad026801fbff3fa20eea921652e6f74166c1edde9abe3a275eebed585da285de364744f9b378dc9ece981',
                       'sha1': '7b3eb1bc24b7f18020388e3106311a35fe5c9519'},
...
 'package_md5sum': 'f7890d88eb58fec2a5f868fbd6b4dc00',
...

Comment 6 Denise Hughes 2009-10-06 19:56:16 UTC
Verified on webdev


Note You need to log in before you can comment on or make changes to this bug.