Bug 519727 - Fedora11 Rawhide: Returning partitions to state prior to edit failed
Fedora11 Rawhide: Returning partitions to state prior to edit failed
Status: CLOSED DUPLICATE of bug 498026
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc64 All
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-27 11:10 EDT by IBM Bug Proxy
Modified: 2009-08-27 11:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 11:19:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda log from fedora11 (201.29 KB, text/plain)
2009-08-27 11:10 EDT, IBM Bug Proxy
no flags Details
F12 alpha: anaconda log file (120.81 KB, text/plain)
2009-08-27 11:10 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 53857 None None None Never

  None (edit)
Description IBM Bug Proxy 2009-08-27 11:10:35 EDT
Installing F11 Rawhide failed during the partition phase giving traceback as shown bellow

====================
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1134, in editPartition
    raise RuntimeError, ("Returning partitions to state "
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1080, in editCB
    self.editPartition(device)
RuntimeError: Returning partitions to state prior to edit failed
=====================

Machine: P510
CPU Type: power5

Steps:
1. Start f11 rawhide installation with vnc
2. Select "Use entire drive" in partitioning. This option should not leave any free space on the disk.
        * Also check for review and modify partitioning layout
        * Pressing next should be able to partition information. 
3. Select one the partition and press 'Edit'
4. Increase the size of the partition and press OK. 
       * This should give an error of saying " not enough free space on disk". Which is expected.
5. Now click on 'OK' for the error. This should generate the above mentioned exception report.

Attaching the anaconda log

This issue is still seen F12 alpha.
Comment 1 IBM Bug Proxy 2009-08-27 11:10:45 EDT
Created attachment 358890 [details]
anaconda log from fedora11
Comment 2 IBM Bug Proxy 2009-08-27 11:10:58 EDT
Created attachment 358891 [details]
F12 alpha: anaconda log file
Comment 3 Andy Lindeberg 2009-08-27 11:19:11 EDT

*** This bug has been marked as a duplicate of bug 498026 ***

Note You need to log in before you can comment on or make changes to this bug.