Bug 498026 - RuntimeError: Returning partitions to state prior to edit failed
RuntimeError: Returning partitions to state prior to edit failed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:8da14ed36d58b62b5...
:
: 502092 519212 519727 526573 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker F12Beta/F12BetaBlocker
  Show dependency treegraph
 
Reported: 2009-04-28 10:53 EDT by Tomasz Torcz
Modified: 2013-01-10 00:11 EST (History)
16 users (show)

See Also:
Fixed In Version: anaconda-12.36-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 18:44:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (157.83 KB, text/plain)
2009-04-28 10:53 EDT, Tomasz Torcz
no flags Details
Attached traceback automatically from anaconda. (681.17 KB, text/plain)
2009-05-14 02:17 EDT, A S Alam
no flags Details
Attached traceback automatically from anaconda. (135.13 KB, text/plain)
2009-05-30 14:28 EDT, Pasi Karkkainen
no flags Details
anaconda log from fedora11 (201.29 KB, text/plain)
2009-08-27 11:25 EDT, IBM Bug Proxy
no flags Details
F12 alpha: anaconda log file (120.81 KB, text/plain)
2009-08-27 11:25 EDT, IBM Bug Proxy
no flags Details
Attached traceback automatically from anaconda. (293.82 KB, text/plain)
2009-09-08 15:47 EDT, David Pravec
no flags Details
anaconda log (165.80 KB, text/plain)
2009-09-25 07:02 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description Tomasz Torcz 2009-04-28 10:53:44 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.47 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1122, in editPartition
    raise RuntimeError, ("Returning partitions to state "
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1068, in editCB
    self.editPartition(device)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 943, in treeActivateCB
    self.editCB()
RuntimeError: Returning partitions to state prior to edit failed
Comment 1 Tomasz Torcz 2009-04-28 10:53:55 EDT
Created attachment 341583 [details]
Attached traceback automatically from anaconda.
Comment 2 Tomasz Torcz 2009-04-28 11:00:19 EDT
What I did:
I started with both drives empty, only with MSDOS partition table.
I selected automatic layout and opted to modify.
I removed VGs.
I changed PV on second drive into 8GB partition, mount on /, type btrfs, selected sda and sdb as allowable drives and 8192MB as fixed size.
Then I edited PV on first drive with exact sam information (/, btrfs, both drives, 8192 fixed). 
At this point I got exception.

What was expected:
I expected to have / with btrfs filesystem spanning over sda2 and sdb1. I also expected question if I want RAID0 or RAID1 withing btrfs over those partitions.
Comment 3 David Lehman 2009-04-28 13:02:59 EDT
Thanks for the report.

(In reply to comment #2)
> What was expected:
> I expected to have / with btrfs filesystem spanning over sda2 and sdb1. I also
> expected question if I want RAID0 or RAID1 withing btrfs over those partitions.  

None of what you expected is going to work. We only support the creation of btrfs filesystems on a single block device, just like all other filesystems.
Comment 4 A S Alam 2009-05-14 02:17:24 EDT
Created attachment 343913 [details]
Attached traceback automatically from anaconda.
Comment 5 Pasi Karkkainen 2009-05-30 14:28:05 EDT
Created attachment 345979 [details]
Attached traceback automatically from anaconda.
Comment 6 Chris Lumens 2009-06-08 16:20:13 EDT
*** Bug 502092 has been marked as a duplicate of this bug. ***
Comment 7 Bug Zapper 2009-06-09 10:42:29 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Andy Lindeberg 2009-08-25 12:56:38 EDT
*** Bug 519212 has been marked as a duplicate of this bug. ***
Comment 9 Andy Lindeberg 2009-08-27 11:19:11 EDT
*** Bug 519727 has been marked as a duplicate of this bug. ***
Comment 10 IBM Bug Proxy 2009-08-27 11:25:41 EDT
Created attachment 358893 [details]
anaconda log from fedora11
Comment 11 IBM Bug Proxy 2009-08-27 11:25:57 EDT
Created attachment 358894 [details]
F12 alpha: anaconda log file
Comment 12 David Pravec 2009-09-08 15:47:37 EDT
Created attachment 360123 [details]
Attached traceback automatically from anaconda.
Comment 13 IBM Bug Proxy 2009-09-25 07:02:11 EDT
Created attachment 362657 [details]
anaconda log


------- Comment on attachment From pavan.naregundi@in.ibm.com 2009-09-25 06:58 EDT-------


Still seeing this issue in latest rawhide with anaconda 12.26.

RedHat, Any updates on this?
Comment 14 David Lehman 2009-09-25 10:50:56 EDT
Can you please provide a detailed description of the process to reproduce this behavior?
Comment 15 Robert Townley 2009-09-30 10:17:35 EDT
I have had several instances of Bug 502092.

Installing to a fresh machine but simply wanted to increase the size of /boot from 200MB to 1000.  This fails saying there is not enough free space, but instead of allowing me to reduce the other partition/vg, it crashes.

HP DL 380 G4 with 2 300GB hot plug SCA scsi drives in a mirror.
Comment 16 Chris Lumens 2009-10-01 11:54:04 EDT
*** Bug 526573 has been marked as a duplicate of this bug. ***
Comment 17 IBM Bug Proxy 2009-10-05 02:22:16 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-10-05 02:19 EDT-------
(In reply to comment #21)
> Can you please provide a detailed description of the process to reproduce this
> behavior?
>

One of the way to reproduce this bug,
Steps:
1. Start f12 rawhide installation with vnc
2. Select "Use entire drive" in partitioning. This option should not leave any
free space on the disk.
* Also check for review and modify partitioning layout
* Pressing next should be able to partition information.
3. Select one the partition and press 'Edit'
4. Increase the size of the partition and press OK.
* This should give an error of saying " not enough free space on disk". Which
is expected.
5. Now click on 'OK' for the error. This will crash the anaconda.
Comment 18 Alexey Torkhov 2009-10-09 11:05:13 EDT
Listing as beta blocker, pretty annoying bug.
Comment 19 Alexey Torkhov 2009-10-09 12:45:36 EDT
I'm getting sometimes this error when editing (and saving as is) partition when disk is full (tracebacks are in bug# 519212).
Comment 20 James Laska 2009-10-09 16:31:54 EDT
Unable to reproduce the problem when testing anaconda-12.35 + http://dlehman.fedorapeople.org/updates-498026.img.
Comment 21 David Lehman 2009-10-09 18:20:40 EDT
Fixed in anaconda-12.36-1.
Comment 22 Jesse Keating 2009-10-12 18:44:05 EDT
That anaconda has been tagged.
Comment 23 IBM Bug Proxy 2009-10-26 09:06:56 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-10-26 01:59 EDT-------
Tested with F12 rawhide having anaconda 12.39. I confirm that the issue is fixed now.

Thanks
Comment 24 James Laska 2009-10-27 10:41:39 EDT
Thanks for the feedback Pavan!
Comment 25 James Laska 2009-10-28 16:32:57 EDT
anaconda-12.39-1 failure (see anacdump.txt in attachment#366492 [details])

1) First, do this - https://fedoraproject.org/wiki/QA/TestCases/PartitioningExt4OnNativeDevice
2) After that install, do this - https://fedoraproject.org/wiki/QA:Testcase_Anaconda_autopart_%28shrink%29_install
3) There will be 2 'PPCPReP Boot' Partitions, I clicked "EDIT" on the original partition and chose to format it again.  Click OK

Crash.
Comment 26 Adam Williamson 2009-10-28 17:30:44 EDT
Well, either re-open this bug or file a new one? New comments on closed bugs have a tendency to get lost in the shuffle...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 27 James Laska 2009-10-28 18:18:01 EDT
Comment#25 opened as bug#531629

Note You need to log in before you can comment on or make changes to this bug.