Bug 520013 - Won't restore when started after fresh install
Summary: Won't restore when started after fresh install
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 521533 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-28 00:36 UTC by Mike Chambers
Modified: 2009-09-08 02:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-28 12:51:16 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 590687 0 None None None Never

Description Mike Chambers 2009-08-28 00:36:48 UTC
Description of problem:When program is started initially after an install, it keeps starting over instead of accepting the restore.


Version-Release number of selected component (if applicable):evolution-2.27.91-1.fc12.x86_64


How reproducible:Always


Steps to Reproduce:
1.Fresh install of F12 Alpha or rawhide
2.Start evolution for first time
3.Select to restore when program first starts
  
Actual results:Program doesn't accept the restore and starts all over again asking to restore or create new identity.


Expected results:Should restore to a certain point depending on what backup file you have.


Additional info:Problem has been the same for the last few weeks.

Comment 1 Milan Crha 2009-08-28 08:15:00 UTC
When you setup your account by hand finally (I guess you did), can you restore from that backup file after that? (File->Restore Settings). I'm wondering whether the archive isn't corrupted or any other content check didn't fail on it.
You can run evolution from console and see messages printed there for more detailed information what the backup-restore plugin does.

Comment 2 Mike Chambers 2009-08-28 09:27:42 UTC
Made a test account and tried starting evo from scratch on it via console, and below is the output..

[test@scrappy ~]$ evolution
** (evolution:9869): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:9869): DEBUG: mailto URL program: evolution
** Message: First result 0
.evolution/
** Message: Second result 0
.evolution/backup-restore-gconf.xml
** Message: Third result 0
** Message: Sanity check result 1:0 0
** Message: First result 0
.evolution/
** Message: Second result 0
.evolution/backup-restore-gconf.xml
** Message: Third result 0
** Message: Cannot restore from an incorrect archive '/home/download/evolution-backup.tar.gz'.
** Message: evolution
[test@scrappy ~]$ ** (evolution:9925): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:9925): DEBUG: mailto URL program: evolution
^C

Been backing up and restoring (same /path/to/file) for few versions of Fedora now with no problems.  F12 is the first time been having problems.  And no it won't accept the restore if I create the evo account by hand.  I even did a backup from my newly created account and tried to restore it and no go.

Comment 3 Milan Crha 2009-08-28 11:26:10 UTC
Thanks for a quick update.

(In reply to comment #2)
> ...
> ** Message: Cannot restore from an incorrect archive
> '/home/download/evolution-backup.tar.gz'.
> ...
> I even did a
> backup from my newly created account and tried to restore it and no go.  

It seems some test failed on the archive structure. I'm investigating more.

Comment 4 Milan Crha 2009-08-28 12:43:48 UTC
OK, searched the code and tested on my F11 machine, and even I see pretty similar output, it works, it restores from the backup properly. But it's F11, not a rawhide.

Comment 5 Milan Crha 2009-08-28 12:51:16 UTC
Oops, no, I see the same, I'm sorry for confusion, I overlooked that.

Here's an upstream bug [1] about very the same, thus upstreaming, for better visibility..

[1] http://bugzilla.gnome.org/show_bug.cgi?id=590687

Comment 6 Milan Crha 2009-09-07 11:02:12 UTC
*** Bug 521533 has been marked as a duplicate of this bug. ***

Comment 7 Mike Chambers 2009-09-08 02:05:59 UTC
The version in koji, or should be rawhide in the next day or two has the fix for this problem.

evolution-2.27.92-1.fc12.x86_64


Note You need to log in before you can comment on or make changes to this bug.