Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 520143 - network service: hibernate - No network connection - network service is stopped
Summary: network service: hibernate - No network connection - network service is stopped
Keywords:
Status: CLOSED DUPLICATE of bug 527641
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 11
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-28 15:44 UTC by jimmyp2
Modified: 2014-03-17 03:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-07 16:06:23 UTC
Type: ---


Attachments (Terms of Use)
content of /var/log/messages (10.28 KB, text/plain)
2009-08-28 15:44 UTC, jimmyp2
no flags Details

Description jimmyp2 2009-08-28 15:44:51 UTC
Created attachment 359089 [details]
content of /var/log/messages

Description of problem:
After hibernation there is no  network connection after system's startup - must manually start network service.


Version-Release number of selected component (if applicable):
kernel : 2.6.29.6-217.2.16.fc11.i686.PAE

How reproducible:
Always

Steps to Reproduce:
1. hibernate laptop
2. restart laptop

Actual results:
No network connection - network service is stopped

Expected results:
Network connection with Network Service started as usual after reboot.


Additional info:
I always have network manager component(service) disabled. When restarting or shutting down laptop normally network service starts without problems next time laptop is reactivated. However, when hibernating, i must manually start Network Service (service network start) from terminal which then works as expected.
Laptop model : Fujitsu-Siemens Amilo pi1536

Comment 1 Dan Williams 2009-11-07 03:59:01 UTC
ACtually I don't think the 'network' service does this automatically, that's the whole point of NetworkManager; it's a daemon that notices these things and handles them accordingly.  The network service just brings your device up and then quits, it doesn't respond to hibernate or other events.

In any case, over to initscripts...

Comment 2 iarly selbir 2009-11-07 05:24:02 UTC
your interfaces are configured with static or dynamic ( dhcp, etc ) address ??

This bug #527641 is about a problem with devices non-NM with DHCP and it now is on update-testing repository, if it's your problem try update.

please attach /var/log/messages for additional information.

--
Fedora Bugzappers Team Member

Comment 3 jimmyp2 2009-11-07 15:14:40 UTC
Hello,
i think that the problem looks similar to the one reported in the #527641 bug.
I use DHCP for my network connection. I'll try the solution(update) suggested by Iarly Selbir and see the results.


Thank you.

Comment 4 iarly selbir 2009-11-07 16:06:23 UTC

*** This bug has been marked as a duplicate of bug 527641 ***


Note You need to log in before you can comment on or make changes to this bug.