Bug 527641 - network does not come back after suspend/hibernate
network does not come back after suspend/hibernate
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
: 520143 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-07 01:49 EDT by Joachim Deguara
Modified: 2009-11-20 03:38 EST (History)
4 users (show)

See Also:
Fixed In Version: 4.1.0p1-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-20 00:35:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Deguara 2009-10-07 01:49:24 EDT
Description of problem:

networking stays down for DHCP non-NetworkManaged devices

Version-Release number of selected component (if applicable):

dhclient-4.1.0p1-2.fc11.i586

How reproducible:

100%

Steps to Reproduce:
1. suspend
2. resume
3. oops where is networking
  
Actual results:


Expected results:


Additional info:

The problem is in the file /usr/lib/pm-utils/sleep.d/56dhclient where line 46 uses ${DEVICE} to incorrectly read the variable from line 45 $device
Comment 1 David Cantrell 2009-10-12 22:22:28 EDT
Patch:

Index: 56dhclient
===================================================================
RCS file: /cvs/pkgs/rpms/dhcp/devel/56dhclient,v
retrieving revision 1.1
diff -u -p -r1.1 56dhclient
--- 56dhclient	6 Aug 2009 21:45:18 -0000	1.1
+++ 56dhclient	13 Oct 2009 02:21:56 -0000
@@ -43,7 +43,7 @@ resume_dhclient() {
 
     cd /etc/sysconfig/network-scripts
     while read device ; do
-        /sbin/ifup ${DEVICE}
+        /sbin/ifup ${device}
     done < ${PM_DHCLIENT_SUSPEND}
 
     /bin/rm -f ${PM_DHCLIENT_SUSPEND}
Comment 2 Fedora Update System 2009-10-13 06:44:28 EDT
dhcp-4.1.0p1-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/dhcp-4.1.0p1-5.fc11
Comment 3 Fedora Update System 2009-10-13 21:54:27 EDT
dhcp-4.1.0p1-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10478
Comment 4 iarly selbir 2009-11-07 11:06:23 EST
*** Bug 520143 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2009-11-10 12:48:33 EST
dhcp-4.1.0p1-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10478
Comment 6 Fedora Update System 2009-11-20 00:34:59 EST
dhcp-4.1.0p1-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.