Bug 520171 - Unable to reconnect the CDROM to an ISO after the first boot
Unable to reconnect the CDROM to an ISO after the first boot
Status: CLOSED DUPLICATE of bug 516116
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-08-28 14:03 EDT by Darryl L. Pierce
Modified: 2015-06-21 20:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-08-31 09:30:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Darryl L. Pierce 2009-08-28 14:03:28 EDT
Description of problem:
When I create a VM and boot it from an ISO, the VM starts fine.

After the node shuts down, I try to reconnect the CDROM device to the ISO that worked previously. However, the domain is given an incorrect driver for the ISO and the VM fails to boot. I have to remove the CDROM device and add a new one pointing to the same ISO in order to boot the domain.

Version-Release number of selected component (if applicable):
(mcpierce@mcpierce-beta:devel)$ rpm -q virt-manager

How reproducible:

Steps to Reproduce:
1. Create a new virtual machine, booted from a CDROM
2. Go through what's necessary to boot and install the virtual machine.
3. Shutdown the VM.
4. Reconnect the CDROM device to the ISO file.
5. Restart teh VM.
Actual results:
An error message is shown (error is below).

Expected results:
The VM to boot with the CDROM that uses the ISO file.

Additional info:
The error message is:
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 567, in run_domain
  File "/usr/share/virt-manager/virtManager/domain.py", line 652, in startup
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 293, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error unsupported driver name 'file' for disk '/usr/share/ovirt-node-image/ovirt-node-image.iso'

virsh dumpxml [domain] reveals:

<disk type='file' device='cdrom'>                                        
  <driver name='file'/>
  <source file='/usr/share/ovirt-node-image/ovirt-node-image.iso'/>
  <target dev='hdc' bus='ide'/>
Comment 1 Cole Robinson 2009-08-31 09:30:03 EDT

*** This bug has been marked as a duplicate of bug 516116 ***

Note You need to log in before you can comment on or make changes to this bug.