Bug 516116 - virt-manager error caused by connect_cdrom() : unsupported driver name 'file'
virt-manager error caused by connect_cdrom() : unsupported driver name 'file'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
: 520171 522307 (view as bug list)
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-08-06 15:43 EDT by Eric Paris
Modified: 2009-09-14 12:04 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 704863 (view as bug list)
Environment:
Last Closed: 2009-09-14 12:04:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager.log (9.57 KB, text/plain)
2009-08-11 15:49 EDT, Eric Paris
no flags Details

  None (edit)
Description Eric Paris 2009-08-06 15:43:18 EDT
virt-manager-0.8.0-1.fc12.noarch

In v-m-m
create a vm attaching a livecd iso as the insall media
do not attach any storage.
Try to boot.
Turn it off.
go to vm->details->Disk vda
clicked the 'disconnect' button
click 'connect'
choose the same file you just disconnected.
try to start the vm
get this error


Error starting domain: internal error unsupported driver name 'file' for disk '/var/lib/libvirt/images/Fedora-11-x86_64-Live.iso

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 567, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 652, in startup
    self.vm.create()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 293, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error unsupported driver name 'file' for disk '/var/lib/libvirt/images/Fedora-11-x86_64-Live.iso'
Comment 1 Mark McLoughlin 2009-08-11 14:12:39 EDT
Could you include ~/.virt-manager/virt-manager.log and
/var/log/libvirt/qemu/$guest.log ?
Comment 2 Eric Paris 2009-08-11 15:49:53 EDT
Created attachment 357071 [details]
virt-manager.log
Comment 3 Eric Paris 2009-08-11 15:50:59 EDT
The guest.log is empty.
Comment 4 Mark McLoughlin 2009-08-14 12:55:11 EDT
Here's the interesting bit:

 connect_cdrom produced: 
   <disk type="file" device="cdrom">
      <driver name="file" type=""/>
      <target dev="vda" bus="virtio"/>
      <readonly/>
      <source file="/var/lib/libvirt/images/Fedora-11-x86_64-Live.iso"/>
   </disk>

it should be name="qemu", not name="file"

The code causing the problem was introduced in:

  http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virt-manager--devel/rev/f4107609ab7d

Need to consider the Xen implications when fixing
Comment 5 Cole Robinson 2009-08-31 09:30:03 EDT
*** Bug 520171 has been marked as a duplicate of this bug. ***
Comment 6 Kevin Fenzi 2009-09-07 16:32:42 EDT
I'm seeing this here as well, any idea when a fix might land? 

virt-install doesn't seem to have this issue.
Comment 7 Cole Robinson 2009-09-14 11:21:10 EDT
*** Bug 522307 has been marked as a duplicate of this bug. ***
Comment 8 Cole Robinson 2009-09-14 12:04:30 EDT
Fixed in virt-manager-0.8.0-3.fc12

Note You need to log in before you can comment on or make changes to this bug.