Bug 52019 - neat deletes the lo device
neat deletes the lo device
Status: CLOSED DUPLICATE of bug 50903
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-network (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-18 17:47 EDT by Gordon Messmer
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-18 18:13:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Messmer 2001-08-18 17:47:38 EDT
Description of Problem:
If you run Red Hat's Network config tools, you will loose your lo device.

Version-Release number of selected component (if applicable):
0.6.1-1

How Reproducible:
Always

Steps to Reproduce:
1. Run Red Hat's Network config tools from a menu, or 'neat' from the
command line
2. Configure a new network device
3. Check for ifcfg-lo, doesn't exist in /etc/sysconfig/network-scripts

Actual Results:
System boots without lo!

Expected Results:
The 'neat' tool should not delete devices that it does not know how to
configure.

Additional Information:
I really miss netcfg.  And rp3.  I used the rp3 applet on new user's
workstations to let them manage their ppp / pcmcia network devices.  Has
this been depreciated?
Comment 1 Gordon Messmer 2001-08-18 18:13:48 EDT
Almost forgot: 'neat' seems to cause other errors.  I configured an eth0 device
so that regular users could bring up the interface after boot (hotplug wasn't
starting the device on insertion, regardless of settings).

When trying to start the device as a user, I saw the error message "ifcfg-eth0
is not a regular file.  Users can not control this device".

initscripts needs to be fixed to recognise that ifcfg's may be symlinks.
Comment 2 Trond Eivind Glomsrxd 2001-08-19 12:43:40 EDT
Fixed a long time ago - try the newer version from
http://people.redhat.com/teg/neat/

*** This bug has been marked as a duplicate of 50903 ***

Note You need to log in before you can comment on or make changes to this bug.