Bug 520222 - /usr/include/bits/mathinline.h is broken
/usr/include/bits/mathinline.h is broken
Status: CLOSED DUPLICATE of bug 520209
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-08-28 23:52 EDT by Lennart Poettering
Modified: 2009-08-31 05:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 05:07:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2009-08-28 23:52:19 EDT
This recent change seems to have broken builds that end up including /usr/include/bits/mathinline.h:

@@ -35,14 +35,16 @@
 __MATH_INLINE int
 __NTH (__signbitf (float __x))
 {
-  __extension__ union { float __f; int __i; } __u = { __f: __x };
-  return __u.__i < 0;
+  int __m;
+  asm ("pmovmskb %1, %0" : "=r" (__m) : "x" (__x));
+  return __m & 0x8;
 }

See end of these logs:

http://koji.fedoraproject.org/koji/getfile?taskID=1642229&name=build.log

glibc-2.10.90-17.x86_64 is broken

glibc-2.10.90-15.x86_64 works fine
Comment 1 Andreas Schwab 2009-08-31 05:07:05 EDT

*** This bug has been marked as a duplicate of bug 520209 ***

Note You need to log in before you can comment on or make changes to this bug.