Bug 520209 - Problem with math.h header in glibc-2.10.90-17
Problem with math.h header in glibc-2.10.90-17
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
:
: 520222 520474 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-28 18:38 EDT by Deji Akingunola
Modified: 2009-09-01 08:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-01 08:53:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deji Akingunola 2009-08-28 18:38:53 EDT
Description of problem:
I got the error below trying to build tokyocabinet in koji (http://koji.fedoraproject.org/koji/taskinfo?taskID=1641937). The package builds fine in F-11 branch.

>>>>
In file included from /usr/include/math.h:416,
                 from tcutil.h:35,
                 from tcutil.c:17:
/usr/include/bits/mathinline.h: In function '__signbitf':
/usr/include/bits/mathinline.h:39: error: expected ')' before ':' token
/usr/include/bits/mathinline.h: In function '__signbit':
/usr/include/bits/mathinline.h:46: error: expected ')' before ':' token
>>>>

Version-Release number of selected component (if applicable): glibc-2.10.90-17


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Owen Taylor 2009-08-28 19:40:45 EDT
This can be reproduced (tested on x86_64) with:

===
cat <<EOF > math-test.c
#define _XOPEN_SOURCE 600 /* C99 */
#include <features.h>
#include <math.h>

int main()
{
   return 0;
}
EOF
gcc -o math-test.o math-test.c -O2
===

and is probably going to keep a large fraction of packages from building.
Comment 2 Andreas Schwab 2009-08-31 05:07:05 EDT
*** Bug 520222 has been marked as a duplicate of this bug. ***
Comment 3 Andreas Schwab 2009-08-31 05:42:48 EDT
The testcase in #c1 compiles without problem.  Only packages that use --std=c99 fail.
Comment 4 Andreas Schwab 2009-08-31 12:33:06 EDT
*** Bug 520474 has been marked as a duplicate of this bug. ***
Comment 5 Owen Taylor 2009-08-31 12:42:03 EDT
Andreas - that testcase reproduced it for me (unless I typo'ed something putting it into the bug report.). Were you testing on x86_64? But yes, --std=c99 would also be a way of enabling the bad portions of mathinline.h.
Comment 6 Andreas Schwab 2009-09-01 08:02:00 EDT
Without --std=c99 the compiler will happily accept all extensions.
Comment 7 Andreas Schwab 2009-09-01 08:53:17 EDT
Fixed in 2.10.90-18.

Note You need to log in before you can comment on or make changes to this bug.