Bug 52047 - RFE: Install dies on machines i810 + 2nd video card
RFE: Install dies on machines i810 + 2nd video card
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: 16123 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2001-08-19 13:45 EDT by Stephen John Smoogen
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:48:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2001-08-19 13:45:38 EDT
Hi guys,

I like the fix you had for 7.2, but figured I should put in another type of
solution as a RFE for 8.0. 

Machine is 
Dell Optiplex GX100
128 Mb Ram
Voodoo 3 3000 w/16Mb
Creative Labs SB Live! EMU10000
Adaptec 2940
 CDrom writer on SCSI chain
Built in
 i810 video *always on*
 3Com Corporation 3c905C-TX [Fast Etherlink]

The first problem is that the system seems to get confused with the initial
frame buffer mode and goes into an ultra lowres 320x200. The previous
workaround was to do a text install which of course dropped off functionality.

This time the install worked by doing a nofb as the installer tried the
VGA16 XFree86.. and I limped along in that (yeah)

I figured that since it saw I had two video cards.. would it be possible
for it to do something like this on an expert install:

Detected 2 video cards
 Which card do you wish to be primary for install?
    [] Voodoo
    [] i810
    [] vga16

The framebuffer problem.. I dont know what to do with.. I dont know if it
is a Voodoo problem or an i810 voodoo conflict problem.
Comment 1 Michael Fulbright 2001-08-20 11:01:01 EDT
How does text mode drop off functionality? Its IDENTICAL to GUI mode now.

We do not support motherboards currently where the i810 cannot be disabled if
another card is present. You will have to manually configure X for the card in
use.  We may reconsider for future releases.

BTW, what does kudzu say when you:

cd /usr/lib/python1.5/site-packages
import kudzu
print kudzu.probe(kudzu.CLASS_VIDEO, kudzu.BUS_UNSPEC, kudzu.PROBE_ALL)

Comment 2 Stephen John Smoogen 2001-08-20 13:35:11 EDT
I figured it would be several releases, which is why the RFE was put on it..

Here is what kudzu says

>>> print kudzu.probe(kudzu.CLASS_VIDEO, kudzu.BUS_UNSPEC, kudzu.PROBE_ALL)
[Desc:           Intel Corporation|82810-DC100 CGC [Chipset Graphics Controller]
Driver:         Card:Intel 810
Device:         None
, Desc:           3Dfx Interactive, Inc.|Voodoo 3
Driver:         Card:Voodoo3 (generic)
Device:         None
Comment 3 Michael Fulbright 2001-08-24 15:45:27 EDT
I'll try to pick this up for the next release.
Comment 4 Brent Fox 2001-09-26 15:09:18 EDT
*** Bug 16123 has been marked as a duplicate of this bug. ***
Comment 5 Michael Fulbright 2002-03-26 12:45:32 EST
Deferring to future release.
Comment 6 Red Hat Bugzilla 2006-02-21 13:48:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.