Bug 520474 - isnan is not found with new glibc on x86_64
Summary: isnan is not found with new glibc on x86_64
Keywords:
Status: CLOSED DUPLICATE of bug 520209
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andreas Schwab
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-31 16:19 UTC by Ngo Than
Modified: 2009-08-31 16:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-31 16:33:06 UTC


Attachments (Terms of Use)

Description Ngo Than 2009-08-31 16:19:15 UTC
Description of problem:
the function isnan is not found if the testcase is built with -std=iso9899:1990
on x86_64

Version-Release number of selected component (if applicable):

glibc-2.10.90-17

How reproducible:
just compile the following code with -std=iso9899:1990

#include <math.h>
void cmakeRequireSymbol(int dummy,...){(void)dummy;}
int main()
{
#ifndef isnan
   cmakeRequireSymbol(0,&isnan);
#endif
   return 0;
}

you will get the following errors:

In file included from /usr/include/math.h:416, from foo.c:2:
/usr/include/bits/mathinline.h: In function ‘__signbitf’:
/usr/include/bits/mathinline.h:39: error: expected ‘)’ before ‘:’ token
/usr/include/bits/mathinline.h: In function ‘__signbit’:
/usr/include/bits/mathinline.h:46: error: expected ‘)’ before ‘:’ token


Expected results:
it should compile the above code

Additional info:
It build without any problem with the current glibc/gcc in F11/F10.
I did not check whether the issue is also affacted on other arch.


i'm using the latest gcc and glibc in rawhide

Comment 1 Andreas Schwab 2009-08-31 16:33:06 UTC

*** This bug has been marked as a duplicate of bug 520209 ***


Note You need to log in before you can comment on or make changes to this bug.