Bug 52056 - Installer hangs when attempting to boot in rescue mode
Installer hangs when attempting to boot in rescue mode
Status: CLOSED DUPLICATE of bug 52055
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-19 18:08 EDT by William M. Quarles
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-19 18:08:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William M. Quarles 2001-08-19 18:08:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686; Nav)

Description of problem:
RedHat Linux OS 7.1 is already installed on our system.  We have kept up to
date with the Errata updates from RedHat, so all of the ix86 pacakges are
installed on our system.  Whenwe try to boot from the OS 7.1 Disc 1, then
go into rescue mode, the machine boots with the penguin logo loads the
kernel.  It asks from the language and keyboard type.   After being
entered, a blue screen is displayed, which starts feeding black again from
the bottom, with the text "Running Anaconda, Please wait..."  The computer
reads from the disc again a litte, then from one of the hard drives, then
stops.  The system will hang here indefinitely.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade from Linux 6.2 to 7.1 on a Pentium III system.
2. Install all update rpms for i386, i686, and noarch, except for
kernel-2.4.3-12.i386.rpm,  kernel-2.4.3-12.i686.rpm,
kernel-enterprise-2.4.3-12.i386.rpm, and kernel-smp-2.4.3-12.i686.rpm
3. Reboot from Linux 7.1 installation Disc 1
4. Start in rescue mode "linux rescue"
5. Choose English as the language and US as the keyboard when prompted.

Actual Results:  System hangs displaying "Running Anaconda, Please wait..."

Expected Results:  Filesystems should be mounted, and the command prompt
should be displayed, allowing the user to interface with the computer.

Additional info:

We were able to run rescue mode before upgrading to Linux OS 7.1.  However,
we obviously cannot now, so some change caused this problem between then
and now.  This is obviously an important thing to fix, because being able
to boot into rescue mode is important if there is a problem with the
system.

We can still load the graphical-mode installer, if that's useful to know.

The only other changes we have made that I can think of might be relevant
are:
- Got rid of our old swap partition, and put another one on a new drive. 
Size of the partition is around 770 MB.  So our linux software is all on
hda, the swap partition is on hdd.
- Upgraded from 128 MB of SDRAM to 384 MB of SDRAM.  The system bus is 100
MHz, the new DIMM that was installed is actually 133 MHz, but has
variable-speed EEPROMS
- Substituted our old IDE cables for ATA-33/66/100 compatible cables. 
During this process, jumpers on the two hard disks on controller 0 were
found to be wrong (who knows why Linux put up with it before?), corrected
for proper Master/Slave relationship.

The computer boots fine from its own hard drive.  It can also boot from the
6.2 installation CD-ROM, and can be run in rescue mode off of there (still
not a very good workaround, however).

I tried burning a new Disc 1 with the image from the ftp site, it
experienced the same problem as our original Disc 1 that we installed our
upgrade from.
Comment 1 William M. Quarles 2001-08-19 19:13:32 EDT

*** This bug has been marked as a duplicate of 52055 ***

Note You need to log in before you can comment on or make changes to this bug.