Bug 52057 - RFE: Support for non-sendmail MTAs on installs and upgrades
RFE: Support for non-sendmail MTAs on installs and upgrades
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-19 18:37 EDT by Chris Ricker
Modified: 2007-03-26 23:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 10:30:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2001-08-19 18:37:01 EDT
Red Hat has shipped and supported alternate MTAs (postfix, exim) in the
Power Tools of prior releases.

Users upgrading from prior releases who have installed these better MTAs
will be broken by the sendmail RPM in RC1, which gets installed even though
it conflicts.

I upgraded a RH 7.1 box which had postfix installed as the MTA.  sendmail
was installed by anaconda, even though the spec for postfix contains

Provides: MTA smtpd smtpdaemon
Conflicts: sendmail, exim

so the sendmail RPM should never have been installed.  When it installed,
it overwrote /usr/sbin/sendmail leaving a subtly broken postfix install behind.

This has to be fixed before release -- there are a *lot* of RH boxes out
there with non-sendmail MTAs
Comment 1 Florian La Roche 2001-08-23 03:34:47 EDT
This should be working ok, if the new rpms also have a
"Obsoletes: sendmail" in them. If this does not work or
if still something in the sendmail rpm is missing to get
this working, please reopen this bug-report or open a new one.

Thanks,

Florian La Roche
Comment 2 Chris Ricker 2001-08-24 12:11:52 EDT
I've not looked at the sendmail spec yet, but the postfix RPM which I had
installed, and which RH's sendmail RPM in RC1 partially overwrote, has

Obsoletes: sendmail, exim, qmail, smail

in the spec file.
Comment 3 Chris Ricker 2001-10-01 18:09:59 EDT
This is still true with the sendmail shipped in RH 7.2 release.

To be blunt, this is majorly fucked
Comment 4 Florian La Roche 2001-12-08 05:00:39 EST
I re-assign this to the installation program anaconda, that should take care
about update policies. Looks like the current settings in the sendmail
spec file should be correct.

Florian La Roche
Comment 5 Chris Ricker 2002-01-15 14:28:32 EST
I'm not certain, but I think you're confusing multiple different bugs here.

There's bug #1:  Red Hat only ships sendmail, and not better replacement MTAs
such as postfix.  That's a bug I've filed before, and argued about, and am
willing to argue about further.  That's not this bug, however.

This bug is bug #2:  The Red Hat upgrade ignores previously installed software
which obsoletes software the installer plans on including.  The specific example
I used was postfix already installed, and sendmail overwriting it, but I think
it's a more generic bug than that.  It looks to me like any alternative software
with an Obsoletes tag gets ignored by the installer and overwritten anyway,
since the same thing happens for me with BIND overwriting djbdns.
Comment 6 Michael Fulbright 2002-01-24 10:45:35 EST
For Hampton there is a strategy for handling this which does not involve
anaconda changes.
Comment 7 Chris Ricker 2002-01-24 12:12:55 EST
What is the strategy?  Or is it still top-secret? ;-)

Note You need to log in before you can comment on or make changes to this bug.