Bug 520642 - System Becomes Unusable After Starting X
Summary: System Becomes Unusable After Starting X
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: rawhide
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-01 14:58 UTC by William Makowski
Modified: 2009-10-01 17:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-01 17:53:36 UTC


Attachments (Terms of Use)
Xorg.0.log (21.10 KB, text/plain)
2009-09-01 14:58 UTC, William Makowski
no flags Details
Output from lspci (799 bytes, text/plain)
2009-09-01 14:58 UTC, William Makowski
no flags Details
Xorg.0.log after updates on 08-Sep-09 (21.20 KB, text/plain)
2009-09-09 01:47 UTC, William Makowski
no flags Details

Description William Makowski 2009-09-01 14:58:22 UTC
Created attachment 359406 [details]
Xorg.0.log

Description of problem:
After bringing up the system in runlevel 3 I attempt to start X from the command line.  At that point it makes an attempt to go into X, but never makes it.  The screen becomes dark and I am unable to use the keyboard to do anything.  I am unable to switch to another virtual terminal, kill X, or reboot.  Fedora-12-Alpha-i386 was installed using vnc by booting from the network with pxe.  It was necessary to use vnc since the installation froze when using the graphical installer (see Bug 519402).  All packages have been brought up to date using yum.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.6.99-43.20090828.fc12.i686

How reproducible:
Everytime, here are the steps.

Steps to Reproduce:
1. Boot to runlevel 3
2. Login at prompt with regular user
3. Enter "startx" at the command line
  
Actual results:
Terminal flickers and then stays black.  I am unable to switch to a virtual terminal.  It appears as if the keyboard and mouse have become disabled.

Expected results:
It should start up the X server and then go into the Gnome Desktop. Virtual terminals should continue to be available.

Additional info:
I am able to login to the system from another computer using ssh after the system becomes unusable.  I've attached the Xorg.0.log and output from lspci.  In the log it doesn't look like it is running through to completion.  I don't see where it initializes and loads input devices, like keyboard or mouse.  Fedora 11 runs well on this machine.

Comment 1 William Makowski 2009-09-01 14:58:59 UTC
Created attachment 359407 [details]
Output from lspci

Comment 2 William Makowski 2009-09-09 01:47:56 UTC
Created attachment 360154 [details]
Xorg.0.log after updates on 08-Sep-09

Problem persists after latest set of updates (log attached).  Let me know if there is any other information needed.

Comment 3 William Makowski 2009-10-01 17:53:36 UTC
The latest set of updates solves this problem.  X is now usable and can be started right from boot.  I consider this bug resolved.


Note You need to log in before you can comment on or make changes to this bug.