Bug 520723 - [perf] don't call adjust_vmx_controls() a second time
Summary: [perf] don't call adjust_vmx_controls() a second time
Keywords:
Status: CLOSED DUPLICATE of bug 520285
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm
Version: 5.4
Hardware: x86_64
OS: All
low
high
Target Milestone: rc
: ---
Assignee: Gleb Natapov
QA Contact: Lawrence Lim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-02 01:10 UTC by IBM Bug Proxy
Modified: 2014-03-26 01:01 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-30 10:15:57 UTC


Attachments (Terms of Use)
patch to avoid calling adjust_vmx_controls() twice (1.06 KB, text/plain)
2009-09-02 01:10 UTC, IBM Bug Proxy
no flags Details


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 55882 None None None Never

Description IBM Bug Proxy 2009-09-02 01:10:26 UTC
=Comment: #0=================================================
Andrew M. Theurer <habanero@us.ibm.com> - 
---Problem Description---
Need fix for KVM to prevent calling adjust_vmx_controls() a second time
 
Contact Information = Andrew Theurer <atheurer@us.ibm.com> Ryan Harper 
<ryanh@us.ibm.com> 
 
---uname output---
vmlinuz-2.6.18-164.el5
 
Machine Type = x3650M2 
 
---Debugger---
A debugger is not configured
 
---Steps to Reproduce---
 Run a Windows VM on RHEL54.  Collect kvmtrace output.
 
---KVM Component Data---

This problem has a very significant performance impact on Windows VMs running on KVM.

This problem already has a fix upstream.  We just need this applied for a 0 day errata for 
RHEL54.  Upstream patch is here:
http://marc.info/?l=kvm&m=125138769804970&w=2

Performance results are here:
http://marc.info/?l=kvm&m=125140575507242&w=2

I will attach a patch that applies to kmod-kvm-83-105.el5 src rpm

Please mirror this to RedHat ASAP and include Chris Wright <chrisw@redhat.com>
=Comment: #1=================================================
Andrew M. Theurer <habanero@us.ibm.com> - 

patch to avoid calling adjust_vmx_controls() twice

Comment 1 IBM Bug Proxy 2009-09-02 01:10:31 UTC
Created attachment 359462 [details]
patch to avoid calling adjust_vmx_controls() twice

Comment 2 Gleb Natapov 2009-09-30 10:15:35 UTC
this is duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=520285

Comment 3 Gleb Natapov 2009-09-30 10:15:57 UTC

*** This bug has been marked as a duplicate of bug 520285 ***


Note You need to log in before you can comment on or make changes to this bug.