Bug 520766 - kernel oops in drm_release with Radeon HD 3870 (r6xx) and kms
Summary: kernel oops in drm_release with Radeon HD 3870 (r6xx) and kms
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 522190 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-02 09:45 UTC by Thomas Woerner
Modified: 2018-04-11 08:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-02 01:15:51 UTC


Attachments (Terms of Use)
dmesg log (44.05 KB, text/plain)
2009-09-02 09:45 UTC, Thomas Woerner
no flags Details
Xorg.0.log (15.27 KB, text/plain)
2009-09-02 09:46 UTC, Thomas Woerner
no flags Details
dmsg with kernel 2.6.31-0.213.rc9.git1.fc12.i686.PAE (42.25 KB, text/plain)
2009-09-09 08:47 UTC, Thomas Woerner
no flags Details

Description Thomas Woerner 2009-09-02 09:45:19 UTC
Created attachment 359495 [details]
dmesg log

Description of problem:
The X-server is not starting, there is a kernel oops:
  BUG: unable to handle kernel NULL pointer dereference at (null)
  IP: [<f7ec151f>] drm_release+0x233/0x4d7 [drm]

With nomodeset, the system is coming up without problems.

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.31-0.190.rc8.fc12.i686

How reproducible:
Everytime

Steps to Reproduce:
1. Install F-12-alpha and later
2. Try to boot into runlevel 5
  
Actual results:
No X-server and no graphics anymore (even no text console)

Expected results:
Working system.

Additional info:
After having the problem with drm and kms the filesystem had to be checked manually at next boot.

Comment 1 Thomas Woerner 2009-09-02 09:46:00 UTC
Created attachment 359496 [details]
Xorg.0.log

Comment 2 Chuck Ebbert 2009-09-05 01:14:39 UTC
BUG: unable to handle kernel NULL pointer dereference at (null)
IP: [<f7ec151f>] drm_release+0x233/0x4d7 [drm]
*pdpt = 0000000035511001 *pde = 000000021f568067 
Oops: 0000 [#1] SMP 
last sysfs file: /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/boot_vga
Modules linked in: ipt_MASQUERADE iptable_nat nf_nat bridge stp llc nfsd lockd nfs_acl auth_rpcgss exportfs sunrpc xt_physdev ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 p4_clockmod dm_multipath kvm_intel kvm uinput snd_hda_codec_atihdmi snd_hda_codec_realtek firewire_ohci firewire_core i2c_i801 snd_hda_intel ppdev parport_pc snd_hda_codec iTCO_wdt snd_hwdep parport snd_pcm snd_timer iTCO_vendor_support crc_itu_t snd soundcore snd_page_alloc pata_acpi ata_generic r8169 usb_storage mii pata_jmicron radeon ttm drm i2c_algo_bit i2c_core [last unloaded: microcode]

Pid: 1418, comm: Xorg Not tainted (2.6.31-0.190.rc8.fc12.i686.PAE #1) P35-DS4
EIP: 0060:[<f7ec151f>] EFLAGS: 00213293 CPU: 1
EIP is at drm_release+0x233/0x4d7 [drm]
EAX: c1df0348 EBX: c1df0000 ECX: 00000000 EDX: ffffffdc
ESI: f384c850 EDI: f384c850 EBP: f292bf44 ESP: f292bf20
 DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
Process Xorg (pid: 1418, ti=f292a000 task=f2e9c140 task.ti=f292a000)
Stack:
 f2d1df00 00000008 f6e775b0 c1df0034 c0503f45 5237de14 f2d1df00 00000008
<0> f6e775b0 f292bf6c c0503f96 f6e775b0 f6705180 c1e6e0b0 c1e6e0b0 5237de14
<0> f2d1df00 00000000 f54d3b80 f292bf78 c0504065 5237de14 f292bf90 c050074e
Call Trace:
 [<c0503f45>] ? __fput+0xb0/0x1a9
 [<c0503f96>] ? __fput+0x101/0x1a9
 [<c0504065>] ? fput+0x27/0x3a
 [<c050074e>] ? filp_close+0x64/0x7f
 [<c05007e5>] ? sys_close+0x7c/0xc2
 [<c040a24b>] ? sysenter_do_call+0x12/0x38
Code: 74 0d 83 79 64 00 75 07 89 f2 89 d8 ff 51 60 8d 43 34 31 d2 89 45 e8 e8 8e 94 97 c8 8b 93 48 03 00 00 8d 83 48 03 00 00 83 ea 24 <8b> 72 24 89 45 ec 83 ee 24 eb 16 39 7a 0c 75 09 31 c9 89 d8 e8 
EIP: [<f7ec151f>] drm_release+0x233/0x4d7 [drm] SS:ESP 0068:f292bf20
CR2: 0000000000000000

Comment 3 Thomas Woerner 2009-09-09 08:47:33 UTC
Created attachment 360172 [details]
dmsg with kernel 2.6.31-0.213.rc9.git1.fc12.i686.PAE

Comment 4 Dave Airlie 2009-09-09 09:13:29 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=1664389

hopefully that fixes it.

kernel-2_6_31-0_218_rc9_git2_fc12

Comment 5 Matěj Cepl 2009-09-09 14:15:07 UTC
*** Bug 521322 has been marked as a duplicate of this bug. ***

Comment 6 Yanko Kaneti 2009-09-09 17:48:29 UTC
*** Bug 522190 has been marked as a duplicate of this bug. ***

Comment 7 Sven Lankes 2009-09-09 22:05:21 UTC
Works for me - I have a machine with ATI onboard hd3xxx graphics and I was suffering from the above oops. Fixed now with kernel -219 - and I even have working kms now.

Comment 8 Fraud 2009-09-09 23:16:46 UTC
Updating to 2.6.31-0.219.rc9.git2.fc12.x86_64 on a RV620/HD3450 box solve the above oops.

modesetting works; dmesg :
  ---
  [drm] radeon: kernel modesetting successfully initialized.
  [drm] Initialized radeon 2.0.0 20080528 for 0000:01:00.0 on minor 0
  ---

Comment 9 Stefan Becker 2009-09-10 03:12:22 UTC
Retested with new testday i686 LiveCD:

01:05.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon HD 3200 Graphics [1002:9610]

kernel-2.6.31-0.219.rc9.git2.fc12.i686
xorg-x11-drv-ati-6.13.0-0.3.20090908git651fe5a47.fc12.i686
libdrm-2.4.12-0.9.fc12.i686
mesa-libGL-7.6-0.11.fc12.i686

X now starts up fine with KMS. Thanks


Note You need to log in before you can comment on or make changes to this bug.