Bug 520772 - OpenOffice Writer crashes after trying to copy text
Summary: OpenOffice Writer crashes after trying to copy text
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 11
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-02 10:24 UTC by Klaas Zwaan
Modified: 2011-08-19 17:50 UTC (History)
3 users (show)

Fixed In Version: 3.1.1-19.2.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-04 04:10:27 UTC


Attachments (Terms of Use)

Description Klaas Zwaan 2009-09-02 10:24:33 UTC
Description of problem:
When I start OpenOffice Writer, just enter one line of text, give it a color and then I want to copy that text: OOo has crashed.

Version-Release number of selected component (if applicable):
OpenOffice 3.1.1

How reproducible:
Easy to reproduce

Steps to Reproduce:
1. Start OpenOffice Writer
2. Enter a short line of text.
3. Select the line of text.
4. Give text the color 'red' (with the colorpicker)
5. Copy the selected text (rightmouse)
6. When you click 'Copy' OOo crashes
7. Crash-info I've added below
  
Actual results:
A nice dumppage

Expected results:


Additional info:

(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers//ati_drv.so
(II) Loading /usr/lib/xorg/modules/drivers//radeon_drv.so
(II) Loading /usr/lib/xorg/modules/drivers//vesa_drv.so
(II) Loading /usr/lib/xorg/modules/drivers//fbdev_drv.so
(II) Unloading /usr/lib/xorg/modules/drivers//vesa_drv.so
(II) Unloading /usr/lib/xorg/modules/drivers//fbdev_drv.so
(--) Depth 24 pixmap format is 32 bpp
(III)  Desktop is: GNOME
(IV)   openoffice.org-kde version is: package openoffice.org-kde is not installed
(V)    libgcj version is: libgcj-4.4.1-2.fc11-i586
(VI)   kernel is: Linux 2.6.29.6-217.2.16.fc11.i686.PAE #1 SMP Mon Aug 24 17:16:21 EDT 2009 i686 athlon i386
(VII)  OpenOffice.org core rpm version is: openoffice.org-core-3.1.1-19.1.fc11-i586
(VIII) accessibility is: false
(IX)   gtk theme is: Clearlooks
(X)    icon theme is: gnome
(XI)   metacity theme is: Clearlooks
(XII)  fedora release is: Fedora release 11 (Leonidas)
(XIII) LANG is: nl_NL.UTF-8
...start free space details ...
Bestandssysteem     1K-blokken  Gebruikt Beschikbr Geb% Aangekoppeld op
/dev/sda5             87829800  10193560  73174724  13% /home
/dev/sda6             21165988   4526944  15563844  23% /
...end free space details ...
...start (default) java details ...
java version "1.6.0_0"
OpenJDK Runtime Environment (IcedTea6 1.5) (fedora-27.b16.fc11-i386)
OpenJDK Client VM (build 14.0-b15, mixed mode)
...end (default) java details ...
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 24
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x46adfe: 0x1c04d4: /usr/lib/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 + 0x20dfe
0x46b745: 0x1c04d4: /usr/lib/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 + 0x21745
0xc04400: 0x0:  + 0x400 (__kernel_sigreturn + 0x0)
0x10ea26c: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x4e526c (BigPtrArray::Index2Block(unsigned long) const + 0xd4)
0x10ea2a7: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x4e52a7 (BigPtrArray::operator[](unsigned long) const + 0x21)
0xda8446: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x1a3446
0xf90389: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x38b389 (SwNodes::_CopyNodes(SwNodeRange const&, SwNodeIndex const&, unsigned char, unsigned char) const + 0x623)
0xf6f617: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x36a617 (SwDoc::CopyWithFlyInFly(SwNodeRange const&, unsigned short, SwNodeIndex const&, unsigned char, unsigned char, unsigned char) const + 0x97)
0xf70754: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x36b754 (SwDoc::_Copy(SwPaM&, SwPosition&, unsigned char, bool, SwPaM*) const + 0xe0a)
0xf70d86: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x36bd86 (SwDoc::Copy(SwPaM&, SwPosition&, bool) const + 0x2d4)
0xdac894: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x1a7894 (SwEditShell::_CopySelToDoc(SwDoc*, SwNodeIndex*) + 0x294)
0x1070cd8: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x46bcd8 (SwFEShell::Copy(SwDoc*, String const*) + 0x648)
0x1200faf: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x5fbfaf
0x12015c4: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x5fc5c4
0x125f38d: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x65a38d
0x3e820cc: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c90cc
0x3e7b365: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c2365
0x3e994ad: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1e04ad
0x3e999ba: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1e09ba
0x3e7a0e7: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c10e7
0x248b156: 0x3852ec: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x96156 (Timer::Timeout() + 0x18)
0x248b62d: 0x3852ec: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x9662d (Timer::ImplTimerCallbackProc() + 0x7b)
0x20bd706: 0x7c4e8: /usr/lib/openoffice.org/basis3.1/program/libvclplug_genli.so + 0x45706 (X11SalData::Timeout() const + 0x2a)
0x1af92e1: 0x4f1d0: /usr/lib/openoffice.org/basis3.1/program/libvclplug_gtkli.so + 0x122e1
0x22f03ac: 0xdd050: /lib/libglib-2.0.so.0 + 0x353ac
0x22efcf8: 0xdd050: /lib/libglib-2.0.so.0 + 0x34cf8 (g_main_context_dispatch + 0x1f8)
0x22f3370: 0xdd050: /lib/libglib-2.0.so.0 + 0x38370
0x22f34a3: 0xdd050: /lib/libglib-2.0.so.0 + 0x384a3 (g_main_context_iteration + 0x73)
0x1af9073: 0x4f1d0: /usr/lib/openoffice.org/basis3.1/program/libvclplug_gtkli.so + 0x12073
0x20c6775: 0x7c4e8: /usr/lib/openoffice.org/basis3.1/program/libvclplug_genli.so + 0x4e775 (X11SalInstance::Yield(bool, bool) + 0x2f)
0x248695a: 0x3852ec: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x9195a (Application::Yield(bool) + 0x5c)
0x24869a9: 0x3852ec: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x919a9 (Application::Execute() + 0x2b)
0x28bef5: 0x63b60: /usr/lib/openoffice.org3/program/../basis-link/program/libsofficeapp.so + 0x18ef5
0x248aaab: 0x3852ec: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x95aab
0x248ac43: 0x3852ec: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x95c43 (SVMain() + 0x2c)
0x2b01a8: 0x63b60: /usr/lib/openoffice.org3/program/../basis-link/program/libsofficeapp.so + 0x3d1a8 (soffice_main + 0xd0)
0x80487c4: 0xd04: /usr/lib/openoffice.org3/program/swriter.bin + 0x7c4 (main + 0x20)
0x2efa66: 0x16cd7c: /lib/libc.so.6 + 0x16a66 (__libc_start_main + 0xe6)
0x8048711: 0xd04: /usr/lib/openoffice.org3/program/swriter.bin + 0x711
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x001cc000)
	libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x0050f000)
	libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00ecf000)
	libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x00c75000)
	libgio-2.0.so.0 => /lib/libgio-2.0.so.0 (0x00149000)
	libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x0096c000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x00110000)
	libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x0012d000)
	libcairo.so.2 => /usr/lib/libcairo.so.2 (0x001cd000)
	libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00d9a000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00276000)
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00308000)
	libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x00138000)
	libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x00b73000)
	librt.so.1 => /lib/librt.so.1 (0x0013c000)
	libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0x00d7b000)
	libdbus-1.so.3 => /lib/libdbus-1.so.3 (0x0033b000)
	libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x0037c000)
	libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x003bd000)
	libvclplug_genli.so => /usr/lib/openoffice.org/basis3.1/program/libvclplug_genli.so (0x00996000)
	libvclli.so => /usr/lib/openoffice.org/basis3.1/program/libvclli.so (0x00f65000)
	libpspli.so => /usr/lib/openoffice.org/basis3.1/program/libpspli.so (0x00a18000)
	libsotli.so => /usr/lib/openoffice.org/basis3.1/program/libsotli.so (0x0049b000)
	libutlli.so => /usr/lib/openoffice.org/basis3.1/program/libutlli.so (0x00bcf000)
	libtlli.so => /usr/lib/openoffice.org/basis3.1/program/libtlli.so (0x00de0000)
	libcomphelp4gcc3.so => /usr/lib/openoffice.org/basis3.1/program/libcomphelp4gcc3.so (0x02117000)
	libucbhelper4gcc3.so => /usr/lib/openoffice.org/basis3.1/program/libucbhelper4gcc3.so (0x00af6000)
	libuno_cppuhelpergcc3.so.3 => /usr/lib/openoffice.org/basis3.1/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3 (0x02047000)
	libuno_cppu.so.3 => /usr/lib/openoffice.org/basis3.1/program/../ure-link/lib/libuno_cppu.so.3 (0x00248000)
	libvos3gcc3.so => /usr/lib/openoffice.org/basis3.1/program/libvos3gcc3.so (0x00906000)
	libuno_sal.so.3 => /usr/lib/openoffice.org/basis3.1/program/../ure-link/lib/libuno_sal.so.3 (0x033b2000)
	libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x001c2000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0x0272c000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x004f9000)
	libdl.so.2 => /lib/libdl.so.2 (0x00509000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x00929000)
	libstlport_gcc.so => /usr/lib/openoffice.org/basis3.1/program/../ure-link/lib/libstlport_gcc.so (0x04f86000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x01339000)
	libm.so.6 => /lib/libm.so.6 (0x00944000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00b78000)
	libc.so.6 => /lib/libc.so.6 (0x06eea000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00b65000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00b6a000)
	libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x00145000)
	libXi.so.6 => /usr/lib/libXi.so.6 (0x00ea9000)
	libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00ba3000)
	libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x00c57000)
	libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00c5a000)
	libselinux.so.1 => /lib/libselinux.so.1 (0x00cf7000)
	libpng12.so.0 => /usr/lib/libpng12.so.0 (0x00d15000)
	libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x03ec1000)
	libz.so.1 => /lib/libz.so.1 (0x00c5d000)
	libexpat.so.1 => /lib/libexpat.so.1 (0x00d3c000)
	/lib/ld-linux.so.2 (0x00bad000)
	libcap.so.2 => /lib/libcap.so.2 (0x00c70000)
	libi18npaperli.so => /usr/lib/openoffice.org/basis3.1/program/libi18npaperli.so (0x00c92000)
	libbasegfxli.so => /usr/lib/openoffice.org/basis3.1/program/libbasegfxli.so (0x0157b000)
	libSM.so.6 => /usr/lib/libSM.so.6 (0x00c97000)
	libICE.so.6 => /usr/lib/libICE.so.6 (0x00e82000)
	libi18nisolang1gcc3.so => /usr/lib/openoffice.org/basis3.1/program/libi18nisolang1gcc3.so (0x00d63000)
	libi18nutilgcc3.so => /usr/lib/openoffice.org/basis3.1/program/libi18nutilgcc3.so (0x00d69000)
	libicuuc.so.40 => /usr/lib/libicuuc.so.40 (0x04398000)
	libicudata.so.40 => /usr/lib/libicudata.so.40 (0xb7355000)
	libicule.so.40 => /usr/lib/libicule.so.40 (0x024da000)
	libjvmaccessgcc3.so.3 => /usr/lib/openoffice.org/basis3.1/program/../ure-link/lib/libjvmaccessgcc3.so.3 (0x00e9c000)
	libuno_salhelpergcc3.so.3 => /usr/lib/openoffice.org/basis3.1/program/../ure-link/lib/libuno_salhelpergcc3.so.3 (0x00ea3000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x074c2000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00eb3000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0x00c9f000)
	libattr.so.1 => /lib/libattr.so.1 (0x04ec9000)
	libuuid.so.1 => /lib/libuuid.so.1 (0x0179d000)
	libfreebl3.so => /lib/libfreebl3.so (0x02a0f000)
...end sample ldd details ...

Comment 1 David Tardon 2009-09-02 10:51:02 UTC
The color change is not even necessary: 3.1.1-19.1 always crashes when trying to copy text. The stack looks like the crash might be caused by fix of bug 501141; on the other side 3.1.1-19.1 in Rawhide, that has been patched as well, is not affected.

Comment 2 David Tardon 2009-09-02 11:36:25 UTC
Update: I had old version of oo.o installed when I tried that on Rawhide. 3.1.1-19.2 crashes too.

Comment 3 Caolan McNamara 2009-09-02 13:09:29 UTC
Happens on copying the first node, i.e. first line. There's a bCopyAll that leads us into a code path where we do a CopyWithFlyInFly that in its depth does -- on a 0 index node taking it to a negative number which dies horribly.


Looking closer, the patch we have has...

+                bRet = GetDoc()->Copy( *PCURCRSR, aPos, true ) || bRet;

in the bit that affects edglss.cxx while the upstream workspace has...

+                bRet = GetDoc()->Copy( *PCURCRSR, aPos, false ) || bRet;

i.e. true->false. We must have ended up with an earlier version of this workspace. I'll regenerate this and respin as fast as we can

Comment 4 David Tardon 2009-09-02 13:44:10 UTC
dtardon->caolanm: Yes, I missed two parts that were committed after a rebase: rev. 272964 and 272980 (this is the fix you found out). I have the patch prepared, thus if you haven't done it yet, I can commit it.

Comment 5 Caolan McNamara 2009-09-02 13:52:02 UTC
I've updated this workspace and make the tweaks to apply. Have a look over it to see if it was what you had in mind. In the meantime builds in progress. Will be in >= 3.1.1-19.2

Comment 6 Fedora Update System 2009-09-03 08:02:30 UTC
openoffice.org-3.1.1-19.2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.2.fc11

Comment 7 Jeffrey C. Ollie 2009-09-03 11:49:30 UTC
I grabbed 3.1.1-19.2 out of koji last night and it seems to have fixed the problem on my F11 box.

Comment 8 Fedora Update System 2009-09-04 04:10:21 UTC
openoffice.org-3.1.1-19.2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.