Bug 520860 - Update scsi_dh_rdac.c for Dell PowerVault storage MD32xx and MD32xxi
Summary: Update scsi_dh_rdac.c for Dell PowerVault storage MD32xx and MD32xxi
Keywords:
Status: CLOSED DUPLICATE of bug 524335
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: alpha
: 5.5
Assignee: Tom Coughlan
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On: 520912
Blocks: 533192 496328
TreeView+ depends on / blocked
 
Reported: 2009-09-02 17:35 UTC by Babu Moger
Modified: 2009-11-05 15:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-23 17:04:22 UTC


Attachments (Terms of Use)
Patch to update scsi_dh_rdac.c for Dell PowerVault storage MD32xx and MD32xxi (454 bytes, patch)
2009-09-02 17:35 UTC, Babu Moger
no flags Details | Diff

Description Babu Moger 2009-09-02 17:35:34 UTC
Created attachment 359559 [details]
Patch to update scsi_dh_rdac.c for Dell PowerVault storage MD32xx and MD32xxi

Description of problem:

This Bugzilla is to add support for next generation Dell PowerVault array in
rdac scsi device handler(scsi_dh_rdac.c). 
The patch has already been submitted to upstram kernel. Please see the link below.

http://marc.info/?l=dm-devel&m=125053752401784&w=2

Please include this patch in next RHEL 5 update. Patch is attached. I have generated the patch based of 2.6.18-164.el5.x86_64. 

Version-Release number of selected component (if applicable):
RHEL 5.5

How reproducible:

Steps to Reproduce:
1. Setup the RHEL 5.4 system with dell PowerVault storage MD32xx or MD32xxi
2. configure device mapper multipath
3. Start failover/failback test.
  
Actual results:
Failover/Failback will not work as VID and PIDs are not in the kernel. 

Expected results:
Failover/Failback should work as expected..


Additional info:

Comment 1 Babu Moger 2009-09-21 15:00:06 UTC
Andrius,
I have opened another bug 524335 to merge all the rdac changes from upstream.
The new bug(524335) should take care of this patch also.  Should I go ahead and mark this one as the duplicate of 524335. Any objections..
-Babu..

Comment 2 Andrius Benokraitis 2009-09-23 17:04:22 UTC

*** This bug has been marked as a duplicate of bug 524335 ***


Note You need to log in before you can comment on or make changes to this bug.