Bug 520912 - Update scsi_dh_rdac.c for Dell PowerVault storage MD32xx and MD32xxi for RHEL 6
Summary: Update scsi_dh_rdac.c for Dell PowerVault storage MD32xx and MD32xxi for RHEL 6
Keywords:
Status: CLOSED DUPLICATE of bug 528576
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
medium
high
Target Milestone: rc
: 6.0
Assignee: Tom Coughlan
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks: 253443 520860
TreeView+ depends on / blocked
 
Reported: 2009-09-02 20:16 UTC by Babu Moger
Modified: 2009-10-13 13:59 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-13 13:59:40 UTC


Attachments (Terms of Use)

Description Babu Moger 2009-09-02 20:16:26 UTC
Description of problem:
This Bugzilla is to add support for next generation Dell PowerVault array in
rdac scsi device handler(scsi_dh_rdac.c). The patch has already been submitted to upstram kernel. Please see the link below.

http://marc.info/?l=dm-devel&m=125053752401784&w=2

This patch should go into RHEL 6. Without this patch multipath failover/failback will not work for this storage..

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Setup the RHEL 6 system with dell PowerVault storage MD32xx or MD32xxi
2. configure device mapper multipath
3. Start failover/failback test.
  
Actual results:
Failover/Failback will not work as VID and PIDs are not in the kernel. 

Expected results:
Failover/Failback should work as expected..

Additional info:

Comment 2 RHEL Product and Program Management 2009-09-02 20:50:40 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Andrius Benokraitis 2009-09-14 17:44:37 UTC
babu - do you have the Dell hardware to test this?

Comment 4 Babu Moger 2009-09-14 18:09:15 UTC
Yes, We have the hardware.. I can test the fix whenever it is available. I will also check with Yanqing from Dell(Yanqing_Liu@Dell.com she is in the CC) to see if she can help us testing this..

Comment 5 Babu Moger 2009-10-13 13:59:40 UTC
I will take care of this with 528576.

*** This bug has been marked as a duplicate of bug 528576 ***


Note You need to log in before you can comment on or make changes to this bug.