Bug 520866 - cluster.ng is very out of date and does not parse logging tags correctly
Summary: cluster.ng is very out of date and does not parse logging tags correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster
Version: 5.5
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
: 597258 606826 (view as bug list)
Depends On:
Blocks: 629083
TreeView+ depends on / blocked
 
Reported: 2009-09-02 18:02 UTC by Shane Bradley
Modified: 2019-02-22 15:55 UTC (History)
11 users (show)

Fixed In Version: system-config-cluster-1.0.57-7
Doc Type: Bug Fix
Doc Text:
Previously, system-config-cluster failed parse logging tags and related children because the cluster.ng file did not contain those tags. This update adds the tags for the logger parent and its children.
Clone Of:
Environment:
Last Closed: 2011-01-13 23:58:53 UTC


Attachments (Terms of Use)
Patch to add the logger tag into cluster.ng (1.09 KB, patch)
2009-09-02 18:02 UTC, Shane Bradley
no flags Details | Diff
Updated patch with more options added. (770 bytes, patch)
2010-07-08 14:26 UTC, Shane Bradley
no flags Details | Diff
Updated patch. (174.43 KB, patch)
2010-08-31 20:58 UTC, Lon Hohberger
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0101 normal SHIPPED_LIVE system-config-cluster bug fix update 2011-01-12 17:21:11 UTC
Red Hat Knowledge Base (Solution) 26773 None None None 2019-02-22 15:55:45 UTC

Description Shane Bradley 2009-09-02 18:02:41 UTC
Created attachment 359563 [details]
Patch to add the logger tag into cluster.ng

Description of problem:
system-config-cluster will error on logging tags and its children. 

For example:
<logging to_stderr="yes">
  <logger ident="CPG" debug="on" to_stderr="yes">
  </logger>
  <logger ident="CMAN" debug="on" to_stderr="yes">
  </logger>
</logging>


The reason that it error is because its cluster.ng file does not contain 
those tags.

Created a patch to resolve this issue by adding in the tags for logger parent
and its children.

Version-Release number of selected component (if applicable):
system-config-cluster-1.0.55-1.0

How reproducible:
Everytime

Steps to Reproduce:
1.Add in the tags above inside <cluster> tags in the cluster.conf
2.Open the cluster.conf with scc
  
Actual results:
An xml parsing error occurs.

Expected results:
No error should occur.

Additional info:

Comment 4 Chris Ward 2010-02-11 10:15:36 UTC
~~ Attention Customers and Partners - RHEL 5.5 Beta is now available on RHN ~~

RHEL 5.5 Beta has been released! There should be a fix present in this 
release that addresses your request. Please test and report back results 
here, by March 3rd 2010 (2010-03-03) or sooner.

Upon successful verification of this request, post your results and update 
the Verified field in Bugzilla with the appropriate value.

If you encounter any issues while testing, please describe them and set 
this bug into NEED_INFO. If you encounter new defects or have additional 
patch(es) to request for inclusion, please clone this bug per each request
and escalate through your support representative.

Comment 15 Lon Hohberger 2010-05-24 15:57:09 UTC
This is valid, but the patch needs to be reviewed by Chrissie.  Looks like there's syslog_facility which is also valid for the logger tag.

Comment 16 Christine Caulfield 2010-05-25 07:35:22 UTC
The <logging> tree looks like this:

logging:
	to_file: yes|no
	to_syslog: yes|no
	to_stderr: yes|no
	debug: on|off
	timestamp: on|off
	logfile: <name>
	fileline: on|off
	syslog_facility: daemon|local[0..7]

	logger:
		ident: <name>
		debug: on/off
		tags: enter|leave|trace[1..8]

Comment 17 Shane Bradley 2010-07-08 14:26:45 UTC
Created attachment 430378 [details]
Updated patch with more options added.

Added the options that was requested in previous comment. It appears previous patch has already been included. This patch was built against:system-config-cluster-1.0.57-3.src.rpm

Comment 18 Lon Hohberger 2010-08-05 20:38:02 UTC
*** Bug 606826 has been marked as a duplicate of this bug. ***

Comment 19 Lon Hohberger 2010-08-09 16:00:45 UTC
*** Bug 597258 has been marked as a duplicate of this bug. ***

Comment 20 Lon Hohberger 2010-08-11 21:31:08 UTC
Proposed updated schema here:

http://people.redhat.com/lhh/cluster-rhel5.rng

Comment 22 Lon Hohberger 2010-08-31 20:58:39 UTC
Created attachment 442277 [details]
Updated patch.

Comment 26 Lon Hohberger 2010-09-27 15:40:03 UTC
I added some missing things which were since added to 5.6 (but not RHEL 5.5) clustering, including __max_restarts / __restart_expire_time for resources, orainstance/oralistener metadata support, fence_cisco_ucs, and fence_rhev support.

I replaced the patch in the package with a new one and rebuilt as 1.0.57-7

Comment 30 Brian Brock 2010-10-12 15:16:25 UTC
All tests of new xml elements and attributes in comment 26 validate with xmllint of system-config-cluster-1.0.57-7

Do any specific attributes need to be tested for the new elements?
Any UI changes for any of the new elements/attributes?

Comment 31 Lon Hohberger 2010-10-12 17:17:42 UTC
There are no new UI elements that I am aware of that correspond to the updated schema.  That is, the schema may provide things that the UIs do not provide, but not all entries in the schema are supposed to have UI elements corresponding to them.

Comment 33 David Juran 2010-10-20 12:57:32 UTC
In the cman man-page we give the following example:

<logging to_stderr="yes">
  <logger ident="CPG" debug="on" to_stderr="yes">
  </logger>
  <logger ident="CMAN" debug="on" to_stderr="yes">
  </logger>
</logging>

The to_stderr attributes of the "logger" tag are not mentinoned in the relaxng file and will cause it to fail validation.

Comment 35 Florian Nadge 2011-01-03 15:44:24 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, system-config-cluster failed parse logging tags and related children because the cluster.ng file did not contain those tags. This update adds the tags for the logger parent and its children.

Comment 37 errata-xmlrpc 2011-01-13 23:58:53 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0101.html


Note You need to log in before you can comment on or make changes to this bug.