Bug 521217 - No kernel entry in yaboot when installing rawhide on non-standard partitioning layout
Summary: No kernel entry in yaboot when installing rawhide on non-standard partitionin...
Keywords:
Status: CLOSED DUPLICATE of bug 523754
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: powerpc
OS: Linux
high
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 523754
TreeView+ depends on / blocked
 
Reported: 2009-09-04 10:58 UTC by Martin Banas
Modified: 2009-09-18 17:38 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 523754 (view as bug list)
Environment:
Last Closed: 2009-09-18 17:38:33 UTC


Attachments (Terms of Use)
/boot directory without ramdisk and vmlinuz to reduce size (2.83 MB, application/x-tar)
2009-09-04 10:59 UTC, Martin Banas
no flags Details
/root directory (70.00 KB, application/x-tar)
2009-09-04 11:00 UTC, Martin Banas
no flags Details
/var/log directory (870.00 KB, application/x-tar)
2009-09-04 11:00 UTC, Martin Banas
no flags Details
program.log from /var/log attachment (74.48 KB, text/plain)
2009-09-09 05:29 UTC, Martin Banas
no flags Details

Description Martin Banas 2009-09-04 10:58:45 UTC
Description of problem:
After installing rawhide with non-standard partitioning layout, no kernel is found in yaboot.

Version-Release number of selected component (if applicable):
rawhide-20090903.0
anaconda 12.19
PPC

How reproducible:
always

Steps to Reproduce:
1. start instalation of current rawhide (note that because of bug in 12.19 you need to supply another boot parameter "updates=http://jlaska.fedorapeople.org/520791-updates.img")
2. start vnc instalation (because of bug 521049 you cannot start it by hand. Use kickstart with option "timezone --isUtc America/New_York" to skip this particular dialog)
3. proceed to partitioning dialog
4. create non-default partitioning layout:
   for example: / on physical volume (non-lvm)
                / on LVM, where LVM is on software raid partition (RAID1)
                / on raid partition.
5. finish the instalation and reboot
  
Actual results:
after reboot there is no entry in yaboot.

Expected results:
there should be entry "linux" to be able to boot the kernel

Additional info:
User can successfully enter rescue mode and chroot the installed system. Attached tar files of "/root" "/var/log" and "/boot" directory.

Comment 1 Martin Banas 2009-09-04 10:59:47 UTC
Created attachment 359787 [details]
/boot directory without ramdisk and vmlinuz to reduce size

Comment 2 Martin Banas 2009-09-04 11:00:21 UTC
Created attachment 359788 [details]
/root directory

Comment 3 Martin Banas 2009-09-04 11:00:57 UTC
Created attachment 359789 [details]
/var/log directory

Comment 5 Chris Lumens 2009-09-04 19:42:57 UTC
What's the problem with the yaboot.conf file you attached as part of the /boot directory?  Comparing to a working ppc install here, it looks okay to me.

Comment 6 Martin Banas 2009-09-07 07:09:41 UTC
Yes, the file itself is OK. The problem is, that even the file seems to be OK, the machine after reboot doesn't see the "linux" kernel and cannot boot.

Comment 7 Chris Lumens 2009-09-08 18:40:48 UTC
Can you attach /var/log/program.log to this bug report so we can see if the bootloader even got run?

Comment 8 Martin Banas 2009-09-09 05:27:42 UTC
The /var/log/program.log is already attached in attachment " /var/log directory   (870.00 KB, application/x-tar) ".

Comment 9 Martin Banas 2009-09-09 05:29:30 UTC
Created attachment 360162 [details]
program.log from /var/log attachment

Comment 11 Chris Lumens 2009-09-16 15:29:53 UTC
Can you switch to tty2 and do:

/sbin/mkofboot -f -C /boot/etc/yaboot.conf
echo $?

Comment 12 Denise Dumas 2009-09-18 17:29:50 UTC
discussion moved to 523754...

Comment 13 Chris Lumens 2009-09-18 17:38:33 UTC

*** This bug has been marked as a duplicate of bug 523754 ***


Note You need to log in before you can comment on or make changes to this bug.