Bug 521273 - Fix instances of #!/usr/bin/env python in gimp
Fix instances of #!/usr/bin/env python in gimp
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gimp (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Nils Philippsen
desktop-bugs@redhat.com
:
Depends On:
Blocks: 502912 590060 521940
  Show dependency treegraph
 
Reported: 2009-09-04 11:46 EDT by Issue Tracker
Modified: 2013-04-15 08:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 952227 952231 (view as bug list)
Environment:
Last Closed: 2013-04-15 08:31:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2009-09-04 11:46:34 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2009-09-04 11:46:36 EDT
Event posted on 09-04-2009 11:44am EDT by kbaxley

THere's a project underway in Fedora 12 to finally resolve the issues with Red Hat including #!/usr/bin/env python in our python executables:

https://fedoraproject.org/wiki/Features/SystemPythonExecutablesUseSystemPython

There's also a Fedora bug opened on this, and comments in there state that this is a big priority for RHEL6:

https://bugzilla.redhat.com/show_bug.cgi?id=518994

For RHEL5, we've been instructed by Product Management to open bugs on a package-by-package basis to address the problem.

In this case, gimp in RHEL5 has at least one python executable containing #!/usr/bin/env python
This event sent from IssueTracker by kbaxley  [LLNL (HPC)]
 issue 339039
Comment 3 RHEL Product and Program Management 2009-11-06 14:15:03 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 RHEL Product and Program Management 2010-08-09 15:30:47 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 RHEL Product and Program Management 2011-05-31 10:58:54 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 17 Nils Philippsen 2013-04-15 08:31:47 EDT
Unfortunately it's too late in the life cycle of Red Hat Enterprise Linux 5 to fix this bug. The upcoming 5.10 update is going to be the first production phase 2 release of Red Hat Enterprise Linux 5. From phase 2 on we'll be addressing primarily security and critical issues, therefore I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.