This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 521285 - Fix instances of #!/usr/bin/env python in switchdesk-gui
Fix instances of #!/usr/bin/env python in switchdesk-gui
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: switchdesk (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Ngo Than
desktop-bugs@redhat.com
:
Depends On:
Blocks: 502912 590060 521940
  Show dependency treegraph
 
Reported: 2009-09-04 12:23 EDT by James G. Brown III
Modified: 2014-12-01 18:06 EST (History)
8 users (show)

See Also:
Fixed In Version: switchdesk-4_0_8-7_el5
Doc Type: Bug Fix
Doc Text:
The shebang lines in Python executables have been changed to "#!/usr/bin/python" to ensure the Python interpreter installed in the system is used.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-14 15:24:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James G. Brown III 2009-09-04 12:23:38 EDT
"There's a project underway in Fedora 12 to finally resolve the issues
with Red Hat including #!/usr/bin/env python in our python executables:

https://fedoraproject.org/wiki/Features/SystemPythonExecutablesUseSystemPython

There's also a Fedora bug opened on this, and comments in there state that this
is a big priority for RHEL6:

https://bugzilla.redhat.com/show_bug.cgi?id=518994

For RHEL5, we've been instructed by Product Management to open bugs on a
package-by-package basis to address the problem.

In this case, switchdesk-gui in RHEL5 has at least one instance of a
python script containing #!/usr/bin/env python"
Comment 1 Ngo Than 2009-09-09 07:12:51 EDT
easy fix ->  +devel ack
Comment 3 RHEL Product and Program Management 2009-11-06 13:43:19 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 5 RHEL Product and Program Management 2010-08-09 14:13:38 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2011-01-11 15:04:18 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2011-01-12 10:12:14 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 11 RHEL Product and Program Management 2011-05-31 09:13:45 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 16 Petr Kovar 2011-09-06 10:34:53 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The shebang lines in Python executables have been changed to "#!/usr/bin/python" to ensure the Python interpreter installed in the system is used.
Comment 18 errata-xmlrpc 2011-09-14 15:24:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1295.html

Note You need to log in before you can comment on or make changes to this bug.