Bug 52145 - redhat-config-network crash
Summary: redhat-config-network crash
Status: CLOSED DUPLICATE of bug 59017
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: roswell
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-21 01:30 UTC by Ed McKenzie
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-26 14:47:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modules.conf (284 bytes, text/plain)
2001-08-21 01:30 UTC, Ed McKenzie
no flags Details

Description Ed McKenzie 2001-08-21 01:30:28 UTC
This happened after clicking the Apply button:

Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 354, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 238, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 249, in saveHardware
    hardwarelist.save()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 249, in save
    modules.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line
977, in write
    self[key] = self.vars[key]
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line
935, in __setitem__
    replace = key + ' ' + varname + ' ' + endofline
TypeError: illegal argument type for built-in operation

Comment 1 Ed McKenzie 2001-08-21 01:30:56 UTC
Created attachment 28594 [details]
modules.conf

Comment 2 Ed McKenzie 2001-08-21 02:15:17 UTC
Related to bug 52147

Comment 3 Trond Eivind Glomsrxd 2001-08-21 02:22:26 UTC
Please try the version at http://people.redhat.com/teg/neat/

Comment 4 Ed McKenzie 2001-08-21 02:39:08 UTC
I forgot to mention this happened on 0.7.3-1 from rawhide.  Do you still want me
to try the older version?

Comment 5 Trond Eivind Glomsrxd 2001-08-21 03:08:16 UTC
No, I thought you had the version from the public beta...

This needs fixing, though.

Comment 6 Glen Foster 2001-08-21 20:26:10 UTC
We (Red Hat) really need to fix this before next release.

Comment 7 Phil Knirsch 2001-08-23 11:17:19 UTC
I've just tried the latest version of rcn with the exact same modules.conf and
it works perfectly for me.

Do you have any other special things or out of the ordinary installs (e.g. hand
backed kernel, etc)?

If i can't reproduce the problem i can't fix it. The only thing i could do is to
blindly fix the Conf.py, but i don't think that this is the root of the problem,
only the symptom of some other problem somewhere else.

Read ya, Phil

Comment 8 Harald Hoyer 2002-06-26 14:47:39 UTC

*** This bug has been marked as a duplicate of 59017 ***


Note You need to log in before you can comment on or make changes to this bug.