Bug 521715 - [abrt] crash detected in NetworkManager-gnome-1:0.7.996-1.git20090826.fc12
Summary: [abrt] crash detected in NetworkManager-gnome-1:0.7.996-1.git20090826.fc12
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: rawhide
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c38d5fb99052cf9d0bf5aa601ba...
: 522276 523308 523310 525310 525312 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-07 22:31 UTC by Nikolay Vladimirov
Modified: 2009-11-03 02:57 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-03 02:57:37 UTC


Attachments (Terms of Use)
File: backtrace (2.98 KB, text/plain)
2009-09-07 22:31 UTC, Nikolay Vladimirov
no flags Details

Description Nikolay Vladimirov 2009-09-07 22:31:45 UTC
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Comment
-----
Clicked on a wireless network from the nm-applet

Additional information
======


Attached files
----
backtrace

cmdline
-----
nm-applet --sm-disable 


component
-----
NetworkManager


executable
-----
/usr/bin/nm-applet


kernel
-----
2.6.31-0.204.rc9.fc12.i686


package
-----
NetworkManager-gnome-1:0.7.996-1.git20090826.fc12


reason
-----
Process was terminated by signal 6

Comment 1 Nikolay Vladimirov 2009-09-07 22:31:47 UTC
Created attachment 360023 [details]
File: backtrace

Comment 2 Michal Nowak 2009-09-10 20:34:51 UTC
*** Bug 522276 has been marked as a duplicate of this bug. ***

Comment 3 Michal Nowak 2009-09-10 20:37:59 UTC
Beware the traceback you attach. "No symbol table info available." is not very useful one.

Dan: Here is bit more useful traceback https://bugzilla.redhat.com/attachment.cgi?id=360369 but the crash is really easy to be hit. Occurs in 1:2 cases when asked nm-applet to change WLAN.

Comment 4 Nikolay Vladimirov 2009-09-11 08:39:49 UTC
Sorry for the useless traceback I was in the middle of filling a mesa bug and I just clicked my way trough the automatic bug submission.

I can try to reproduce this tonight and get some usable traceback.

Comment 5 Sam 2009-09-19 17:25:12 UTC
ABRT says this is the bug I'm seeing. Here's my writeup:

Running the F12 Snapshot 3 LiveCD, I installed firmware for my WiFi card (with b43-fwcutter), waited a bit, hit Fn-F2 to enable WiFi, clicked the Network Manager applet in my notification area, clicked my WiFi network, and then the notification icon disappeared (and ABRT appeared).

I restarted nm-applet and was immediately prompted for my WPA key. WiFi now works fine.

For a while, I could reproduce this crash consistently by having Network Manager need a WiFi key. Connecting to an unencrypted WiFi network or my home network (which NM knows the WPA key to) worked fine, but trying to connect to a neighbor's encrypted WiFi network caused nm-applet to crash before I ever saw a prompt for a WPA key.

Now though (15 minutes later), everything seems to be working fine. The only things I've really done is close the ABRT window, and restart the ABRT daemon (hitting bug 518390)

ABRT says the cmdline was "nm-applet --sm-disable"; running nm-applet with or without the sm-disable switch has no effect.

NetworkManager-gnome-0.7.996-1.git20090826.fc12.x86_64
NetworkManager-0.7.996-1.git20090826.fc12.x86_64



I'd attach a backtrace, but the one ABRT is showing is full of "No symbol table info available" and I don't know how to get a better one. :-/

Comment 6 Niels Haase 2009-09-23 22:05:31 UTC
*** Bug 523308 has been marked as a duplicate of this bug. ***

Comment 7 Niels Haase 2009-09-23 22:05:39 UTC
*** Bug 523310 has been marked as a duplicate of this bug. ***

Comment 8 Niels Haase 2009-09-23 22:05:49 UTC
*** Bug 525310 has been marked as a duplicate of this bug. ***

Comment 9 Niels Haase 2009-09-23 22:05:57 UTC
*** Bug 525312 has been marked as a duplicate of this bug. ***

Comment 10 Sam 2009-10-22 00:27:06 UTC
This crash is fixed in F12 Beta.

NetworkManager-0.7.996-4.git20091002.fc12.x86_64
NetworkManager-gnome-0.7.996-4.git20091002.fc12.x86_64

Comment 11 Petr Herynk 2009-10-22 07:49:47 UTC
After start application announced missing part of NM and compiz doesnt work.

Comment 12 Tim Lauridsen 2009-10-22 11:48:27 UTC
I works for me to in F12 Beta


Note You need to log in before you can comment on or make changes to this bug.