Bug 518390 - Bugzilla plugin failed to report bug (cant resolve bugzilla.redhat.com)
Summary: Bugzilla plugin failed to report bug (cant resolve bugzilla.redhat.com)
Keywords:
Status: CLOSED DUPLICATE of bug 533589
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 524025 525996 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-20 08:50 UTC by Tim Waugh
Modified: 2015-02-01 22:48 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-10 10:10:47 UTC


Attachments (Terms of Use)
tarball containing full logs from a system where this was seen. (176.80 KB, application/octet-stream)
2009-10-25 16:06 UTC, Michael De La Rue
no flags Details

Description Tim Waugh 2009-08-20 08:50:14 UTC
Description of problem:
I just tried reporting a crash in pulseaudio-module-gconf and got this dialog:

Report done!
Bugzilla: CReporterBugzilla::Report(): CReporterBugzilla::Login(): Unable to transport XML to server and get XML response back.  libcurl failed to execute the HTTP POST transaction.  Couldn't resolve host 'bugzilla.redhat.com'
Logger: CPluginManager::GetPluginType():Plugin: 'Logger' is not registered

However, I can ping bugzilla.redhat.com without any problems.

Version-Release number of selected component (if applicable):
abrt-0.0.7.1-1.fc12.x86_64

How reproducible:
Tried twice, happened both times.

Comment 1 Michal Schmidt 2009-09-16 12:40:06 UTC
This happens quite often to me. I am not sure what exactly causes it. I use NetworkManager to connect to my wireless network at home and to access the Red Hat VPN. I think that changing the connection somehow confuses abrt. For example connecting and disconnecting from the VPN or losing and restoring the wireless connection. When abrt fails to resolve 'bugzilla.redhat.com', all other apps can connect without problems. It's of no use to try to submit a crash report from abrt-gui again and again. The only thing that makes abrt communicate with BZ again is
/etc/init.d/abrtd restart

Comment 2 Sam 2009-09-19 17:38:18 UTC
Michal's workaround (restart abrtd) worked for me. I booted the F12 snapshot 3 liveCD, installed WiFi card firmware, and saw ABRT in action when nm-applet crashed wheh connecting to my WiFi network. I hopped from network to network exploring the crash, then couldn't submit ABRT's report because of this bug.

abrt-0.0.8.5-1.fc12.x86_64
abrt-addon-ccpp-0.0.8.5-1.fc12.x86_64
abrt-addon-kerneloops-0.0.8.5-1.fc12.x86_64
abrt-addon-python-0.0.8.5-1.fc12.x86_64
abrt-desktop-0.0.8.5-1.fc12.x86_64
abrt-gui-0.0.8.5-1.fc12.x86_64
abrt-libs-0.0.8.5-1.fc12.x86_64
abrt-plugin-bugzilla-0.0.8.5-1.fc12.x86_64
abrt-plugin-kerneloopsreporter-0.0.8.5-1.fc12.x86_64
abrt-plugin-sqlite3-0.0.8.5-1.fc12.x86_64
libcurl-7.19.6-5.fc12.x86_64

Comment 3 Tim Lauridsen 2009-09-20 11:07:22 UTC
Having the same issue when booting the F12 snapshot (1,2,3) LiveCd (i686) and the nm-applet blows up, then trying to report it i get the error in #0.

I have configured the bugzilla plugin with my bugzilla login.

Comment 4 Jiri Moskovcak 2009-09-21 11:49:17 UTC
One really nasty workaround that works for me is to add:
209.132.176.231  bugzilla.redhat.com

into /etc/hosts.

Jirka

Comment 5 Denys Vlasenko 2009-10-06 13:27:58 UTC
*** Bug 524025 has been marked as a duplicate of this bug. ***

Comment 6 Denys Vlasenko 2009-10-06 13:29:08 UTC
I duped 524025. Apart from this bug, it mentions problems with # and space chars in passwords being problematic. This needs to be checked/fixed as well before this bug is closed.

Comment 7 Denys Vlasenko 2009-10-06 14:02:42 UTC
*** Bug 525996 has been marked as a duplicate of this bug. ***

Comment 8 Michael De La Rue 2009-10-25 16:06:59 UTC
Created attachment 366034 [details]
tarball containing full logs from a system where this was seen.

I had the same problem too:

CReporterBugzilla::Report(): CReporterBugzilla::CheckUUIDInBugzilla(): Unable to transport XML to server and get XML response back.  libcurl failed to execute the HTTP POST transaction.  Couldn't resolve host 'bugzilla.redhat.com'
CPluginManager::GetPluginType():Plugin: 'Logger' is not registered.

This was in a completely clean Fedora 12 Beta install in which the only changes were that a) I reused pre-existing logical voumes b) I installed development tools.  

In the attached tarball (michael-2009-10-24-fedora-test-record.tjz) complete set of /var/log/messages + install logs copied into /root.

It's nasty that if you don't know that the bug is in /var/cache somewhere it's not easy to get the contents out and report it.

Comment 9 Andy Lawrence 2009-10-31 17:46:47 UTC
Perhaps the same, I receive this error on every bug I attempt to report via abrt:

CReporterBugzilla::Report(): CReporterBugzilla::Login(): RPC respon
CPluginManager::GetPluginType():Plugin: 'Logger' is not registered

Can't find any good info in any log file:

Oct 31 13:37:53 localhost kernel: pulseaudio[1942]: segfault at ffffffff00bade78 ip 0000003a41675f52 sp 00007fffb76a3ac0 error 4 in libc-2.10.90.so[3a41600000+177000]
Oct 31 13:37:53 localhost abrtd: Directory 'ccpp-1257010673-1942' creation detected
Oct 31 13:37:53 localhost abrtd: Lock file '/var/cache/abrt/ccpp-1257010673-1942.lock' is locked by process 13729
Oct 31 13:37:53 localhost abrt: saved core dump of pid 1942 to /var/cache/abrt/ccpp-1257010673-1942/coredump
Oct 31 13:37:53 localhost rtkit-daemon[1795]: Sucessfully made thread 13732 of process 13732 (/usr/bin/pulseaudio) owned by '500' high priority at nice level -11.
Oct 31 13:37:53 localhost pulseaudio[13732]: pid.c: Stale PID file, overwriting.
Oct 31 13:37:53 localhost rtkit-daemon[1795]: Sucessfully made thread 13733 of process 13732 (/usr/bin/pulseaudio) owned by '500' RT at priority 5.
Oct 31 13:37:53 localhost rtkit-daemon[1795]: Sucessfully made thread 13734 of process 13732 (/usr/bin/pulseaudio) owned by '500' RT at priority 5.
Oct 31 13:37:53 localhost abrtd: Getting local universal unique identification...
Oct 31 13:37:55 localhost abrtd: New crash, saving...
Oct 31 13:37:58 localhost abrtd: Getting crash infos...
Oct 31 13:38:05 localhost abrtd: Creating report...
Oct 31 13:38:05 localhost abrtd: Getting module names, file names, build IDs from core file
Oct 31 13:38:05 localhost abrtd: Builting list of missing debuginfos
Oct 31 13:38:05 localhost abrtd: build_id:750091d13b4517926b771d87037932a91ee0c5c9 exists:1
Oct 31 13:38:05 localhost abrtd: All debuginfos are present, not installing debuginfo packages
Oct 31 13:38:07 localhost abrtd: Getting global universal unique identification...
Oct 31 13:38:07 localhost abrtd: Getting global universal unique identification...
Oct 31 13:38:18 localhost abrtd: Getting crash infos...
Oct 31 13:38:41 localhost abrtd: Creating report...
Oct 31 13:38:41 localhost abrtd: Getting global universal unique identification...
Oct 31 13:38:41 localhost abrtd: Getting global universal unique identification...
Oct 31 13:38:47 localhost abrtd: Getting crash infos...
Oct 31 13:40:15 localhost abrtd: Creating report...
Oct 31 13:40:15 localhost abrtd: Getting global universal unique identification...
Oct 31 13:40:15 localhost abrtd: Getting global universal unique identification...
Oct 31 13:43:14 localhost abrtd: Getting crash infos...
[root@garage ~]#

Comment 10 Andy Lawrence 2009-10-31 17:49:22 UTC
Forgot to add:

I am registered and am absolutely sure my user/pass is correct.

Comment 11 Nikola Pajkovsky 2009-11-10 10:10:47 UTC

*** This bug has been marked as a duplicate of bug 533589 ***


Note You need to log in before you can comment on or make changes to this bug.