Bug 521737 - KDE crashes and gets you back to the login screen with openchrome video driver
Summary: KDE crashes and gets you back to the login screen with openchrome video driver
Keywords:
Status: CLOSED DUPLICATE of bug 507600
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome
Version: 11
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Xavier Bachelot
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-08 02:25 UTC by Luis Felipe Marzagao
Modified: 2009-09-10 02:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 02:53:19 UTC


Attachments (Terms of Use)
xsession error log (8.10 KB, text/plain)
2009-09-08 02:25 UTC, Luis Felipe Marzagao
no flags Details

Description Luis Felipe Marzagao 2009-09-08 02:25:46 UTC
Created attachment 360029 [details]
xsession error log

Description of problem:

KDE starts but after some time goes back to the login screen. If I change the video driver to vesa, then it works.


Version-Release number of selected component (if applicable):

xorg-x11-drv-openchrome-0.2.903-10.fc11.x86_64


How reproducible:

Always.

Steps to Reproduce:
1. Install F11 on a computer with S3 UniChrome Pro video card.
2. Start KDE session.

  
Actual results:

KDE starts to load, but then gets you back to the login screen.


Expected results:

KDE should load correctly.


Additional info:

lscpi -v

00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
   Subsystem: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
   Flags: bus master, 66MHz, medium devsel, latency 8
   Memory at e8000000 (32-bit, prefetchable) [size=128M]
   Capabilities: <access denied>
   Kernel driver in use: agpgart-via

00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
   Flags: bus master, medium devsel, latency 0

00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
   Flags: bus master, medium devsel, latency 0

00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
   Flags: bus master, medium devsel, latency 0

00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
   Flags: bus master, medium devsel, latency 0

00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
   Flags: bus master, medium devsel, latency 0

00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge (prog-if 00 [Normal decode])
   Flags: bus master, 66MHz, medium devsel, latency 0
   Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
   I/O behind bridge: 0000b000-0000bfff
   Memory behind bridge: fb000000-fcffffff
   Prefetchable memory behind bridge: f4000000-f7ffffff
   Capabilities: <access denied>

00:08.0 Modem: Smart Link Ltd. SmartPCI2800 V.92 PCI Soft DFT (rev 02) (prog-if 00 [Generic])
   Subsystem: Aztech System Ltd Device 2800
   Flags: medium devsel, IRQ 11
   Memory at fa000000 (32-bit, prefetchable) [size=16M]
   Capabilities: <access denied>

00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80) (prog-if 8f [Master SecP SecO PriP PriO])
   Subsystem: Micro-Star International Co., Ltd. Device 7211
   Flags: bus master, medium devsel, latency 32, IRQ 11
   I/O ports at fc00 [size=8]
   I/O ports at f800 [size=4]
   I/O ports at f400 [size=8]
   I/O ports at f000 [size=4]
   I/O ports at ec00 [size=16]
   I/O ports at e800 [size=256]
   Capabilities: <access denied>
   Kernel driver in use: sata_via
   Kernel modules: sata_via

00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06) (prog-if 8a [Master SecP PriP])
   Subsystem: Micro-Star International Co., Ltd. Device 7211
   Flags: bus master, medium devsel, latency 32, IRQ 10
   [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [size=8]
   [virtual] Memory at 000003f0 (type 3, non-prefetchable) [size=1]
   [virtual] Memory at 00000170 (32-bit, non-prefetchable) [size=8]
   [virtual] Memory at 00000370 (type 3, non-prefetchable) [size=1]
   I/O ports at e400 [size=16]
   Capabilities: <access denied>
   Kernel driver in use: pata_via
   Kernel modules: pata_via

00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81) (prog-if 00 [UHCI])
   Subsystem: Micro-Star International Co., Ltd. Device 7211
   Flags: bus master, medium devsel, latency 32, IRQ 10
   I/O ports at e000 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81) (prog-if 00 [UHCI])
   Subsystem: Micro-Star International Co., Ltd. Device 7211
   Flags: bus master, medium devsel, latency 32, IRQ 10
   I/O ports at dc00 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81) (prog-if 00 [UHCI])
   Subsystem: Micro-Star International Co., Ltd. Device 7211
   Flags: bus master, medium devsel, latency 32, IRQ 11
   I/O ports at d800 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81) (prog-if 00 [UHCI])
   Subsystem: Micro-Star International Co., Ltd. Device 7211
   Flags: bus master, medium devsel, latency 32, IRQ 11
   I/O ports at d400 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86) (prog-if 20 [EHCI])
   Subsystem: Micro-Star International Co., Ltd. Device 7211
   Flags: bus master, medium devsel, latency 32, IRQ 10
   Memory at fdfff000 (32-bit, non-prefetchable) [size=256]
   Capabilities: <access denied>
   Kernel driver in use: ehci_hcd

00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
   Subsystem: VIA Technologies, Inc. DFI KT600-AL / Soltek SL-B9D-FGR Motherboard
   Flags: bus master, stepping, medium devsel, latency 0
   Capabilities: <access denied>
   Kernel modules: i2c-viapro

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
   Subsystem: Micro-Star International Co., Ltd. Device b010
   Flags: medium devsel, IRQ 10
   I/O ports at d000 [size=256]
   Capabilities: <access denied>
   Kernel driver in use: VIA 82xx Audio
   Kernel modules: snd-via82xx

00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
   Subsystem: Micro-Star International Co., Ltd. Device 7211
   Flags: bus master, stepping, medium devsel, latency 32, IRQ 10
   I/O ports at cc00 [size=256]
   Memory at fdffe000 (32-bit, non-prefetchable) [size=256]
   Capabilities: <access denied>
   Kernel driver in use: via-rhine
   Kernel modules: via-rhine

01:00.0 VGA compatible controller: VIA Technologies, Inc. CN700/P4M800 Pro/P4M800 CE/VN800 [S3 UniChrome Pro] (rev 01) (prog-if 00 [VGA controller])
   Subsystem: Micro-Star International Co., Ltd. Device 7211
   Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 10
   Memory at f4000000 (32-bit, prefetchable) [size=64M]
   Memory at fb000000 (32-bit, non-prefetchable) [size=16M]
   [virtual] Expansion ROM at fc000000 [disabled] [size=64K]
   Capabilities: <access denied>

Comment 1 Luis Felipe Marzagao 2009-09-10 02:53:19 UTC
This workaround has solved the problem:

https://bugzilla.redhat.com/show_bug.cgi?id=507600#c8

So I'm marking this bug duplicate as that one.

*** This bug has been marked as a duplicate of bug 507600 ***


Note You need to log in before you can comment on or make changes to this bug.