Bug 507600 - OPENCHROME:P4M800 Login Screen Reappears after Logging in successfully
OPENCHROME:P4M800 Login Screen Reappears after Logging in successfully
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
: Triaged
: 512105 521737 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 08:49 EDT by Makarand
Modified: 2010-12-05 01:48 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-05 01:48:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log file (46.48 KB, text/plain)
2009-06-24 09:17 EDT, Makarand
no flags Details
dmesg file (28.06 KB, text/plain)
2009-06-24 09:19 EDT, Makarand
no flags Details
Xsession file from /etc/X11/xdm (3.42 KB, text/plain)
2009-06-24 09:26 EDT, Makarand
no flags Details
my dmesg (23.86 KB, text/plain)
2009-06-27 18:42 EDT, Stefan Stanacar
no flags Details
my xorg.conf (1.90 KB, text/plain)
2009-06-27 18:42 EDT, Stefan Stanacar
no flags Details
Xorg.0.log with AIGLX off (56.86 KB, text/plain)
2009-06-27 18:43 EDT, Stefan Stanacar
no flags Details
Xorg.0.log for failing session (with AIGLX on in xorg.conf) (57.05 KB, text/plain)
2009-06-27 18:56 EDT, Stefan Stanacar
no flags Details

  None (edit)
Description Makarand 2009-06-23 08:49:29 EDT
Description of problem:
I downloaded the fedora 11 kde live cd. i booted it normally but its not reaching till the kde environment.
Login screen appears, when i login successfully the fedora progress bar starts and then it lends me back to the login screen, whats the problem?

My hardware config: 
Intel Pentium 4 CPU 2.80 Ghz.
MSI P4M800 Motherboard with 64MB of shared graphics memory.
784mb of RAM DDR1.
40GB harddisk.
Combo Drive.
Comment 1 Matěj Cepl 2009-06-23 13:53:59 EDT
That looks like Xorg crashing. Could you please attach to this bug your /var/log/Xorg.0.log and /var/log/dmesg from X session when you get back to xdm, please? Do you have /etc/X11/xorg.conf as well?

Thank you.
Comment 2 Makarand 2009-06-24 07:43:43 EDT
Thank you, Mestej Cepl for your precious reply.
I am attaching the files as u have mentioned.
I don't have /etc/X11/xorg.conf file.
Comment 3 Makarand 2009-06-24 09:17:32 EDT
Created attachment 349234 [details]
Xorg.0.log file
Comment 4 Makarand 2009-06-24 09:19:49 EDT
Created attachment 349236 [details]
dmesg file
Comment 5 Makarand 2009-06-24 09:26:01 EDT
Created attachment 349238 [details]
Xsession file from /etc/X11/xdm
Comment 6 Matěj Cepl 2009-06-27 10:16:47 EDT
I don't see anything suspicious. Pushing towards driver component.
Comment 7 Makarand 2009-06-27 13:17:04 EDT
I solved the problem as follows:
i logged into failsafe session.
Logged in as root at terminal by typing su.
I didn't had the xorg.conf file in /etc/X11 so i generated it by typing Xorg -configure :1
After typing this a new file will be generated called xorg.conf.new
copied it to the location /etc/X11 as xorg.conf
Then edited it by typing vi xorg.conf and pressed i for editing
changed the word openchrome to vesa were ever it was.
Pressed ESC Saved it by typing :wq
rebooted the machine and logged into KDE session mode and it worked.
Thanks all for the replies.
Comment 8 Stefan Stanacar 2009-06-27 18:38:40 EDT
I can confirm this. I use openchrome driver and disabling AIGLX in xorg.conf fixed the problem. I'm almost sure that the problem is related to the driver and AIGLX stuff.
Comment 9 Stefan Stanacar 2009-06-27 18:42:13 EDT
Created attachment 349677 [details]
my dmesg
Comment 10 Stefan Stanacar 2009-06-27 18:42:46 EDT
Created attachment 349678 [details]
my xorg.conf
Comment 11 Stefan Stanacar 2009-06-27 18:43:22 EDT
Created attachment 349679 [details]
Xorg.0.log with AIGLX off
Comment 12 Stefan Stanacar 2009-06-27 18:56:37 EDT
Created attachment 349680 [details]
Xorg.0.log for failing session (with AIGLX on in xorg.conf)
Comment 13 Makarand 2009-06-28 16:49:42 EDT
Yes it worked after turning off the ServerFlag AIGLX off.
Thanks blitz00 for clearing the exact problem.
I searched whole internet for this problem but couldn't find it.
So the problem is with the AIGLX Option, when it is turned off then only the kde session starts with openchrome driver.
For those not working also after turning off AIGLX use the vesa option, it also works fine. :D
Comment 14 Stefan Stanacar 2009-06-28 17:04:15 EDT
What's interesting is that KDE desktop effects work using XRender as compositing type, although with poor performance (acceptable if you are patient :)). Unfortunately enabling desktop effects is the only way to have a transparent panel :((.
Also this bug may be related to #473163 and #504307, although I may be wrong.
Comment 15 Xavier Bachelot 2009-07-01 15:02:28 EDT
Related to rhbz#473163, but definitely different from rhbz#504307.
Comment 16 Luis Felipe Marzagao 2009-09-09 22:53:19 EDT
*** Bug 521737 has been marked as a duplicate of this bug. ***
Comment 17 Matěj Cepl 2009-11-05 13:33:01 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 18 Stefan Stanacar 2009-11-19 17:05:32 EST
On my fully upgraded system this issue is still reproducible.
The version of the openchrome driver is xorg-x11-drv-openchrome-0.2.903-12.fc11.i586
Comment 19 Vedran Miletić 2009-11-28 04:18:52 EST
How about Fedora 12?
Comment 20 Stefan Stanacar 2009-11-28 09:20:29 EST
I recently upgraded to F12 and the issue is still reproducible.

xorg-x11-server-Xorg-1.7.1-7.fc12.i686
xorg-x11-drv-openchrome-0.2.904-1.fc12.i686

If it helps I can post again dmesg/xorg.conf/Xorg.log, but I doubt there is any difference that could help.
Comment 21 Peter Lister 2009-12-01 10:37:52 EST
Still reproducible in Fedora 12. I had been hoping to turn acceleration back on.

Workround is to turn off acceleration.

	Option	    "NoAccel" "True"

lspci -n:

01:00.0 0300: 1106:3344 (rev 01)

lspci -v: 

01:00.0 VGA compatible controller: VIA Technologies, Inc. CN700/P4M800 Pro/P4M800 CE/VN800 [S3 UniChrome Pro] (rev 01) (prog-if 00 [VGA controller])
	Subsystem: VIA Technologies, Inc. CN700/P4M800 Pro/P4M800 CE/VN800 [S3 UniChrome Pro]
	Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 10
	Memory at f4000000 (32-bit, prefetchable) [size=64M]
	Memory at fb000000 (32-bit, non-prefetchable) [size=16M]
	[virtual] Expansion ROM at fc000000 [disabled] [size=64K]
	Capabilities: [60] Power Management version 2
	Capabilities: [70] AGP version 3.0


xorg-x11-server-Xorg-1.7.1-7.fc12.i686
xorg-x11-drv-openchrome-0.2.904-1.fc12.i686
Comment 22 Stephen E Clark 2009-12-01 13:31:06 EST
As a workaround try adding:

Section "ServerFlags"
      Option  "AIGLX" "off"
EndSection

to your xorg.conf file and turn set "NoAccel" "False"

This worked for me.
Comment 23 Bartosz 2009-12-06 20:16:33 EST
Add the to the Section "Device" following lines:
Option "XAANoOffscreenPixmaps"
and check if it helps.

Try also set 16 bit depth and check if it helps


Attach the output of ~/.xsession-errors (with DRI and AIGLX enabled)?
Comment 24 Xavier Bachelot 2010-01-20 16:58:01 EST
*** Bug 512105 has been marked as a duplicate of this bug. ***
Comment 25 Matěj Cepl 2010-02-26 07:20:52 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 26 Matěj Cepl 2010-02-26 07:29:47 EST
Reporter, could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Notice, that this is an automatically filed comment for all bugs with hanging NEEDINFO for longer time; it is possible by quirks of bugzilla, that some bugs are in this state even though you have attached the required information; please, make a comment to this bug ... that we should see correctly; I am sorry for the bothering you in such case.]
Comment 27 Peter Lister 2010-02-26 09:39:02 EST
The more recent traffic Openchrome bug #340 answers the above questions (so I'll tick the box) and seems to confirm that the fault lies in the openchrome driver.

http://www.openchrome.org/trac/ticket/340

I have just upgraded FC12 to KDE 4.4.0, so I will test again to see if KDE now works around it, as suggested there.  If so, then this particular Fedora bug (i.e. KDE login fails) can probably be closed.

As the actual openchrome / X server crash is not yet resolved; can Fedora track the Openchrome bug?
Comment 28 Peter Lister 2010-03-06 07:53:56 EST
The bug is still present with KDE 4.4.0, despite the suggestion (on the openchrome bug) that there may be a KDE workaround.

Except... the first test worked; i.e. the first X restart & login after I re-enabled AIGLX with RC12 / KDE 4.4.0 resulted in a working KDE environment 3D acceleration, confirmed with glxgears. Compiz didn't work, possibly because I had some elements missing.

Trouble is - next login I was back to normal, with the X server crash at login.

No X server log of the one and only working session, sorry.

I'll try to pursue this with the openchrome people.
Comment 29 Bug Zapper 2010-11-04 07:01:09 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 30 Bug Zapper 2010-12-05 01:48:50 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.