Bug 521821 - Forward button not visible
Summary: Forward button not visible
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firstboot
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-08 12:55 UTC by Kamil Páral
Modified: 2009-10-26 20:52 UTC (History)
3 users (show)

Fixed In Version: firstboot-1.110-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-23 11:34:57 UTC


Attachments (Terms of Use)
post-installation dialog (25.67 KB, image/jpeg)
2009-09-08 12:55 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2009-09-08 12:55:32 UTC
Created attachment 360072 [details]
post-installation dialog

Description of problem:
I have a notebook with 1680x1050 screen with attached external LCD display with the same 1680x1050 resolution. During the installation both displays run at native resolution. The installation finishes fine and after reboot there is some post-installation dialog (see attachment dialog.jpg). In this dialog the Forward button (which should be in the lower right corner) is not visible - it is *under* the screen edge. Both displays are running full resolution and the displays are cloned - the same image is presented on notebook LCD and external LCD. The Forward button is not visible anywhere. The only solution is to poweroff the computer and boot again with the external LCD detached. After that the dialog is correctly shown - not cropped.

Version-Release number of selected component (if applicable):
Anaconda 12.20

How reproducible:
Always

Steps to Reproduce:
1. Have the same screen setup as described
2. Boot to post-installation dialog
  
Actual results:
Dialog is cropped.

Expected results:
Dialog is not cropped.

Additional info:

Comment 1 Adam Williamson 2009-10-14 18:50:04 UTC
this is related to 526836. depending on the strategy we choose, it could effectively be a dupe (same fix for both problems). for now, just noting the relationship.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Adam Williamson 2009-10-15 18:05:24 UTC
can you try the updated firstboot package mentioned at https://bugzilla.redhat.com/show_bug.cgi?id=526836#c4 ?

install it on a rawhide system, enable the firstboot service, change /etc/sysconfig/firstboot to YES, and reboot - it should go into firstboot, and you can see if it's fixed. you'll need to either run through the wizard again or boot to runlevel 3 to disable it once you're done testing.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Kamil Páral 2009-10-21 11:26:43 UTC
$ cat /etc/sysconfig/firstboot
RUN_FIRSTBOOT=YES

$ rpm -q firstboot
firstboot-1.110-1.fc12.x86_64

But on reboot it boots normally to GDM. What is wrong?

Comment 4 Adam Williamson 2009-10-21 22:47:09 UTC
you need to do 'chkconfig firstboot on' as well.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Kamil Páral 2009-10-23 11:34:57 UTC
Ok, it's fixed now. Now it displays blank black screen on notebook display and correctly sized firstboot dialog on external display. The desktop is in a stretched mode. I think it would be more reasonable to turn on mirror mode while on firstboot (because how do you know which display is the user looking on, the other is completely dark, also it has some other problems: bug #521803), but this particular issue is fixed.

Comment 6 Adam Williamson 2009-10-26 20:52:54 UTC
unfortunately enabling clone mode with a command line parameter is impossible, and having firstboot write its own private xorg.conf just to use cloning rather than spanning was considered too complex a solution. so this is what you get. :) thanks for confirming the fix.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.