Bug 521863 - Fix instances of #!/usr/bin/env python in java-1.4.2-gcj-compat-devel [NEEDINFO]
Summary: Fix instances of #!/usr/bin/env python in java-1.4.2-gcj-compat-devel
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: java-1.4.2-gcj-compat
Version: 5.4
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Rodney Russ
QA Contact: BaseOS QE
URL:
Whiteboard:
Depends On:
Blocks: 502912 590060 521940
TreeView+ depends on / blocked
 
Reported: 2009-09-08 14:50 UTC by Issue Tracker
Modified: 2014-06-02 13:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:00:43 UTC
pm-rhel: needinfo? (tao)


Attachments (Terms of Use)

Description Issue Tracker 2009-09-08 14:50:07 UTC
Escalated to Bugzilla from IssueTracker

Comment 1 Issue Tracker 2009-09-08 14:50:08 UTC
Event posted on 09-08-2009 10:48am EDT by kbaxley

There's a project underway in Fedora 12 to finally resolve the issues
with Red Hat including #!/usr/bin/env python in our python executables:

https://fedoraproject.org/wiki/Features/SystemPythonExecutablesUseSystemPython

There's also a Fedora bug opened on this, and comments in there state
that this is a big priority for RHEL6:

https://bugzilla.redhat.com/show_bug.cgi?id=518994

For RHEL5, we've been instructed by Product Management to open bugs on
a package-by-package basis to address the problem.

In this case, java-1.4.2-gcj-compat-devel in RHEL5 has at least one instance of a
python script containing #!/usr/bin/env python.  Here are some of the files in the package that contained this line:

# head -1 /usr/bin/aot-compile
#!/usr/bin/env python
# head -1 /usr/bin/aot-compile-rpm 
#!/usr/bin/env python

This event sent from IssueTracker by kbaxley  [LLNL (HPC)]
 issue 339808

Comment 3 RHEL Product and Program Management 2009-11-06 19:03:26 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 6 RHEL Product and Program Management 2010-08-09 19:05:46 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 9 RHEL Product and Program Management 2011-05-31 14:23:00 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 11 RHEL Product and Program Management 2013-07-24 04:18:17 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 12 RHEL Product and Program Management 2014-03-07 12:37:24 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 13 RHEL Product and Program Management 2014-06-02 13:00:43 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.