Bug 521892 - Fix instances of #!/usr/bin/env python in postresql-python
Fix instances of #!/usr/bin/env python in postresql-python
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: postgresql (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Tom Lane
qe-baseos-daemons
:
Depends On:
Blocks: 502912 590060 521940
  Show dependency treegraph
 
Reported: 2009-09-08 11:56 EDT by Issue Tracker
Modified: 2013-07-02 23:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-05 23:17:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2009-09-08 11:56:16 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2009-09-08 11:56:17 EDT
Event posted on 09-08-2009 11:54am EDT by kbaxley

There's a project underway in Fedora 12 to finally resolve the issues
with Red Hat including #!/usr/bin/env python in our python executables:

https://fedoraproject.org/wiki/Features/SystemPythonExecutablesUseSystemPython

There's also a Fedora bug opened on this, and comments in there state
that this is a big priority for RHEL6:

https://bugzilla.redhat.com/show_bug.cgi?id=518994

For RHEL5, we've been instructed by Product Management to open bugs on
a package-by-package basis to address the problem.

In this case, postgresql-python in RHEL5 has at least one instance of a
python script containing #!/usr/bin/env python.  

/usr/share/doc/postgresql-python-8.1.11/tutorial/advanced.py in postgresql-python-8.1.11-1.el5_1.1
/usr/share/doc/postgresql-python-8.1.11/tutorial/basics.py in postgresql-python-8.1.11-1.el5_1.1

/usr/lib64/python2.4/site-packages/pg.py in postgresql-python-8.1.11-1.el5_1.1
This event sent from IssueTracker by kbaxley  [LLNL (HPC)]
 issue 339885
Comment 2 Issue Tracker 2009-09-08 11:57:09 EDT
Event posted on 09-08-2009 11:57am EDT by kbaxley

also...

/usr/lib64/python2.4/site-packages/pgdb.py in
postgresql-python-8.1.11-1.el5_1.1



This event sent from IssueTracker by kbaxley 
 issue 339885
Comment 3 Tom Lane 2009-09-08 15:53:56 EDT
As far as I saw, the conclusions about this in the recent fedora-packaging discussion were (a) the issue is not clear enough to have a system-wide mandate, and (b) the form with env is mildly preferred anyhow.  Please explain why I should not close this NOTABUG.
Comment 5 Tom Lane 2009-09-08 16:37:47 EDT
As far as I can see, the discussion here rejected any standardization in this area:

https://www.redhat.com/archives/fedora-packaging/2009-July/msg00056.html

If there's been further discussion, or somebody has decided that Python deserves a special rule, please say where that took place.  My take on it is that if someone has gone so far as to install a private version of python, it's probably because they want to *use* that version of python.
Comment 6 Tom Lane 2009-09-08 16:44:22 EDT
Please note also that the Features page you cite is no better than draft status --- it has no owner, is zero percent complete (which at this point means it ain't happening in F-12), and based on the aforesaid mailing list discussion it's not clear it has any community consensus behind it anyway.
Comment 8 RHEL Product and Program Management 2009-11-06 13:57:32 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 10 RHEL Product and Program Management 2010-08-09 15:04:07 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 13 RHEL Product and Program Management 2011-05-31 10:19:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 15 Tom Lane 2013-03-05 23:17:10 EST
Closing as WONTFIX: given the lack of consensus on whether this is even a good idea, I can't see that we'll change these scripts in RHEL5.

Note You need to log in before you can comment on or make changes to this bug.