Bug 521897 - Fix instances of #!/usr/bin/env python in PyQt-examples
Fix instances of #!/usr/bin/env python in PyQt-examples
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: PyQt (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Ngo Than
desktop-bugs@redhat.com
:
Depends On:
Blocks: 502912 590060 521940
  Show dependency treegraph
 
Reported: 2009-09-08 12:06 EDT by Issue Tracker
Modified: 2013-04-12 16:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-27 08:29:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2009-09-08 12:06:01 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2009-09-08 12:06:03 EDT
Event posted on 09-08-2009 12:04pm EDT by kbaxley

There's a project underway in Fedora 12 to finally resolve the issues
with Red Hat including #!/usr/bin/env python in our python executables:

https://fedoraproject.org/wiki/Features/SystemPythonExecutablesUseSystemPython

There's also a Fedora bug opened on this, and comments in there state
that this is a big priority for RHEL6:

https://bugzilla.redhat.com/show_bug.cgi?id=518994

For RHEL5, we've been instructed by Product Management to open bugs on
a package-by-package basis to address the problem.

In this case, PyQt-examples in RHEL5 has at least one instance of a
python script containing #!/usr/bin/env python.  

(note, all the scripts that were found were in the "examples" directory, so, this can be a low-priority item):

/usr/share/doc/PyQt-examples-3.16/aclock.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tut1.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/drawlines.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/qdir.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tut14.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/checklists.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tut12.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/dirview.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/listbox.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/fontdisplayer.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tut8.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/progressbar.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tut5.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/addressbook.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tut11.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/dclock.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/application.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/dragdrop.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/biff.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tooltip.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tut10.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tablestatistics.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tut2.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/progress.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/buttongroups.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/semaphore.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/gears.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/splitter.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/qmag.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tut3.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/lineedits.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/rangecontrols.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/fonts.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/cursor.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/desktop.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/mdi.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tut4.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tabdialog.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/menu.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/richtext.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tut6.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/smalltable.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/listboxcombo.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tut7.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tut13.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/bigtable.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/widgets.py in PyQt-examples-3.16-4
/usr/share/doc/PyQt-examples-3.16/tut9.py in PyQt-examples-3.16-4

This event sent from IssueTracker by kbaxley  [LLNL (HPC)]
 issue 339897
Comment 3 RHEL Product and Program Management 2009-11-06 13:57:05 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 5 RHEL Product and Program Management 2010-08-09 15:02:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 RHEL Product and Program Management 2011-05-31 10:17:58 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 19 Phil Knirsch 2013-03-27 08:29:09 EDT
This request was evaluated by Red Hat Engineering for inclusion in a Red
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat Enterprise
Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in
response to customer and partner requirements, Red Hat takes a conservative
approach when evaluating enhancements for inclusion in maintenance updates
for currently deployed products. The primary objectives of update releases
are to enable new hardware platform support and to resolve critical
defects.

However, Red Hat will further review this request for potential inclusion
in future major releases of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.