Bug 522034 - X Server not even starting with KMS enabled on Radeon 4870
Summary: X Server not even starting with KMS enabled on Radeon 4870
Keywords:
Status: CLOSED DUPLICATE of bug 520030
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 08:49 UTC by Adam Kovari
Modified: 2009-09-09 10:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-09 10:26:59 UTC


Attachments (Terms of Use)

Description Adam Kovari 2009-09-09 08:49:25 UTC
Description of problem:
Test Day:2009-09-09 Radeon QA:Testcase_radeon_basic

If i enable radeon.modeset=1 as a kernel parameter i get high resolution during text boot, but when X server is supposed to start, it ends in black screen and nothing else can be done(not even switching to console works).

My another notice is, that radeon.modeset kernet parameter must be followed by a space. Therefore adding just "radeon.modeset=1" will make no use of KMS, but "radeon.modeset=1 " will actually enable KMS. And either way, there will be a message about unknown parameter and ignoring it.


Version-Release number of selected component (if applicable):
fedora live cd http://adamwill.fedorapeople.org/20090908_test_day_images/testday-20090908-x86_64.iso

How reproducible:

start fedora with radeon KMS enabled


Steps to Reproduce:
1. add "radeon.modeset=1 " to kernel line in grub
2.boot
3.no x server!
  
Actual results:

no x server!

Expected results:

x server running
Additional info:

Comment 1 Amit Shah 2009-09-09 10:26:59 UTC
Might be a duplicate of bug #520030

*** This bug has been marked as a duplicate of bug 520030 ***


Note You need to log in before you can comment on or make changes to this bug.