Bug 520030 - KMS:RV515M:X1400 backligth seems off (display goes blank on X startup with F12 Alpa)
Summary: KMS:RV515M:X1400 backligth seems off (display goes blank on X startup with F1...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 522034 522050 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-28 05:30 UTC by Amit Shah
Modified: 2018-04-11 10:24 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-13 10:47:35 UTC


Attachments (Terms of Use)
/var/log/messages (134.61 KB, text/plain)
2009-08-28 08:31 UTC, Amit Shah
no flags Details
Xorg.0.log (74.94 KB, text/plain)
2009-08-28 08:31 UTC, Amit Shah
no flags Details

Description Amit Shah 2009-08-28 05:30:16 UTC
Description of problem:
I have an r500 based X1400 Mobility chip on a ThinkPad X60. Trying out the F12-alpha LiveUSB the display goes blank immediately after selecting the 'boot' entry from grub.

Removing the quiet and rhgb parameters shows the kernel bootup messages. However, the display goes blank again when X is started.

The behaviour is the same with 'nomodeset=1'

(No logs; can't get to a console. Even with 'single')

Comment 1 Jérôme Glisse 2009-08-28 08:15:04 UTC
Can you try with radeon.modeset=0 instead of nomodeset=1

Comment 2 Amit Shah 2009-08-28 08:31:13 UTC
Created attachment 359024 [details]
/var/log/messages

radeon.modeset=0 works; gets me the startup bar and also X.

But it also shows

Unknown boot option `radeon.modeset=0': ignoring

Attaching /var/log/messages and Xorg.0.log

Comment 3 Amit Shah 2009-08-28 08:31:41 UTC
Created attachment 359025 [details]
Xorg.0.log

Comment 4 Amit Shah 2009-09-09 10:26:59 UTC
*** Bug 522034 has been marked as a duplicate of this bug. ***

Comment 5 Amit Shah 2009-09-09 10:27:57 UTC
*** Bug 522050 has been marked as a duplicate of this bug. ***

Comment 6 Amit Shah 2009-09-09 10:29:43 UTC
Tests from the F12 Radeon Test Day

https://fedoraproject.org/wiki/Test_Day:2009-09-09_Radeon

show that the LiveCD prepared for the test day too has this issue.

Comment 7 Adam Williamson 2009-11-01 22:37:33 UTC
can you re-try with a recent nightly image? http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/

there've been quite a few changes since the report was filed. thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 8 Amit Shah 2009-11-05 09:25:28 UTC
I tried with the beta image and the machine reboots in a short while after booting begins. Before that, the plymouth screen appears and instantly goes off, leaving an fb display with a blinking cursor.

Have there been changes since the beta-rc2 compose?

Comment 9 Adam Williamson 2009-11-05 09:32:14 UTC
since beta? yes, quite a lot. can't say if any of them would fix this but they can't hurt. please grab a nightly...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 10 Amit Shah 2009-11-05 14:31:13 UTC
Yay, with the 3 Nov nightly plymouth bootup + gnome desktop works fine!

Can the others who had the same problem report success/failure as well?

Comment 11 Matěj Cepl 2009-11-05 17:14:33 UTC
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages (at least F12Beta, but even better if the very latest versions).

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]

Comment 12 Adam Williamson 2009-11-05 19:25:00 UTC
Amit, no-one else posted in this bug that they are seeing the same problem, so if it works for you now we can close it. Thanks for testing!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 13 Jiri Moskovcak 2009-11-11 12:04:45 UTC
I just ran into this bug yesterday when testing RC4 on my laptop. I ended up with vesa driver, as radeon is not working for me either :(

the pc is:
Lenovo t60 with ati mobility X1400

Comment 14 Jiri Moskovcak 2009-11-11 12:21:30 UTC
I took a closer look to this and it seems that the problem is with the backlight, because I can see the grey gdm login screen. I tested it couple times and the problem is only with laptops LCD, if I connect an external monitor then it works fine (but only the external lcd). And when I put the laptop in the docking station, the backlight turns on.

Jirka

Comment 15 Jiri Moskovcak 2009-11-11 20:53:10 UTC
The docking station doesn't matter, it is the plugging/unplugging the power cord what turns on the backlight.

Jirka

Comment 16 Jindrich Novy 2009-11-12 12:28:40 UTC
Happens to me as well.

Comment 17 Jérôme Glisse 2009-11-12 13:32:08 UTC
Please everyone affected attach full dmesg and give the GPU you are using. Also gives output of :
rpm -q kernel xorg-x11-drv-ati xorg-x11-server-Xorg

Thanks

Comment 18 Jiri Moskovcak 2009-11-12 13:55:22 UTC
It seems I blame a wrong component here, I'm using radeonhd bacause xorg-x11-drv-ati was unstable and it kills my X - e.g. running chromium-browser kills X server every time. 
 I have these packages installed:

kernel-2.6.31.5-127.fc12.x86_64
xorg-x11-drv-ati-6.13.0-0.10.20091006git457646d73.fc12.x86_64
xorg-x11-server-Xorg-1.7.1-7.fc12.x86_64

Comment 19 Jérôme Glisse 2009-11-12 18:25:39 UTC
Jiri do you still get X endup being kill with this package when using xorg-x11-drv-ati with kernel modesetting activated (note that with radeonhd you can't have KMS enabled iirc)

Comment 20 Jiri Moskovcak 2009-11-13 09:26:19 UTC
I don't use KMS with neither of the drivers (do you think enabling KMS would fix the stability problem??). And yes, my X dies everytime I try to open newegg.com in firefox (I have flash installed) and the other 100% reliable reproducer is:

1. open thunderbird
2. right click on some folder->properities->Check this folder for new messsages
3. and X dies ...

Jirka

Comment 21 Jérôme Glisse 2009-11-13 10:47:35 UTC
Jiri i am closing this bug as the original reported don't have the issue anymore. Please test with KMS and if you have X crashing with KMS enabled please open a bug report for it. Otherwise we already have several bug against UMS (no kms) for firefox crashing the X server :
https://bugzilla.redhat.com/show_bug.cgi?id=528390
https://bugzilla.redhat.com/show_bug.cgi?id=536832
https://bugzilla.redhat.com/show_bug.cgi?id=534142
https://bugzilla.redhat.com/show_bug.cgi?id=533105

Which are likely all duplicate and you more than likely experiencing the same issue. Note also that we don't work actively on fixing UMS bugs are we do care a lot more about KMS. Out of curiosity why don't you use KMS ?


Note You need to log in before you can comment on or make changes to this bug.