Bug 52214 - Anaconda could use some more progress bars
Anaconda could use some more progress bars
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
: 54641 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-21 14:59 EDT by Pekka Pietikäinen
Modified: 2007-03-26 23:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 2001-08-21 14:59:24 EDT
There are still a few operations in anaconda, which take minutes to
complete that only display a dialog in the center of the screen, with no
progress  bar, making it look like the installer has hung. Checking
dependancies when doing upgrades is one of these.

For 8.0 a progress bar certainly would be nice for these, for 7.2 maybe a
"this may take a few minutes" text could be added (assuming the dialog is
not in the screenshots for the manual)
Comment 1 Michael Fulbright 2001-08-24 15:28:14 EDT
We will revisit this request next development cycle.
Comment 2 Michael Fulbright 2002-01-15 15:29:36 EST
*** Bug 54641 has been marked as a duplicate of this bug. ***
Comment 3 Michael Fulbright 2002-03-26 12:44:04 EST
Deferring to future release.
Comment 4 Jay R. Ashworth, http://baylink.pitas.com 2002-10-04 01:38:52 EDT
In addition to needing more thermometers, it would be nice if certain error 
dialogs had options other than "Ok; I give up; go ahead and crash".

Sometimes, the installer *can* make judgement calls about what's an acceptable 
thing to have to fix later.

Notably, anaconda in 7.3 does this on packages that can't be opened (no "Skip" 
button), lack of free space on a partition (you can clear some space on Alt-F2, 
but it has to completely re-do the dependency table -- which is depressing on a 
P266 laptop), and the bug I'm about to file: can't unmount disk 2: busy.

In general, anaconda seems to be poor at dealing with unexpected behavior 
during the install; "what could go wrong here" wasn't asked enough.  More in 
the other bug report.

Which I'll file tomorrow; the 17 hours it's cost me came out of sleep.


Zzzzzz.
Comment 5 Red Hat Bugzilla 2006-02-21 13:48:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.